summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-13 06:10:25 +0100
committerRemi Collet <remi@remirepo.net>2018-02-13 06:10:25 +0100
commiteeecaebc3dfc0b5377bcf2af9bb074d8ec3d5f40 (patch)
treed1b5a4e233c18763b68d4768c95d26c9c6cf68dd
parent338cff2a939062dd13d3db73c7ba5b9af05c1327 (diff)
v2.4.4
-rw-r--r--REFLECTION323
-rw-r--r--php-pecl-couchbase2.spec19
2 files changed, 329 insertions, 13 deletions
diff --git a/REFLECTION b/REFLECTION
index 39f1cbf..ad89ccc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #177 couchbase version 2.4.3 ] {
+Extension [ <persistent> extension #180 couchbase version 2.4.4 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -322,7 +322,7 @@ Extension [ <persistent> extension #177 couchbase version 2.4.3 ] {
}
}
- - Classes [47] {
+ - Classes [52] {
Class [ <internal:couchbase> class Couchbase\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -3294,6 +3294,325 @@ Extension [ <persistent> extension #177 couchbase version 2.4.3 ] {
}
}
}
+
+ Class [ <internal:couchbase> class Couchbase\SearchSort ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:couchbase> static public method id ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> static public method score ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> static public method field ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> static public method geoDistance ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:couchbase, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\SearchSortField extends Couchbase\SearchSort implements JsonSerializable ] {
+
+ - Constants [9] {
+ Constant [ public string TYPE_AUTO ] { auto }
+ Constant [ public string TYPE_STRING ] { string }
+ Constant [ public string TYPE_NUMBER ] { number }
+ Constant [ public string TYPE_DATE ] { date }
+ Constant [ public string MODE_DEFAULT ] { default }
+ Constant [ public string MODE_MIN ] { min }
+ Constant [ public string MODE_MAX ] { max }
+ Constant [ public string MISSING_FIRST ] { first }
+ Constant [ public string MISSING_LAST ] { last }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method id ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method score ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method field ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method geoDistance ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:couchbase, overwrites Couchbase\SearchSort, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> public method descending ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $descending ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method type ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method mode ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $mode ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method missing ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $missing ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\SearchSortGeoDistance extends Couchbase\SearchSort implements JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method id ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method score ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method field ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method geoDistance ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:couchbase, overwrites Couchbase\SearchSort, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> public method descending ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $descending ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method unit ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $missing ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\SearchSortId extends Couchbase\SearchSort implements JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method id ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method score ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method field ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method geoDistance ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:couchbase, overwrites Couchbase\SearchSort, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> public method descending ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $descending ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> class Couchbase\SearchSortScore extends Couchbase\SearchSort implements JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method id ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method score ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method field ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, inherits Couchbase\SearchSort> static public method geoDistance ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:couchbase, overwrites Couchbase\SearchSort, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> public method descending ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $descending ]
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index 610893d..fb8fe26 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -6,6 +6,10 @@
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-couchbase2
@@ -21,10 +25,9 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.4.3
+Version: 2.4.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-Group: Development/Languages
URL: http://pecl.php.net/package/couchbase
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
@@ -64,12 +67,6 @@ Conflicts: %{?scl_prefix}php-pecl-couchbase < 2
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php54-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name}2 <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php56u-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php56w-pecl-%{pecl_name}2 <= %{version}
%if "%{php_version}" > "7.0"
@@ -105,9 +102,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-# override the old PHP 4 metadata file
-[ -f package2.xml ] && mv package2.xml package.xml
-
mv %{pecl_name}-%{version}%{?prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
@@ -247,6 +241,9 @@ fi
%changelog
+* Tue Feb 13 2018 Remi Collet <remi@remirepo.net> - 2.4.4-1
+- Update to 2.4.4
+
* Fri Jan 5 2018 Remi Collet <remi@remirepo.net> - 2.4.3-1
- Update to 2.4.3
- raise dependency on libcouchbase 2.8.4