summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-01 08:10:09 +0200
committerRemi Collet <remi@remirepo.net>2017-06-01 08:10:09 +0200
commitd715c08f34d35c9ef5eaf4f829b9433aa884244a (patch)
treee67de381fc8211972f1b74c9f4d6ee5a4799bc9c
parent1712715b2cba6152540e6eab93004ebd00f9398f (diff)
v2.3.3
-rw-r--r--REFLECTION257
-rw-r--r--php-pecl-couchbase2.spec8
2 files changed, 257 insertions, 8 deletions
diff --git a/REFLECTION b/REFLECTION
index 5abd171..3b1ea6d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
+Extension [ <persistent> extension #166 couchbase version 2.3.3 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -26,7 +26,7 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
}
}
- - Constants [149] {
+ - Constants [150] {
Constant [ integer COUCHBASE_PERSISTTO_MASTER ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_ONE ] { 1 }
Constant [ integer COUCHBASE_PERSISTTO_TWO ] { 2 }
@@ -141,6 +141,7 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
Constant [ integer COUCHBASE_GENERIC_TMPERR ] { 80 }
Constant [ integer COUCHBASE_GENERIC_SUBDOCERR ] { 81 }
Constant [ integer COUCHBASE_GENERIC_CONSTRAINT_ERR ] { 82 }
+ Constant [ integer COUCHBASE_NAMESERVER_ERROR ] { 83 }
Constant [ integer COUCHBASE_TMPFAIL ] { 11 }
Constant [ integer COUCHBASE_KEYALREADYEXISTS ] { 12 }
Constant [ integer COUCHBASE_KEYNOTFOUND ] { 13 }
@@ -317,7 +318,7 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
}
}
- - Classes [43] {
+ - Classes [47] {
Class [ <internal:couchbase> class Couchbase\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -434,7 +435,7 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase, ctor> final public method __construct ] {
- Parameters [1] {
@@ -464,6 +465,14 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
Parameter #0 [ <required> $authenticator ]
}
}
+
+ Method [ <internal:couchbase> final public method authenticateAs ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $username ]
+ Parameter #1 [ <required> $password ]
+ }
+ }
}
}
@@ -481,7 +490,7 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [8] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -509,6 +518,27 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
}
}
+ Method [ <internal:couchbase> final public method listUsers ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final public method upsertUser ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $settings ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method removeUser ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
Method [ <internal:couchbase> final public method info ] {
- Parameters [0] {
@@ -517,6 +547,51 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
}
}
+ Class [ <internal:couchbase> final class Couchbase\UserSettings ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:couchbase, ctor> final public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final public method fullName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fullName ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method password ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $password ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method role ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $role ]
+ Parameter #1 [ <required> $bucket ]
+ }
+ }
+ }
+ }
+
Class [ <internal:couchbase> final class Couchbase\Bucket ] {
- Constants [0] {
@@ -1776,7 +1851,7 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
- Static properties [0] {
}
- - Static methods [20] {
+ - Static methods [23] {
Method [ <internal:couchbase> final static public method booleanField ] {
- Parameters [1] {
@@ -1884,6 +1959,31 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
}
}
+ Method [ <internal:couchbase> final static public method termRange ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final static public method geoBoundingBox ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $topLeftLongitude ]
+ Parameter #1 [ <required> $topLeftLatitude ]
+ Parameter #2 [ <required> $bottomRightLongitude ]
+ Parameter #3 [ <required> $bottomRightLatitude ]
+ }
+ }
+
+ Method [ <internal:couchbase> final static public method geoDistance ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $longitude ]
+ Parameter #1 [ <required> $latitude ]
+ Parameter #2 [ <required> $distance ]
+ }
+ }
+
Method [ <internal:couchbase> final static public method wildcard ] {
- Parameters [1] {
@@ -2328,6 +2428,92 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
}
}
+ Class [ <internal:couchbase> final class Couchbase\GeoBoundingBoxSearchQuery implements JsonSerializable, Couchbase\SearchQueryPart ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:couchbase, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final public method boost ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $boost ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method field ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $field ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:couchbase> final class Couchbase\GeoDistanceSearchQuery implements JsonSerializable, Couchbase\SearchQueryPart ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:couchbase, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final public method boost ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $boost ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method field ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $field ]
+ }
+ }
+ }
+ }
+
Class [ <internal:couchbase> final class Couchbase\MatchAllSearchQuery implements JsonSerializable, Couchbase\SearchQueryPart ] {
- Constants [0] {
@@ -2795,6 +2981,65 @@ Extension [ <persistent> extension #165 couchbase version 2.3.2 ] {
}
}
+ Class [ <internal:couchbase> final class Couchbase\TermRangeSearchQuery implements JsonSerializable, Couchbase\SearchQueryPart ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [6] {
+ Method [ <internal:couchbase, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase, prototype JsonSerializable> final public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> final public method boost ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $boost ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method field ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $field ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method min ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $min ]
+ Parameter #1 [ <required> $inclusive ]
+ }
+ }
+
+ Method [ <internal:couchbase> final public method max ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $max ]
+ Parameter #1 [ <required> $inclusive ]
+ }
+ }
+ }
+ }
+
Class [ <internal:couchbase> final class Couchbase\WildcardSearchQuery implements JsonSerializable, Couchbase\SearchQueryPart ] {
- Constants [0] {
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index c0b2c5d..261811b 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -27,7 +27,7 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.3.2
+Version: 2.3.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -38,7 +38,7 @@ BuildRequires: %{?scl_prefix}php-devel >= 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-json
-BuildRequires: pkgconfig(libcouchbase) >= 2.7.4
+BuildRequires: pkgconfig(libcouchbase) >= 2.7.5
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
@@ -254,6 +254,10 @@ fi
%changelog
+* Thu Jun 1 2017 Remi Collet <remi@remirepo.net> - 2.3.3-1
+- Update to 2.3.3
+- raise dependency on libcouchbase 2.7.5
+
* Tue May 2 2017 Remi Collet <remi@remirepo.net> - 2.3.2-1
- Update to 2.3.2