summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 19:50:41 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 19:50:41 +0200
commit705d4b5ecc8d96e59f20e0f1273d715113902396 (patch)
tree2acd6128d01b3da4ac527431a09a235053890aad
parent7f88cf05204887ac54feeec6ccfb03f711c3a816 (diff)
php-pecl-couchbase2: 2.2.0beta4
-rw-r--r--REFLECTION57
-rw-r--r--php-pecl-couchbase2-dev.spec23
2 files changed, 60 insertions, 20 deletions
diff --git a/REFLECTION b/REFLECTION
index 8a58a6e..345ff89 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
+Extension [ <persistent> extension #132 couchbase version 2.2.0beta4 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -132,8 +132,8 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
}
}
- - Classes [6] {
- Class [ <internal:couchbase> class CouchbaseException extends Exception ] {
+ - Classes [7] {
+ Class [ <internal:couchbase> class CouchbaseException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -152,7 +152,7 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -164,28 +164,28 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
@@ -201,11 +201,12 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> public $error ]
Property [ <default> public $value ]
Property [ <default> public $flags ]
Property [ <default> public $cas ]
+ Property [ <default> public $token ]
}
- Methods [0] {
@@ -223,10 +224,11 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [4] {
Property [ <default> public $error ]
Property [ <default> public $cas ]
Property [ <default> public $value ]
+ Property [ <default> public $token ]
}
- Methods [0] {
@@ -299,7 +301,7 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
- Properties [0] {
}
- - Methods [22] {
+ - Methods [23] {
Method [ <internal:couchbase, ctor> public method __construct ] {
}
@@ -342,6 +344,9 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
Method [ <internal:couchbase> public method http_request ] {
}
+ Method [ <internal:couchbase> public method fts_request ] {
+ }
+
Method [ <internal:couchbase> public method subdoc_request ] {
}
@@ -367,6 +372,28 @@ Extension [ <persistent> extension #196 couchbase version 2.2.0beta3 ] {
}
}
}
+
+ Class [ <internal:couchbase> class CouchbaseMutationToken ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> public $bucket ]
+ Property [ <default> public $vbucketID ]
+ Property [ <default> public $vbucketUUID ]
+ Property [ <default> public $sequenceNumber ]
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/php-pecl-couchbase2-dev.spec b/php-pecl-couchbase2-dev.spec
index 8e12067..4921422 100644
--- a/php-pecl-couchbase2-dev.spec
+++ b/php-pecl-couchbase2-dev.spec
@@ -6,8 +6,14 @@
#
# Please, preserve the changelog entries
#
-
-%{?scl: %scl_package php-pecl-couchbase2}
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%scl_package php-pecl-couchbase2
+%endif
%global pecl_name couchbase
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -19,12 +25,12 @@
# After 40-igbinary and 40-json
%global ini_name 50-%{pecl_name}.ini
%endif
-%global prever beta3
+%global prever beta4
Summary: Couchbase Server PHP extension
-Name: %{?scl_prefix}php-pecl-couchbase2
+Name: %{?sub_prefix}php-pecl-couchbase2
Version: 2.2.0
-Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: pecl.php.net/package/couchbase
@@ -79,6 +85,10 @@ Obsoletes: php56w-pecl-%{pecl_name}2 <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -228,6 +238,9 @@ fi
%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 2.2.0-0.3.beta4
+- Update to 2.2.0beta4 (php 5 and 7, beta)
+
* Thu May 26 2016 Remi Collet <remi@fedoraproject.org> - 2.2.0-0.2.beta3
- Update to 2.2.0beta3 (php 5 and 7, beta)