summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-05 14:00:42 +0200
committerRemi Collet <remi@remirepo.net>2017-10-05 14:00:42 +0200
commit6ecd8866cc7312d7aded918f9b808e05bb74529f (patch)
tree4bd9e99f5ff0c8a8db6afc25bfa5cadb54eb4ec3
parent8299a00e2e30c083d7c7057d2ed909d90cafce9a (diff)
v2.4.1
-rw-r--r--REFLECTION24
-rw-r--r--php-pecl-couchbase2.spec7
2 files changed, 20 insertions, 11 deletions
diff --git a/REFLECTION b/REFLECTION
index 939561f..6cd6566 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #171 couchbase version 2.4.0 ] {
+Extension [ <persistent> extension #173 couchbase version 2.4.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -24,6 +24,9 @@ Extension [ <persistent> extension #171 couchbase version 2.4.0 ] {
Entry [ couchbase.decoder.json_arrays <ALL> ]
Current = '0'
}
+ Entry [ couchbase.pool.max_idle_time_sec <ALL> ]
+ Current = '60'
+ }
}
- Constants [151] {
@@ -1552,19 +1555,12 @@ Extension [ <persistent> extension #171 couchbase version 2.4.0 ] {
Property [ <default> public $options ]
}
- - Methods [2] {
+ - Methods [1] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
}
}
-
- Method [ <internal:couchbase> final public method hostname ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $hostname ]
- }
- }
}
}
@@ -1726,7 +1722,7 @@ Extension [ <persistent> extension #171 couchbase version 2.4.0 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [5] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -1741,6 +1737,14 @@ Extension [ <persistent> extension #171 couchbase version 2.4.0 ] {
}
}
+ Method [ <internal:couchbase> final public method getCount ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $path ]
+ Parameter #1 [ <optional> $options ]
+ }
+ }
+
Method [ <internal:couchbase> final public method exists ] {
- Parameters [2] {
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index 8cdb4e5..421d47d 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -27,7 +27,7 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.4.0
+Version: 2.4.1
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -140,6 +140,7 @@ extension=%{pecl_name}.so
;couchbase.encoder.compression_threshold = 0
;couchbase.encoder.compression_factor = 0.0
;couchbase.decoder.json_arrays = 0
+;couchbase.pool.max_idle_time_sec = 60
EOF
%if 0%{?__ztsphp:1}
@@ -250,6 +251,10 @@ fi
%changelog
+* Thu Oct 5 2017 Remi Collet <remi@remirepo.net> - 2.4.1-1
+- Update to 2.4.1
+- update provided configuration for couchbase.pool.max_idle_time_sec
+
* Wed Sep 20 2017 Remi Collet <remi@remirepo.net> - 2.4.0-2
- rebuild with libcouchbase 2.8.1