summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-06 07:02:38 +0200
committerRemi Collet <remi@remirepo.net>2018-10-06 07:02:38 +0200
commit49c4aac3d42a13c3d7d9188736e633bc99671bf5 (patch)
tree641c8cf50fddb845a432b18afb5ebfa6e3efe1a3
parent29cc6aa5aa2b435961c3081e76b27895469a3037 (diff)
update to 2.6.0
raise dependency on libcouchbase 2.9.5
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION133
-rw-r--r--php-pecl-couchbase2.spec10
3 files changed, 137 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 7dc0511..02ac0c6 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
couchbase
couchbase support => enabled
-extension version => 2.5.0
-libcouchbase runtime version => 2.9.2 (git: 0f7cb6fe8b81c66273bfdab304d0f63bb4490377)
-libcouchbase headers version => 2.9.2 (git: 0f7cb6fe8b81c66273bfdab304d0f63bb4490377)
+extension version => 2.6.0
+libcouchbase runtime version => 2.9.5 (git: 2bf296af07b40e1b0163f900c4f8bf388ae4e8a3)
+libcouchbase headers version => 2.9.5 (git: 2bf296af07b40e1b0163f900c4f8bf388ae4e8a3)
igbinary transcoder => enabled
zlib compressor => enabled
diff --git a/REFLECTION b/REFLECTION
index 496e2d8..61b749d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
+Extension [ <persistent> extension #182 couchbase version 2.6.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -332,7 +332,7 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
}
}
- - Classes [54] {
+ - Classes [55] {
Class [ <internal:couchbase> class Couchbase\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -1053,7 +1053,7 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
- Properties [0] {
}
- - Methods [14] {
+ - Methods [15] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -1157,6 +1157,12 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
Parameter #2 [ <optional> $defer ]
}
}
+
+ Method [ <internal:couchbase> public method searchIndexManager ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -1663,12 +1669,34 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
Property [ <default> public $options ]
}
- - Methods [1] {
+ - Methods [4] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:couchbase> public method positionalParams ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $params ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method namedParams ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $params ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method rawParam ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
}
}
@@ -1699,7 +1727,7 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
Property [ <default> public $options ]
}
- - Methods [13] {
+ - Methods [14] {
Method [ <internal:couchbase, ctor> final private method __construct ] {
- Parameters [0] {
@@ -1789,6 +1817,14 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
Parameter #0 [ <required> $readonly ]
}
}
+
+ Method [ <internal:couchbase> public method rawParam ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
}
}
@@ -2275,7 +2311,7 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $style ]
- Parameter #1 [ <required> ...$(fields) ]
+ Parameter #1 [ <optional> ...$(fields) ]
}
}
@@ -3782,6 +3818,91 @@ Extension [ <persistent> extension #183 couchbase version 2.5.0 ] {
}
}
}
+
+ Class [ <internal:couchbase> class Couchbase\SearchIndexManager ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [10] {
+ Method [ <internal:couchbase, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> public method listIndexes ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> public method getIndex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method createIndex ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $indexDefinition ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method deleteIndex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method getIndexedDocumentsCount ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method listIndexDefinitions ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:couchbase> public method listIndexDefinition ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method getIndexDefinition ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:couchbase> public method getIndexedDocumentCount ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index bb81f5d..ce40ea7 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -25,8 +25,8 @@
Summary: Couchbase Server PHP extension
Name: %{?sub_prefix}php-pecl-couchbase2
-Version: 2.5.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.6.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/couchbase
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
@@ -37,7 +37,7 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-igbinary-devel
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-tokenizer
-BuildRequires: pkgconfig(libcouchbase) >= 2.9.2
+BuildRequires: pkgconfig(libcouchbase) >= 2.9.5
BuildRequires: fastlz-devel
BuildRequires: zlib-devel
@@ -246,6 +246,10 @@ fi
%changelog
+* Sat Oct 6 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on libcouchbase 2.9.5
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 2.5.0-3
- rebuild for 7.3.0beta2 new ABI