summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-03 07:15:01 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-03 07:15:01 +0100
commit447208ee6855baed73cdc4f23c46f63291272989 (patch)
tree60ed37d9bbd0006de6ef3abeb2f92a1b34ca6b56
parent497cf3d34850b164aa29823dc38e5146568e9d02 (diff)
php-pecl-couchbase2: 2.0.2
-rw-r--r--REFLECTION40
-rw-r--r--php-pecl-couchbase2.spec11
2 files changed, 28 insertions, 23 deletions
diff --git a/REFLECTION b/REFLECTION
index 1b47ec4..a62e827 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #16 couchbase version 2.0.1 ] {
+Extension [ <persistent> extension #169 couchbase version 2.0.2 ] {
- Constants [57] {
Constant [ integer COUCHBASE_PERSISTTO_MASTER ] { 1 }
@@ -80,7 +80,7 @@ Extension [ <persistent> extension #16 couchbase version 2.0.1 ] {
}
- Methods [9] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -115,7 +115,7 @@ Extension [ <persistent> extension #16 couchbase version 2.0.1 ] {
}
}
- Class [ <internal:couchbase> class _CouchbaseCluster ] {
+ Class [ <internal:couchbase> class CouchbaseMetaDoc ] {
- Constants [0] {
}
@@ -126,22 +126,18 @@ Extension [ <persistent> extension #16 couchbase version 2.0.1 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [4] {
+ Property [ <default> public $error ]
+ Property [ <default> public $value ]
+ Property [ <default> public $flags ]
+ Property [ <default> public $cas ]
}
- - Methods [3] {
- Method [ <internal:couchbase, ctor> public method __construct ] {
- }
-
- Method [ <internal:couchbase> public method connect ] {
- }
-
- Method [ <internal:couchbase> public method http_request ] {
- }
+ - Methods [0] {
}
}
- Class [ <internal:couchbase> class CouchbaseMetaDoc ] {
+ Class [ <internal:couchbase> class _CouchbaseCluster ] {
- Constants [0] {
}
@@ -152,14 +148,18 @@ Extension [ <persistent> extension #16 couchbase version 2.0.1 ] {
- Static methods [0] {
}
- - Properties [4] {
- Property [ <default> public $error ]
- Property [ <default> public $value ]
- Property [ <default> public $flags ]
- Property [ <default> public $cas ]
+ - Properties [0] {
}
- - Methods [0] {
+ - Methods [3] {
+ Method [ <internal:couchbase, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:couchbase> public method connect ] {
+ }
+
+ Method [ <internal:couchbase> public method http_request ] {
+ }
}
}
diff --git a/php-pecl-couchbase2.spec b/php-pecl-couchbase2.spec
index 5e90912..91df00b 100644
--- a/php-pecl-couchbase2.spec
+++ b/php-pecl-couchbase2.spec
@@ -25,7 +25,7 @@
Summary: Couchbase Server PHP extension
Name: %{?scl_prefix}php-pecl-couchbase2
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -35,6 +35,8 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?svnrev:-dev}.tg
BuildRequires: %{?scl_prefix}php-devel >= 5.3.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libcouchbase-devel
+# to ensure compatibility with XDebug
+BuildRequires: %{?scl_prefix}php-pecl-xdebug
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
@@ -52,8 +54,6 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
# Only 1 version can be installed
Conflicts: %{?scl_prefix}php-pecl-couchbase < 2
-# http://www.couchbase.com/issues/browse/PCBC-294
-Conflicts: %{?scl_prefix}php-pecl-xdebug
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -162,12 +162,14 @@ done
: minimal NTS load test
%{__php} -n \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ -d zend_extension=%{php_extdir}/xdebug.so \
-m | grep %{pecl_name}
%if %{with_zts}
: minimal ZTS load test
%{__ztsphp} -n \
-d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ -d zend_extension=%{php_ztsextdir}/xdebug.so \
-m | grep %{pecl_name}
%endif
@@ -199,6 +201,9 @@ fi
%changelog
+* Wed Dec 03 2014 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- Update to 2.0.2
+
* Wed Nov 05 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
- Update to 2.0.1