summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO7
-rw-r--r--REFLECTION9
-rw-r--r--php-pecl-cmark.spec34
3 files changed, 35 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..edf9438
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,7 @@
+
+cmark
+
+cmark support => enabled
+cmark extension version => 1.2.0
+libcmark headers version => 0.28.3
+libcmark library version => 0.28.3
diff --git a/REFLECTION b/REFLECTION
index 62f4ddf..0de05d9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 cmark version 1.1.0 ] {
+Extension [ <persistent> extension #83 cmark version 1.2.0 ] {
- Constants [13] {
Constant [ integer CommonMark\Node\Lists\Delimit\Period ] { 1 }
@@ -23,6 +23,7 @@ Extension [ <persistent> extension #79 cmark version 1.1.0 ] {
Parameter #0 [ <required> $content ]
Parameter #1 [ <optional> $options ]
}
+ - Return [ CommonMark\Node ]
}
Function [ <internal:cmark> function CommonMark\Render ] {
@@ -2047,12 +2048,14 @@ Extension [ <persistent> extension #79 cmark version 1.1.0 ] {
- Parameters [1] {
Parameter #0 [ <required> $buffer ]
}
+ - Return [ void ]
}
Method [ <internal:cmark> public method finish ] {
- Parameters [0] {
}
+ - Return [ CommonMark\Node ]
}
}
}
@@ -2074,7 +2077,8 @@ Extension [ <persistent> extension #79 cmark version 1.1.0 ] {
- Methods [3] {
Method [ <internal:cmark, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $cql ]
}
}
@@ -2090,6 +2094,7 @@ Extension [ <persistent> extension #79 cmark version 1.1.0 ] {
- Parameters [0] {
}
+ - Return [ void ]
}
}
}
diff --git a/php-pecl-cmark.spec b/php-pecl-cmark.spec
index a4c7b6f..67426e4 100644
--- a/php-pecl-cmark.spec
+++ b/php-pecl-cmark.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-cmark
#
-# Copyright (c) 2018 Remi Collet
+# Copyright (c) 2018-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -22,14 +22,14 @@
Summary: CommonMark extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.1.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
BuildRequires: cmark-devel >= 0.28
@@ -52,8 +52,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
@@ -63,9 +61,13 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -110,7 +112,7 @@ cp -pr NTS ZTS
# Create configuration file
cat << 'EOF' | tee %{ini_name}
; Enable %{summary}
-extension=%{pecl_name}.so
+extension=%{pecl_name}
EOF
@@ -160,9 +162,6 @@ done
%check
-export NO_INTERACTION=1
-export REPORT_EXIT_STATUS=1
-
: Minimal load test for NTS extension
cd NTS
%{__php} --no-php-ini \
@@ -171,7 +170,10 @@ cd NTS
%if %{with_tests}
: Upstream test suite
-make test
+REPORT_EXIT_STATUS=1 \
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+%{_bindir}/php -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
@@ -183,7 +185,10 @@ cd ../ZTS
%if %{with_tests}
: Upstream test suite
-make test
+REPORT_EXIT_STATUS=1 \
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
%endif
@@ -223,6 +228,9 @@ fi
%changelog
+* Mon May 27 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.1.0-3
- rebuild for 7.3.0beta2 new ABI