summaryrefslogtreecommitdiffstats
path: root/php-pecl-chdb.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-09 09:46:40 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-09 09:46:40 +0200
commitde9e63237ac578a4e6afb79f320a32089012bcba (patch)
treebea1a6c949de15da4ade0916679859d32f033250 /php-pecl-chdb.spec
php-pecl-chdb: 1.0.3 - New package
Diffstat (limited to 'php-pecl-chdb.spec')
-rw-r--r--php-pecl-chdb.spec179
1 files changed, 179 insertions, 0 deletions
diff --git a/php-pecl-chdb.spec b/php-pecl-chdb.spec
new file mode 100644
index 0000000..ac38582
--- /dev/null
+++ b/php-pecl-chdb.spec
@@ -0,0 +1,179 @@
+# spec file for php-pecl-chdb
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?php_inidir: %{expand: %%global php_inidir %{_sysconfdir}/php.d}}
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name chdb
+
+Summary: A fast database for constant data
+Name: php-pecl-%{pecl_name}
+Version: 1.0.3
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: php-devel
+BuildRequires: php-pear
+BuildRequires: cmph-devel
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires: php-spl%{?_isa}
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+
+%description
+CHDB (constant hash database) is a fast key-value database for constant data,
+realized by using a memory-mapped file and thus providing the following
+functionalities:
+- Extremely fast initial load, regardless of the size of the database.
+- Only the pages of the file which are actually used are loaded from the disk.
+- Once a page is loaded it is shared across multiple processes.
+- Loaded pages are cached across multiple requests and even process recycling.
+
+A typical use of CHDB is as a faster alternative to defining many PHP
+constants.
+
+CHDB is internally implemented as a hash-table using a perfect hashing
+function, thus guaranteeing worst case O(1) lookup time.
+
+
+%prep
+%setup -q -c -T
+# broken archive https://github.com/lcastelli/chdb/issues/5
+tar xif %{SOURCE0}
+
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+sed -e 's:/lib:/$PHP_LIBDIR:' \
+ -i config.m4
+
+# Fix version
+sed -e /PHP_CHDB_VERSION/s/1.0.1/%{version}/ -i php_chdb.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_CHDB_VERSION/{s/.* "//;s/".*$//;p}' php_chdb.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{pecl_name}.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+%endif
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{_bindir}/php --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+%{__ztsphp} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc NTS/{LICENSE,README}
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- initial package, version 1.0.3 (stable)
+- https://github.com/lcastelli/chdb/issues/5