summaryrefslogtreecommitdiffstats
path: root/php-pecl-bitset.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-bitset.spec')
-rw-r--r--php-pecl-bitset.spec34
1 files changed, 17 insertions, 17 deletions
diff --git a/php-pecl-bitset.spec b/php-pecl-bitset.spec
index 75c15e9..47a0e72 100644
--- a/php-pecl-bitset.spec
+++ b/php-pecl-bitset.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-bitset
#
-# Copyright (c) 2014-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2014-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -15,15 +15,12 @@
Summary: BITSET library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 3.0.1
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
-Group: Development/Languages
+Version: 3.2.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-php82.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -55,8 +52,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr14
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_BITSET_VERSION/{s/.* "//;s/".*$//;p}' php_bitset.h)
if test "x${extver}" != "x%{version}"; then
@@ -143,15 +138,14 @@ cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
@@ -159,15 +153,14 @@ cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with tests}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/zts-php -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
%endif
@@ -187,6 +180,13 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri May 26 2023 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+
+* Thu May 25 2023 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- drop patch merged upstream
+
* Fri Sep 9 2022 Remi Collet <remi@remirepo.net> - 3.0.1-6
- add patch for PHP 8.2 from
https://github.com/php/pecl-numbers-bitset/pull/14