summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION115
-rw-r--r--REFLECTION-PHP7164
-rw-r--r--php-pecl-bitset-php7.spec234
-rw-r--r--php-pecl-bitset.spec47
4 files changed, 26 insertions, 534 deletions
diff --git a/REFLECTION b/REFLECTION
index 7579eb0..0fad9a4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,117 +1,4 @@
-Extension [ <persistent> extension #80 bitset version 2.0.3 ] {
-
- - Functions {
- Function [ <internal:bitset> function bitset_empty ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $bitcount ]
- }
- }
- Function [ <internal:bitset> function bitset_incl ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> &$bitset ]
- Parameter #1 [ <required> $bit ]
- }
- }
- Function [ <internal:bitset> function bitset_excl ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> &$bitset ]
- Parameter #1 [ <required> $bit ]
- }
- }
- Function [ <internal:bitset> function bitset_in ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $bitset ]
- Parameter #1 [ <required> $bit ]
- }
- }
- Function [ <internal:bitset> function bitset_fill ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $bitcount ]
- }
- }
- Function [ <internal:bitset> function bitset_intersection ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $bitset1 ]
- Parameter #1 [ <required> $bitset2 ]
- }
- }
- Function [ <internal:bitset> function bitset_union ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $bitset1 ]
- Parameter #1 [ <required> $bitset2 ]
- }
- }
- Function [ <internal:bitset> function bitset_invert ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $bitset ]
- Parameter #1 [ <required> $size ]
- }
- }
- Function [ <internal:bitset> function bitset_subset ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $bitset1 ]
- Parameter #1 [ <required> $bitset2 ]
- }
- }
- Function [ <internal:bitset> function bitset_equal ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $bitset1 ]
- Parameter #1 [ <required> $bitset2 ]
- }
- }
- Function [ <internal:bitset> function bitset_to_string ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $bitset ]
- }
- }
- Function [ <internal:bitset> function bitset_from_string ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $source_str ]
- }
- }
- Function [ <internal:bitset> function bitset_to_hash ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $bitset ]
- }
- }
- Function [ <internal:bitset> function bitset_from_hash ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $bit_array ]
- }
- }
- Function [ <internal:bitset> function bitset_to_array ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $bitset ]
- }
- }
- Function [ <internal:bitset> function bitset_from_array ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $bit_array ]
- }
- }
- Function [ <internal:bitset> function bitset_is_empty ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $bitset ]
- }
- }
- }
+Extension [ <persistent> extension #60 bitset version 3.0.0 ] {
- Classes [1] {
Class [ <internal:bitset> class BitSet ] {
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index 0fad9a4..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,164 +0,0 @@
-Extension [ <persistent> extension #60 bitset version 3.0.0 ] {
-
- - Classes [1] {
- Class [ <internal:bitset> class BitSet ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [3] {
- Method [ <internal:bitset> static public method fromArray ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $arr ]
- }
- }
-
- Method [ <internal:bitset> static public method fromString ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $str ]
- }
- }
-
- Method [ <internal:bitset> static public method fromRawValue ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $str ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [20] {
- Method [ <internal:bitset, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $value ]
- }
- }
-
- Method [ <internal:bitset> public method andOp ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method andNotOp ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method cardinality ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method clear ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method get ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $index ]
- }
- }
-
- Method [ <internal:bitset> public method getRawValue ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method intersects ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method isEmpty ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method length ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method nextClearBit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method nextSetBit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method orOp ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method previousClearBit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method previousSetBit ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method set ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method size ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method toArray ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method xorOp ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:bitset> public method __toString ] {
-
- - Parameters [0] {
- }
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-bitset-php7.spec b/php-pecl-bitset-php7.spec
deleted file mode 100644
index 08f121c..0000000
--- a/php-pecl-bitset-php7.spec
+++ /dev/null
@@ -1,234 +0,0 @@
-# remirepo spec file for php-pecl-bitset
-#
-# Copyright (c) 2014-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl: %scl_package php-pecl-bitset}
-
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name bitset
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%global ini_name 40-%{pecl_name}.ini
-
-Summary: BITSET library
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 3.0.0
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Bitsets manipulation library.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-cd NTS
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_BITSET_VERSION/{s/.* "//;s/".*$//;p}' php_bitset.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-
-%install
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-cd NTS
-: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
-%endif
-
-%if %{with_zts}
-cd ../ZTS
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{_bindir}/zts-php -n run-tests.php --show-diff
-%endif
-%endif
-
-
-%files
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 3.0.0-4
-- rebuild for PHP 7.2.0beta1 new API
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-3
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-2
-- rebuild for PHP 7.1 new API version
-
-* Tue Mar 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
-- Update to 3.0.0 (php 7, beta)
-
-* Mon Feb 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
-- Update to 2.0.3
-
-* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
-- update to 2.0.2
-- drop runtime dependency on pear, new scriptlets
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1.1
-- Fedora 21 SCL mass rebuild
-
-* Fri Oct 31 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
-- initial package, version 2.0.1 (beta)
diff --git a/php-pecl-bitset.spec b/php-pecl-bitset.spec
index 5607727..08f121c 100644
--- a/php-pecl-bitset.spec
+++ b/php-pecl-bitset.spec
@@ -7,30 +7,22 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-bitset}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name bitset
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: BITSET library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.3
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.0.0
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -50,13 +42,19 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -121,8 +119,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -197,12 +193,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -217,6 +208,18 @@ rm -rf %{buildroot}
%changelog
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 3.0.0-4
+- rebuild for PHP 7.2.0beta1 new API
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-3
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-2
+- rebuild for PHP 7.1 new API version
+
+* Tue Mar 1 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- Update to 3.0.0 (php 7, beta)
+
* Mon Feb 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
- Update to 2.0.3