summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-10-31 13:45:18 +0100
committerRemi Collet <fedora@famillecollet.com>2014-10-31 13:45:18 +0100
commita1d6c05ba9d2c432ece004734375c12edca8e771 (patch)
tree1d52cebb77739ddedca83655370a35738340a674
php-pecl-bitset: 2.0.1 (beta) - new package
-rw-r--r--Makefile4
-rw-r--r--REFLECTION270
-rw-r--r--bitset-upstream.patch100
-rw-r--r--php-pecl-bitset.spec212
4 files changed, 586 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..cf0d1af
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,270 @@
+Extension [ <persistent> extension #77 bitset version 2.0.1 ] {
+
+ - Functions {
+ Function [ <internal:bitset> function bitset_empty ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $bitcount ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_incl ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$bitset ]
+ Parameter #1 [ <required> $bit ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_excl ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$bitset ]
+ Parameter #1 [ <required> $bit ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_in ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $bitset ]
+ Parameter #1 [ <required> $bit ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_fill ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bitcount ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_intersection ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $bitset1 ]
+ Parameter #1 [ <required> $bitset2 ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_union ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $bitset1 ]
+ Parameter #1 [ <required> $bitset2 ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_invert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $bitset ]
+ Parameter #1 [ <required> $size ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_subset ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $bitset1 ]
+ Parameter #1 [ <required> $bitset2 ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_equal ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $bitset1 ]
+ Parameter #1 [ <required> $bitset2 ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_to_string ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bitset ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_from_string ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $source_str ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_to_hash ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bitset ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_from_hash ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bit_array ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_to_array ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bitset ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_from_array ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bit_array ]
+ }
+ }
+ Function [ <internal:bitset> function bitset_is_empty ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $bitset ]
+ }
+ }
+ }
+
+ - Classes [1] {
+ Class [ <internal:bitset> class BitSet ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:bitset> static public method fromArray ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $arr ]
+ }
+ }
+
+ Method [ <internal:bitset> static public method fromString ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $str ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [20] {
+ Method [ <internal:bitset, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:bitset> public method andOp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method andNotOp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method cardinality ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method clear ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:bitset> public method getRawValue ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method intersects ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method isEmpty ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method length ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method nextClearBit ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method nextSetBit ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method orOp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method previousClearBit ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method previousSetBit ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method set ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method size ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method xorOp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:bitset> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/bitset-upstream.patch b/bitset-upstream.patch
new file mode 100644
index 0000000..4e69971
--- /dev/null
+++ b/bitset-upstream.patch
@@ -0,0 +1,100 @@
+From 27b7641d815e4279763e7716295f6169d1e3d5b7 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Fri, 31 Oct 2014 13:12:43 +0100
+Subject: [PATCH] Fix build with PHP < 5.4 (and min version set to 5.3)
+
+Tested against 5.3.3 (RHEL-6)
+---
+ bitset.c | 17 +++++++++++++++++
+ 1 file changed, 17 insertions(+)
+
+diff --git a/bitset.c b/bitset.c
+index 890a115..ba6fc34 100644
+--- a/bitset.c
++++ b/bitset.c
+@@ -31,6 +31,14 @@
+ #include "php_bitset.h"
+ #include <limits.h>
+
++/* For PHP < 5.3.7 */
++#ifndef PHP_FE_END
++#define PHP_FE_END { NULL, NULL, NULL }
++#endif
++#ifndef ZEND_MOD_END
++#define ZEND_MOD_END { NULL, NULL, NULL }
++#endif
++
+ #define BITSET_DEPRECATED_MESSAGE "The bitset_* functions are deprecated and will be removed in 3.0. Please update to the BitSet class API"
+
+ zend_class_entry *bitset_class_entry = NULL;
+@@ -963,7 +971,16 @@ static php_bitset_object *php_bitset_objects_new(zend_class_entry *ce TSRMLS_DC)
+ intern->bitset_val = 0;
+
+ zend_object_std_init(&intern->zo, ce TSRMLS_CC);
++#if PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION < 4
++ {
++ zval *tmp;
++
++ zend_hash_copy(intern->zo.properties, &ce->default_properties,
++ (copy_ctor_func_t) zval_add_ref, (void *) &tmp, sizeof(zval *));
++ }
++#else
+ object_properties_init(&intern->zo, ce);
++#endif
+
+ return intern;
+ }
+--
+2.1.0
+
+From 95ee02568e29dc2e51bb09a3397fdc2e101366ea Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Fri, 31 Oct 2014 13:16:46 +0100
+Subject: [PATCH] fix warning: variable 'previous_bit' set but not used
+ [-Wunused-but-set-variable]
+
+---
+ bitset.c | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/bitset.c b/bitset.c
+index ba6fc34..d858be4 100644
+--- a/bitset.c
++++ b/bitset.c
+@@ -606,7 +606,7 @@ PHP_METHOD(BitSet, orOp)
+ PHP_METHOD(BitSet, previousClearBit)
+ {
+ php_bitset_object *intern;
+- long start_bit = 0, previous_bit = 0;
++ long start_bit = 0;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &start_bit) == FAILURE) {
+ return;
+@@ -623,7 +623,6 @@ PHP_METHOD(BitSet, previousClearBit)
+
+ while (start_bit >= 0) {
+ if (!(intern->bitset_val[start_bit / CHAR_BIT] & (1 << (start_bit % CHAR_BIT)))) {
+- previous_bit = start_bit;
+ break;
+ }
+
+@@ -643,7 +642,7 @@ PHP_METHOD(BitSet, previousClearBit)
+ PHP_METHOD(BitSet, previousSetBit)
+ {
+ php_bitset_object *intern;
+- long start_bit = 0, previous_bit = 0;
++ long start_bit = 0;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &start_bit) == FAILURE) {
+ return;
+@@ -660,7 +659,6 @@ PHP_METHOD(BitSet, previousSetBit)
+
+ while (start_bit >= 0) {
+ if (intern->bitset_val[start_bit / CHAR_BIT] & (1 << (start_bit % CHAR_BIT))) {
+- previous_bit = start_bit;
+ break;
+ }
+
+--
+2.1.0
+
diff --git a/php-pecl-bitset.spec b/php-pecl-bitset.spec
new file mode 100644
index 0000000..c7bb463
--- /dev/null
+++ b/php-pecl-bitset.spec
@@ -0,0 +1,212 @@
+# spec file for php-pecl-bitset
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-bitset}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name bitset
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: BITSET library
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 2.0.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+Patch0: %{pecl_name}-upstream.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+Bitsets manipulation library.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' -i package.xml
+
+cd NTS
+%patch0 -p1 -b .upstream
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_BITSET_VERSION/{s/.* "//;s/".*$//;p}' php_bitset.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/zts-php -n run-tests.php --show-diff
+%endif
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_docdir}/%{pecl_name}
+%{?_licensedir:%license NTS/LICENSE}
+
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Fri Oct 31 2014 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- initial package, version 2.0.1 (beta) \ No newline at end of file