summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-29 20:02:12 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-29 20:02:12 +0100
commit0b3147c5bdeb0747510997f9d3c886335f2d8fa4 (patch)
tree57a5137e2d98d9e9bd205042706c051209677920
parentc5157e696bdc67e10db874022c1c2215c7516d61 (diff)
php-pecl-bitset: 2.0.3 (stable)
-rw-r--r--REFLECTION2
-rw-r--r--bitset-upstream.patch100
-rw-r--r--php-pecl-bitset.spec10
3 files changed, 6 insertions, 106 deletions
diff --git a/REFLECTION b/REFLECTION
index 4eea205..7579eb0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 bitset version 2.0.2 ] {
+Extension [ <persistent> extension #80 bitset version 2.0.3 ] {
- Functions {
Function [ <internal:bitset> function bitset_empty ] {
diff --git a/bitset-upstream.patch b/bitset-upstream.patch
deleted file mode 100644
index 4e69971..0000000
--- a/bitset-upstream.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 27b7641d815e4279763e7716295f6169d1e3d5b7 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Fri, 31 Oct 2014 13:12:43 +0100
-Subject: [PATCH] Fix build with PHP < 5.4 (and min version set to 5.3)
-
-Tested against 5.3.3 (RHEL-6)
----
- bitset.c | 17 +++++++++++++++++
- 1 file changed, 17 insertions(+)
-
-diff --git a/bitset.c b/bitset.c
-index 890a115..ba6fc34 100644
---- a/bitset.c
-+++ b/bitset.c
-@@ -31,6 +31,14 @@
- #include "php_bitset.h"
- #include <limits.h>
-
-+/* For PHP < 5.3.7 */
-+#ifndef PHP_FE_END
-+#define PHP_FE_END { NULL, NULL, NULL }
-+#endif
-+#ifndef ZEND_MOD_END
-+#define ZEND_MOD_END { NULL, NULL, NULL }
-+#endif
-+
- #define BITSET_DEPRECATED_MESSAGE "The bitset_* functions are deprecated and will be removed in 3.0. Please update to the BitSet class API"
-
- zend_class_entry *bitset_class_entry = NULL;
-@@ -963,7 +971,16 @@ static php_bitset_object *php_bitset_objects_new(zend_class_entry *ce TSRMLS_DC)
- intern->bitset_val = 0;
-
- zend_object_std_init(&intern->zo, ce TSRMLS_CC);
-+#if PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION < 4
-+ {
-+ zval *tmp;
-+
-+ zend_hash_copy(intern->zo.properties, &ce->default_properties,
-+ (copy_ctor_func_t) zval_add_ref, (void *) &tmp, sizeof(zval *));
-+ }
-+#else
- object_properties_init(&intern->zo, ce);
-+#endif
-
- return intern;
- }
---
-2.1.0
-
-From 95ee02568e29dc2e51bb09a3397fdc2e101366ea Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Fri, 31 Oct 2014 13:16:46 +0100
-Subject: [PATCH] fix warning: variable 'previous_bit' set but not used
- [-Wunused-but-set-variable]
-
----
- bitset.c | 6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/bitset.c b/bitset.c
-index ba6fc34..d858be4 100644
---- a/bitset.c
-+++ b/bitset.c
-@@ -606,7 +606,7 @@ PHP_METHOD(BitSet, orOp)
- PHP_METHOD(BitSet, previousClearBit)
- {
- php_bitset_object *intern;
-- long start_bit = 0, previous_bit = 0;
-+ long start_bit = 0;
-
- if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &start_bit) == FAILURE) {
- return;
-@@ -623,7 +623,6 @@ PHP_METHOD(BitSet, previousClearBit)
-
- while (start_bit >= 0) {
- if (!(intern->bitset_val[start_bit / CHAR_BIT] & (1 << (start_bit % CHAR_BIT)))) {
-- previous_bit = start_bit;
- break;
- }
-
-@@ -643,7 +642,7 @@ PHP_METHOD(BitSet, previousClearBit)
- PHP_METHOD(BitSet, previousSetBit)
- {
- php_bitset_object *intern;
-- long start_bit = 0, previous_bit = 0;
-+ long start_bit = 0;
-
- if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &start_bit) == FAILURE) {
- return;
-@@ -660,7 +659,6 @@ PHP_METHOD(BitSet, previousSetBit)
-
- while (start_bit >= 0) {
- if (intern->bitset_val[start_bit / CHAR_BIT] & (1 << (start_bit % CHAR_BIT))) {
-- previous_bit = start_bit;
- break;
- }
-
---
-2.1.0
-
diff --git a/php-pecl-bitset.spec b/php-pecl-bitset.spec
index b2cefd7..8fcab05 100644
--- a/php-pecl-bitset.spec
+++ b/php-pecl-bitset.spec
@@ -22,15 +22,13 @@
Summary: BITSET library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Version: 2.0.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Source1: https://raw.githubusercontent.com/php/pecl-numbers-bitset/master/LICENSE
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
@@ -85,7 +83,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-cp %{SOURCE1} LICENSE
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_BITSET_VERSION/{s/.* "//;s/".*$//;p}' php_bitset.h)
@@ -220,6 +217,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Feb 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
+- Update to 2.0.3
+
* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
- update to 2.0.2
- drop runtime dependency on pear, new scriptlets