summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-15 15:45:17 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-15 15:45:17 +0200
commit124d3f9b7048db41d494d1ef0feb573bc8052493 (patch)
treefacbe0a37c1cf67623ba643bd134202a473b5b79
parent69a05ccf9195336d948c28cc0eb716cde78ec23b (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-bbcode.spec23
1 files changed, 15 insertions, 8 deletions
diff --git a/php-pecl-bbcode.spec b/php-pecl-bbcode.spec
index 5da4278..898d64d 100644
--- a/php-pecl-bbcode.spec
+++ b/php-pecl-bbcode.spec
@@ -14,11 +14,16 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name bbcode
%global pre b1
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: BBCode parsing Extension
Name: %{?scl_prefix}php-pecl-bbcode
Version: 1.0.3
-Release: 0.4.%{pre}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.5.%{pre}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
# pecl extension is PHP, bbcode2 is BSD, bstrlib (from bstring) is BSD
License: PHP and BSD
Group: Development/Languages
@@ -87,7 +92,7 @@ if test "x${extver}" != "x%{version}%{?pre}"; then
fi
cd ..
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -120,7 +125,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
-install -Dpm 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -Dpm 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
mkdir -p %{buildroot}%{pecl_xmldir}
@@ -129,7 +134,7 @@ install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -190,17 +195,20 @@ fi
%defattr(-, root, root, -)
%doc %{pecl_testdir}/%{pecl_name}
%doc %{pecl_docdir}/%{pecl_name}
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Tue Apr 15 2014 Remi Collet <remi@fedoraproject.org> - 1.0.3-0.5.b1
+- add numerical prefix to extension configuration file
+
* Fri Nov 29 2013 Remi Collet <rcollet@redhat.com> - 1.0.3-0.4.b1
- adapt for SCL
@@ -217,5 +225,4 @@ fi
- build against php 5.4
* Wed Oct 05 2011 Remi Collet <remi@fedoraproject.org> 1.0.3-0.1.b1
-- initial RPM
-
+- initial RPM \ No newline at end of file