summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-27 12:09:57 +0200
committerRemi Collet <remi@php.net>2023-07-27 12:09:57 +0200
commitf2a97290ee283081501cfe88dd20858e19a43a74 (patch)
treeba96dd99229f83ad6ff29c34a7b79f0218b0fe3f
parent1b56c553de93d5b79d357f88efdcc8a01f1e9e44 (diff)
update to 1.2.2
buld out of sources tree
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-awscrt.spec58
3 files changed, 31 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index ba6093b..56f7d48 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
awscrt
-Version => 1.2.1
+Version => 1.2.2
Directive => Local Value => Master Value
awscrt.log_level => no value => no value
diff --git a/REFLECTION b/REFLECTION
index 3518129..df8f26f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 awscrt version 1.2.1 ] {
+Extension [ <persistent> extension #124 awscrt version 1.2.2 ] {
- INI {
Entry [ awscrt.log_level <ALL> ]
diff --git a/php-pecl-awscrt.spec b/php-pecl-awscrt.spec
index 3a34bb6..a51349b 100644
--- a/php-pecl-awscrt.spec
+++ b/php-pecl-awscrt.spec
@@ -9,32 +9,30 @@
# TODO unsuitable for Fedora with tons of bundled lib
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-pecl-awscrt}
+
+# For PHP < 5.6 and EPEL-9
+%{!?__phpize: %global __phpize %{_bindir}/phpize}
+%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
+%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
+%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
-%if 0%{?scl:1}
-%scl_package php-pecl-awscrt
-%else
-%global _root_prefix %{_prefix}
-%endif
# not wanted for now
%global with_zts 0
%global pecl_name awscrt
%global ini_name 40-%{pecl_name}.ini
-
-# commit is used only if tag is missing
-%global gh_commit 3f77a01fbfa8ca9fb5469743fe6c4abf6ccb6bcc
-#global gh_tag v1.0.1
-%global gh_owner awslabs
-%global gh_project aws-crt-php
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: AWS Common Runtime PHP bindings
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: Apache-2.0
+# extension is Apache-2.0
+# see LICENSE* for rust libraries
+License: Apache-2.0 AND MIT AND BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
%if 0%{?rhel} == 7 && 0%{?dtsversion} == 0
BuildRequires: devtoolset-6-toolchain
@@ -66,7 +64,6 @@ Provides: bundled(libaws-c-common)
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -94,9 +91,7 @@ sed -e 's/role="test"/role="src"/' \
-e '/"README.md"/s/role="src"/role="doc"/'\
-i package.xml
-mv %{pecl_name}-%{version} NTS
-
-pushd NTS
+pushd %{sources}
# Parallel build
sed -e '/(CMAKE_BUILD)/s/$/ --verbose %{?_smp_mflags}/' -i Makefile.frag
@@ -105,9 +100,9 @@ sed -e 's/-Werror//' \
-i crt/aws-crt-ffi/crt/*/CMakeLists.txt
popd
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -129,21 +124,22 @@ source /opt/%{scl_vendor}/%{scl}/enable
export PHP_RPATH=no
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-awscrt \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-awscrt \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -169,7 +165,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -208,7 +204,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -222,6 +218,10 @@ fi
%changelog
+* Thu Jul 27 2023 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+- buld out of sources tree
+
* Wed Mar 29 2023 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1
- drop patch merged upstream