summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-23 15:17:46 +0200
committerRemi Collet <remi@remirepo.net>2021-06-23 15:17:46 +0200
commitb82acd8fac0fcc1fd01330805eb0185cb873f6fd (patch)
treeffe20a4ea160885cd9a50c753671644f53a2bdc0
New package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO1
-rw-r--r--REFLECTION391
-rw-r--r--awscrt-build.patch11
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-pecl-awscrt.spec233
7 files changed, 677 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..218cc9a
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1 @@
+awscrt
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..144f5d8
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,391 @@
+Extension [ <persistent> extension #68 awscrt version <no_version> ] {
+
+ - INI {
+ Entry [ awscrt.log_level <ALL> ]
+ Current = ''
+ }
+ }
+
+ - Functions {
+ Function [ <internal:awscrt> function aws_crt_last_error ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_error_name ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_code ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_error_str ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_code ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_error_debug_str ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_code ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_event_loop_group_options_new ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_event_loop_group_options_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $elg_options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_event_loop_group_options_set_max_threads ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $elg_options ]
+ Parameter #1 [ <required> $max_threads ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_event_loop_group_new ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_event_loop_group_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $event_loop_group ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_options_new ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_options_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_options_set_user_data ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $user_data ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_new ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $stream ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_seek ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $stream ]
+ Parameter #1 [ <required> $offset ]
+ Parameter #2 [ <required> $basis ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_read ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $stream ]
+ Parameter #1 [ <required> $length ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_eof ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $stream ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_input_stream_get_length ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $stream ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_http_message_new_from_blob ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $blob ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_http_message_to_blob ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $message ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_http_message_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $message ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_options_new ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_options_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_options_set_access_key_id ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $access_key_id ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_options_set_secret_access_key ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $secret_access_key ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_options_set_session_token ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $session_token ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_options_set_expiration_timepoint_seconds ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $expiration_timepoint_seconds ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_new ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $credentials ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_provider_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $credentials ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_provider_static_options_new ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_provider_static_options_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_provider_static_options_set_access_key_id ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $access_key_id ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_provider_static_options_set_secret_access_key ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $secret_access_key ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_provider_static_options_set_session_token ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $options ]
+ Parameter #1 [ <required> $session_token ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_credentials_provider_static_new ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $options ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_new ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $config ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_algorithm ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $algorithm ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_signature_type ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $signature_type ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_credentials_provider ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $credentials_provider ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_region ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $region ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_service ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $service ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_use_double_uri_encode ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $use_double_uri_encode ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_should_normalize_uri_path ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $should_normalize_uri_path ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_omit_session_token ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $omit_session_token ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_signed_body_value ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $signed_body_value ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_signed_body_header_type ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $signed_body_header_type ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_expiration_in_seconds ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $expiration_in_seconds ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_date ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $timestamp ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signable_new_from_http_request ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $http_message ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signable_new_from_chunk ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $input_stream ]
+ Parameter #1 [ <required> $previous_signature ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signable_new_from_canonical_request ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $request ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signable_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $signable ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_result_release ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $signing_result ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_signing_result_apply_to_http_request ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $signing_result ]
+ Parameter #1 [ <required> $http_request ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_sign_request_aws ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $signable ]
+ Parameter #1 [ <required> $signing_config ]
+ Parameter #2 [ <required> $on_complete ]
+ Parameter #3 [ <required> $user_data ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_crc32 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $input ]
+ Parameter #1 [ <required> $prev ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_crc32c ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $input ]
+ Parameter #1 [ <required> $prev ]
+ }
+ }
+ }
+}
+
diff --git a/awscrt-build.patch b/awscrt-build.patch
new file mode 100644
index 0000000..e82c5ac
--- /dev/null
+++ b/awscrt-build.patch
@@ -0,0 +1,11 @@
+diff -up aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c.old aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c
+--- aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c.old 2021-06-23 14:05:19.531147607 +0200
++++ aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c 2021-06-23 14:05:56.792059326 +0200
+@@ -63,6 +63,7 @@
+ #include "internal.h"
+ #include "../../internal.h"
+
++# pragma GCC diagnostic ignored "-Wstringop-overflow"
+
+ int SHA224_Init(SHA256_CTX *sha) {
+ OPENSSL_memset(sha, 0, sizeof(SHA256_CTX));
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4406870
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+if [ -f $NAME-$VERSION.tgz ]; then
+ echo Skip $NAME-$VERSION.tgz
+else
+ echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+ echo "Cloning..."
+ rm -rf $PROJECT-$COMMIT
+ git clone --recursive --branch v$VERSION https://github.com/$OWNER/$PROJECT.git $PROJECT-$VERSION
+
+ echo "Archiving..."
+ tar czf $NAME-$VERSION.tgz --exclude .git $PROJECT-$VERSION
+
+ echo "Cleaning..."
+ rm -rf $PROJECT-$VERSION
+
+ echo "Done."
+fi
+
+spectool -g -S *spec
+
diff --git a/php-pecl-awscrt.spec b/php-pecl-awscrt.spec
new file mode 100644
index 0000000..f26875a
--- /dev/null
+++ b/php-pecl-awscrt.spec
@@ -0,0 +1,233 @@
+# remirepo spec file for php-pecl-awscrt
+#
+# Copyright (c) 2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# TODO unsuitable for Fedora with tons of bundled lib
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%scl_package php-pecl-awscrt
+%else
+%global _root_prefix %{_prefix}
+%endif
+# not wanted for now
+%global with_zts 0
+%global pecl_name awscrt
+%global ini_name 40-%{pecl_name}.ini
+
+%global gh_tag v1.0.0
+%global gh_owner awslabs
+%global gh_project aws-crt-php
+
+Summary: AWS Common Runtime PHP bindings
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: ASL 2.0
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# recursive git clone
+Source1: php-pecl-%{pecl_name}-%{version}.tgz
+Source2: makesrc.sh
+
+# Workaround for https://github.com/awslabs/aws-crt-php/issues/35
+Patch0: %{pecl_name}-build.patch
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
+BuildRequires: %{?scl_prefix}php-cli
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: openssl-devel
+%if 0%{?rhel} == 7
+BuildRequires: cmake3
+%else
+BuildRequires: cmake
+%endif
+
+# List from config.m4
+Provides: bundled(libaws-crt-ffi)
+Provides: bundled(libaws-c-auth)
+Provides: bundled(libaws-c-http)
+Provides: bundled(libaws-c-io)
+Provides: bundled(libaws-c-cal)
+Provides: bundled(libaws-c-compression)
+Provides: bundled(libaws-checksums)
+Provides: bundled(libaws-c-common)
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+
+%description
+AWS Common Runtime provides a set of low level tools as network protocols and
+authentication used by the AWSSDK for PHP to provide high level API to access
+AWS services.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c -a1
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ -e 's/role="doc"/role="src"/' \
+ %{!?_licensedir:-e '/LICENSE/s/role="src"/role="doc"/' } \
+ -e '/md"/s/role="src"/role="doc"/'\
+ -i package.xml
+
+mv %{pecl_name}-%{version} NTS
+ln -s ../%{gh_project}-%{version}/crt NTS/crt
+
+pushd %{gh_project}-%{version}
+# Workaround for https://github.com/awslabs/aws-crt-php/issues/35
+sed -e 's/-Werror//' \
+ -i crt/aws-crt-ffi/crt/*/CMakeLists.txt
+
+%patch0 -p1
+popd
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension=%{pecl_name}.so
+
+: Configuration
+;awscrt.log_level = ''
+EOF
+
+
+%build
+%{?dtsenable}
+%if 0%{?scl:1}
+# make invokes php command
+source /opt/%{scl_vendor}/%{scl}/enable
+%endif
+
+export PHP_RPATH=no
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-awscrt \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-awscrt \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS \
+ install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS \
+ install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+# Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_zts}
+# Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Wed Jun 23 2021 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0 (devel)