summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 07:34:45 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 07:34:45 +0200
commit5c7fd837b3a8e51eb4776a136828f96ea2a4a40e (patch)
tree09ec3c77dedbf9f24b4fee422e67f929e08c83a7
parente4320af2e8c8adc99140a83f20c9f06628522f89 (diff)
update to 1.0.7
-rw-r--r--REFLECTION59
-rw-r--r--awscrt-build.patch11
-rwxr-xr-xmakesrc.sh37
-rw-r--r--php-pecl-awscrt.spec23
4 files changed, 66 insertions, 64 deletions
diff --git a/REFLECTION b/REFLECTION
index 144f5d8..3271e13 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #68 awscrt version <no_version> ] {
+Extension [ <persistent> extension #70 awscrt version <no_version> ] {
- INI {
Entry [ awscrt.log_level <ALL> ]
@@ -30,6 +30,45 @@ Extension [ <persistent> extension #68 awscrt version <no_version> ] {
Parameter #0 [ <required> $error_code ]
}
}
+ Function [ <internal:awscrt> function aws_crt_log_to_stdout ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_log_to_stderr ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_log_to_file ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $filename ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_log_to_stream ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $stream ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_log_stop ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_log_set_level ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $level ]
+ }
+ }
+ Function [ <internal:awscrt> function aws_crt_log_message ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $message ]
+ }
+ }
Function [ <internal:awscrt> function aws_crt_event_loop_group_options_new ] {
- Parameters [0] {
@@ -325,6 +364,13 @@ Extension [ <persistent> extension #68 awscrt version <no_version> ] {
Parameter #1 [ <required> $timestamp ]
}
}
+ Function [ <internal:awscrt> function aws_crt_signing_config_aws_set_should_sign_header_fn ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <required> $should_sign_header ]
+ }
+ }
Function [ <internal:awscrt> function aws_crt_signable_new_from_http_request ] {
- Parameters [1] {
@@ -372,6 +418,17 @@ Extension [ <persistent> extension #68 awscrt version <no_version> ] {
Parameter #3 [ <required> $user_data ]
}
}
+ Function [ <internal:awscrt> function aws_crt_test_verify_sigv4a_signing ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $signable ]
+ Parameter #1 [ <required> $signing_config ]
+ Parameter #2 [ <required> $expected_canonical_request ]
+ Parameter #3 [ <required> $signature ]
+ Parameter #4 [ <required> $ecc_key_pub_x ]
+ Parameter #5 [ <required> $ecc_key_pub_y ]
+ }
+ }
Function [ <internal:awscrt> function aws_crt_crc32 ] {
- Parameters [2] {
diff --git a/awscrt-build.patch b/awscrt-build.patch
deleted file mode 100644
index e82c5ac..0000000
--- a/awscrt-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -up aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c.old aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c
---- aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c.old 2021-06-23 14:05:19.531147607 +0200
-+++ aws-crt-php-1.0.0/crt/aws-crt-ffi/crt/aws-lc/crypto/fipsmodule/sha/sha256.c 2021-06-23 14:05:56.792059326 +0200
-@@ -63,6 +63,7 @@
- #include "internal.h"
- #include "../../internal.h"
-
-+# pragma GCC diagnostic ignored "-Wstringop-overflow"
-
- int SHA224_Init(SHA256_CTX *sha) {
- OPENSSL_memset(sha, 0, sizeof(SHA256_CTX));
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index 87afb43..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
-TAG=$(sed -n '/^%global gh_tag/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
-
-if [ -f $NAME-$VERSION.tgz ]; then
- echo Skip $NAME-$VERSION.tgz
-else
- echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-
- echo "Cloning..."
- rm -rf $PROJECT-$VERSION
-
- if [ -z "$TAG" ]; then
- git clone --recursive https://github.com/$OWNER/$PROJECT.git $PROJECT-$VERSION
- pushd $PROJECT-$VERSION
- git checkout $COMMIT || exit 1
- popd
- else
- git clone --recursive --branch $TAG https://github.com/$OWNER/$PROJECT.git $PROJECT-$VERSION
- fi
-
- echo "Archiving..."
- tar czf $NAME-$VERSION.tgz --exclude .git $PROJECT-$VERSION
-
- echo "Cleaning..."
- rm -rf $PROJECT-$VERSION
-
- echo "Done."
-fi
-
-spectool -g -S *spec
-
diff --git a/php-pecl-awscrt.spec b/php-pecl-awscrt.spec
index 8af2d6c..4e27e19 100644
--- a/php-pecl-awscrt.spec
+++ b/php-pecl-awscrt.spec
@@ -30,21 +30,15 @@
Summary: AWS Common Runtime PHP bindings
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.4
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.0.7
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# recursive git clone
-Source1: php-pecl-%{pecl_name}-%{version}.tgz
-Source2: makesrc.sh
-
-# Workaround for https://github.com/awslabs/aws-crt-php/issues/35
-Patch0: %{pecl_name}-build.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.4
+BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-cli
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: openssl-devel
@@ -94,7 +88,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
-%setup -q -c -a1
+%setup -q -c
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -106,15 +100,11 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
mv %{pecl_name}-%{version} NTS
-rm -rf NTS/crt
-ln -s ../%{gh_project}-%{version}/crt NTS/crt
-pushd %{gh_project}-%{version}
+pushd NTS
# Workaround for https://github.com/awslabs/aws-crt-php/issues/35
sed -e 's/-Werror//' \
-i crt/aws-crt-ffi/crt/*/CMakeLists.txt
-
-%patch0 -p1
popd
%if %{with_zts}
@@ -234,6 +224,9 @@ fi
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 1.0.7-1
+- update to 1.0.7
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.0.4-2
- rebuild for 8.1.0RC1