summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 07:24:08 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 07:24:08 +0100
commit55db876609f597d9dad4a28d061af4c021cd1c64 (patch)
treeca26f92b323b5d8c7449a38387ab57ffb605b428
parent2ad87b0259a49fe9dec3092fc5b9c244287e7c21 (diff)
php-pecl-ares: F24
-rw-r--r--php-pecl-ares.spec26
1 files changed, 16 insertions, 10 deletions
diff --git a/php-pecl-ares.spec b/php-pecl-ares.spec
index 412e592..2079c9f 100644
--- a/php-pecl-ares.spec
+++ b/php-pecl-ares.spec
@@ -15,10 +15,6 @@
%endif
%{?scl: %scl_package php-pecl-ares}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?php_incldir: %global php_incldir %{_includedir}/php}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name ares
@@ -34,7 +30,7 @@
Summary: Asynchronous Resolver
Name: %{?sub_prefix}php-pecl-ares
Version: 0.8.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -49,10 +45,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -87,7 +85,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -q -c
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
mv %{pecl_name}-%{version} NTS
@@ -156,6 +156,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -172,6 +173,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -228,6 +230,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.8.0-3
+- adapt for F24
+
* Wed Jun 24 2015 Remi Collet <remi@fedoraproject.org> - 0.8.0-2
- allow build against rh-php56 (as more-php56)
- drop runtime dependency on pear, new scriptlets
@@ -236,4 +241,5 @@ rm -rf %{buildroot}
- Fedora 21 SCL mass rebuild
* Fri Nov 14 2014 Remi Collet <remi@fedoraproject.org> - 0.8.0-1
-- initial package, version 0.8.0 (beta) \ No newline at end of file
+- initial package, version 0.8.0 (beta)
+