summaryrefslogtreecommitdiffstats
path: root/php-pecl-apcu.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-apcu.spec')
-rw-r--r--php-pecl-apcu.spec30
1 files changed, 17 insertions, 13 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index f914506..cad6462 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-apcu
#
-# Copyright (c) 2013-2021 Remi Collet
+# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -14,7 +14,6 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-apcu
%endif
@@ -27,7 +26,7 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-Name: %{?sub_prefix}php-pecl-apcu
+Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
Version: 5.1.21
License: PHP
@@ -36,13 +35,16 @@ URL: https://pecl.php.net/package/APCu
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
Source1: %{pecl_name}-5.1.19.ini
Source2: %{pecl_name}-panel.conf
Source3: %{pecl_name}.conf.php
+# git diff v5.1.21 -- *.c *.h *.php tests
+Patch0: %{pecl_name}-php82.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -57,10 +59,6 @@ Provides: %{?scl_prefix}php-apcu = %{version}
Provides: %{?scl_prefix}php-apcu%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(apcu) = %{version}
Provides: %{?scl_prefix}php-pecl(apcu)%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-apcu = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-apcu%{?_isa} = %{version}-%{release}
-%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -104,7 +102,7 @@ APCu is userland caching: APC stripped of opcode caching.
APCu only supports userland caching of variables.
-The %{?sub_prefix}php-pecl-apcu-bc package provides a drop
+The %{?scl_prefix}php-pecl-apcu-bc package provides a drop
in replacement for APC.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -118,10 +116,6 @@ Requires: %{?scl_prefix}php-devel%{?_isa}
Obsoletes: %{?scl_prefix}php-pecl-apc-devel < 4
Provides: %{?scl_prefix}php-pecl-apc-devel = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-apc-devel%{?_isa} = %{version}-%{release}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-apcu-devel = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-apcu-devel%{?_isa} = %{version}-%{release}
-%endif
%description devel
These are the files needed to compile programs using APCu.
@@ -157,6 +151,10 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%if "%{php_version}" > "8.2"
+%patch0 -p1 -b .php82
+%endif
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_APCU_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -322,6 +320,12 @@ fi
%changelog
+* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 5.1.21-3
+- rebuild for PHP 8.2.0RC1
+
+* Thu Aug 18 2022 Remi Collet <remi@remirepo.net> - 5.1.21-2
+- add upstream patches for PHP 8.2
+
* Thu Oct 7 2021 Remi Collet <remi@remirepo.net> - 5.1.21-1
- update to 5.1.21