summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO27
-rw-r--r--REFLECTION15
-rw-r--r--php-pecl-apcu.spec5
3 files changed, 40 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..f690b5e
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,27 @@
+
+apcu
+
+APCu Support => Enabled
+Version => 5.1.12
+APCu Debugging => Disabled
+MMAP Support => Enabled
+MMAP File Mask => /tmp/apc.UDG9ZA
+Serialization Support => php, igbinary
+Build Date => Jul 9 2018 12:01:21
+
+Directive => Local Value => Master Value
+apc.enabled => On => On
+apc.shm_segments => 1 => 1
+apc.shm_size => 32M => 32M
+apc.entries_hint => 4096 => 4096
+apc.gc_ttl => 3600 => 3600
+apc.ttl => 0 => 0
+apc.smart => 0 => 0
+apc.mmap_file_mask => /tmp/apc.UDG9ZA => /tmp/apc.UDG9ZA
+apc.enable_cli => On => On
+apc.slam_defense => On => On
+apc.preload_path => no value => no value
+apc.coredump_unmap => Off => Off
+apc.use_request_time => On => On
+apc.serializer => php => php
+apc.writable => /tmp => /tmp
diff --git a/REFLECTION b/REFLECTION
index 0336958..8e3d223 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #73 apcu version 5.1.11 ] {
+Extension [ <persistent> extension #73 apcu version 5.1.12 ] {
- INI {
Entry [ apc.enabled <SYSTEM> ]
@@ -23,10 +23,10 @@ Extension [ <persistent> extension #73 apcu version 5.1.11 ] {
Current = '0'
}
Entry [ apc.mmap_file_mask <SYSTEM> ]
- Current = '/tmp/apc.XXXXXX'
+ Current = '/tmp/apc.WFRjUS'
}
Entry [ apc.enable_cli <SYSTEM> ]
- Current = '0'
+ Current = '1'
}
Entry [ apc.slam_defense <SYSTEM> ]
Current = '1'
@@ -48,7 +48,8 @@ Extension [ <persistent> extension #73 apcu version 5.1.11 ] {
}
}
- - Constants [15] {
+ - Constants [16] {
+ Constant [ integer ] { 140351166538576 }
Constant [ integer APC_LIST_ACTIVE ] { 1 }
Constant [ integer APC_LIST_DELETED ] { 2 }
Constant [ integer APC_ITER_TYPE ] { 1 }
@@ -126,18 +127,20 @@ Extension [ <persistent> extension #73 apcu version 5.1.11 ] {
}
Function [ <internal:apcu> function apcu_inc ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> $step ]
Parameter #2 [ <optional> &$success ]
+ Parameter #3 [ <optional> $ttl ]
}
}
Function [ <internal:apcu> function apcu_dec ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> $step ]
Parameter #2 [ <optional> &$success ]
+ Parameter #3 [ <optional> $ttl ]
}
}
Function [ <internal:apcu> function apcu_cas ] {
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index 736bbb4..016adee 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -29,7 +29,7 @@
Name: %{?sub_prefix}php-pecl-apcu
Summary: APC User Cache
-Version: 5.1.11
+Version: 5.1.12
%if 0%{?gh_date:1}
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -316,6 +316,9 @@ fi
%changelog
+* Mon Jul 9 2018 Remi Collet <remi@remirepo.net> - 5.1.12-1
+- update to 5.1.12 (stable)
+
* Thu Mar 8 2018 Remi Collet <remi@remirepo.net> - 5.1.11-1
- update to 5.1.11 (stable)