summaryrefslogtreecommitdiffstats
path: root/php-pecl-apcu.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-19 08:42:57 +0200
committerRemi Collet <remi@php.net>2022-09-19 08:42:57 +0200
commitedebae9ac945f18ec001ed8998f3b5f84bf0b596 (patch)
treee87f06b8eb061f3616a05ad938c7e1001beaf0b1 /php-pecl-apcu.spec
parentdcdcbda2c20b25f9584db633e0b63d49e3c53247 (diff)
update to 5.1.22
Diffstat (limited to 'php-pecl-apcu.spec')
-rw-r--r--php-pecl-apcu.spec26
1 files changed, 11 insertions, 15 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index cad6462..2564130 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -17,6 +17,8 @@
%scl_package php-pecl-apcu
%endif
+%bcond_without tests
+
%global gh_commit b771cd50a7fe519b6aaccbe5dc97594e68e0c88f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner krakjoe
@@ -28,23 +30,20 @@
Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
-Version: 5.1.21
+Version: 5.1.22
License: PHP
URL: https://pecl.php.net/package/APCu
%if 0%{?gh_date:1}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
Source1: %{pecl_name}-5.1.19.ini
Source2: %{pecl_name}-panel.conf
Source3: %{pecl_name}.conf.php
-# git diff v5.1.21 -- *.c *.h *.php tests
-Patch0: %{pecl_name}-php82.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -88,12 +87,6 @@ Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
%endif
@@ -151,10 +144,6 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%if "%{php_version}" > "8.2"
-%patch0 -p1 -b .php82
-%endif
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_APCU_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -244,12 +233,14 @@ cd NTS
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
-m | grep 'apcu'
+%if %{with tests}
# Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{_bindir}/php -n run-tests.php --show-diff
+%endif
%if %{with_zts}
cd ../ZTS
@@ -257,6 +248,7 @@ cd ../ZTS
-d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
-m | grep 'apcu'
+%if %{with tests}
# Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
@@ -264,6 +256,7 @@ NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
%endif
+%endif
%if 0%{?fedora} < 24 && 0%{?rhel} < 8
@@ -320,6 +313,9 @@ fi
%changelog
+* Mon Sep 19 2022 Remi Collet <remi@remirepo.net> - 5.1.22-1
+- update to 5.1.22
+
* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 5.1.21-3
- rebuild for PHP 8.2.0RC1