summaryrefslogtreecommitdiffstats
path: root/php-pecl-apcu.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-01 11:13:47 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-01 11:13:47 +0100
commitb4ebc2eca8fc77ec4916ae86cdc043fd6d1e05d3 (patch)
tree4677a5a5aa9eab42ae450e04d3fa3e30ddd5a6f5 /php-pecl-apcu.spec
parent9b0eb5aee1a628af00978e5051f12a0b26bbdf28 (diff)
php-pecl-apcu: 4.0.4
Diffstat (limited to 'php-pecl-apcu.spec')
-rw-r--r--php-pecl-apcu.spec21
1 files changed, 18 insertions, 3 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index 3655f1b..fda2d4e 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -6,8 +6,8 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-pecl-apcu}
-%{!?scl: %global pkg_name %{name}}
+%{?scl: %scl_package php-pecl-apcu}
+%{!?scl: %global pkg_name %{name}}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?php_incldir: %global php_incldir %{_includedir}/php}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
@@ -17,7 +17,7 @@
Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
-Version: 4.0.3
+Version: 4.0.4
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{pecl_name}.ini
@@ -66,6 +66,9 @@ Obsoletes: php54-pecl-%{pecl_name}
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
%endif
%if 0%{?fedora} < 20
@@ -141,6 +144,15 @@ configuration, available on http://localhost/apcu-panel/
%setup -qc
mv %{pecl_name}-%{version} NTS
+cd NTS
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_APCU_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
# Fix file roles
sed -e '/LICENSE/s/role="src"/role="doc"/' \
-e '/NOTICE/s/role="src"/role="doc"/' \
@@ -289,6 +301,9 @@ fi
%changelog
+* Sat Mar 01 2014 Remi Collet <remi@fedoraproject.org> - 4.0.4-1
+- Update to 4.0.4 (beta)
+
* Mon Jan 27 2014 Remi Collet <remi@fedoraproject.org> - 4.0.3-1
- Update to 4.0.3 (beta)
- install doc in pecl doc_dir