summaryrefslogtreecommitdiffstats
path: root/php-pecl-apcu.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-25 12:33:51 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-25 12:33:51 +0200
commit76682c27b5c0f6b1b8e256e704aae2d15138823e (patch)
treee1248965cfe3c57f9669ad558afe99e216ef9664 /php-pecl-apcu.spec
parentc603628102cc27b075389f271f5f3585e77e8dcf (diff)
php-pecl-apcu: upstream patch to fix a segfault when used from cli
Diffstat (limited to 'php-pecl-apcu.spec')
-rw-r--r--php-pecl-apcu.spec13
1 files changed, 11 insertions, 2 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index 7cb8d62..bc39141 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -6,12 +6,14 @@
Name: php-pecl-apcu
Summary: APC User Cache
Version: 4.0.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{pecl_name}.ini
Source2: %{pecl_name}-panel.conf
Source3: %{pecl_name}.conf.php
+Patch0: %{pecl_name}-git.patch
+
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/APCu
@@ -87,12 +89,16 @@ configuration, available on http://localhost/apcu-panel/
%setup -qc
mv %{pecl_name}-%{version} NTS
+cd NTS
+%patch0 -p1 -b .fromgit
+
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_APC_VERSION/{s/.* "//;s/".*$//;p}' NTS/php_apc.h)
+extver=$(sed -n '/#define PHP_APC_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}.
exit 1
fi
+cd ..
%if %{with_zts}
# duplicate for ZTS build
@@ -197,6 +203,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Apr 25 2013 Remi Collet <remi@fedoraproject.org> - 4.0.0-2
+- fix segfault when used from command line
+
* Wed Mar 27 2013 Remi Collet <remi@fedoraproject.org> - 4.0.0-1
- first pecl release
- rename from php-apcu to php-pecl-apcu