summaryrefslogtreecommitdiffstats
path: root/php-pecl-apcu.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-07 10:53:02 +0200
committerRemi Collet <remi@remirepo.net>2021-07-07 10:53:02 +0200
commit3a69a5b8a3634b440ff8943ea3076720ecb603de (patch)
treeafbd40bdb6b3f577a5573f99e583afe8d9edda30 /php-pecl-apcu.spec
parentd4bca5573153ea4c0fabde7937e4c076cb6edea5 (diff)
add upstream patch for test suite with PHP 8.1
Diffstat (limited to 'php-pecl-apcu.spec')
-rw-r--r--php-pecl-apcu.spec16
1 files changed, 9 insertions, 7 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index e2a494b..eea74d7 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -36,13 +36,16 @@ URL: https://pecl.php.net/package/APCu
Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
Source1: %{pecl_name}-5.1.19.ini
Source2: %{pecl_name}-panel.conf
Source3: %{pecl_name}.conf.php
+# Upstream patch
+Patch0: %{pecl_name}-php81.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -157,6 +160,8 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .up
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_APCU_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -241,12 +246,6 @@ done
%check
-%if "%{php_version}" > "8.1"
-rm ?TS/tests/apc_003b.phpt
-rm ?TS/tests/apc_006_php73.phpt
-rm ?TS/tests/bug76145.phpt
-%endif
-
cd NTS
%{_bindir}/php -n \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
@@ -328,6 +327,9 @@ fi
%changelog
+* Wed Jul 7 2021 Remi Collet <remi@remirepo.net> - 5.1.20-3
+- add upstream patch for test suite with PHP 8.1
+
* Thu Jun 10 2021 Remi Collet <remi@remirepo.net> - 5.1.20-2
- temporarily ignore 3 tests with PHP 8.1