summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-11 09:12:19 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-11 09:12:19 +0200
commitde3dd09bbb717d65d1b9afb60eb51b0fadc46c10 (patch)
tree6025150836c44bfb130fec2712e17d6b8f87467e
parent8cdab475e3fc811e4108907474e3050610cfd8c8 (diff)
php-pecl-apcu: 4.0.5 (beta)
-rw-r--r--REFLECTION2
-rw-r--r--apcu-php56.patch57
-rw-r--r--php-pecl-apcu.spec17
3 files changed, 5 insertions, 71 deletions
diff --git a/REFLECTION b/REFLECTION
index c5e23d2..5805b57 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #74 apcu version 4.0.4 ] {
+Extension [ <persistent> extension #74 apcu version 4.0.5 ] {
- INI {
Entry [ apc.enabled <SYSTEM> ]
diff --git a/apcu-php56.patch b/apcu-php56.patch
deleted file mode 100644
index 70efbc6..0000000
--- a/apcu-php56.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 244473d2bca7aff7ce24a58651ab8a261669d99d Mon Sep 17 00:00:00 2001
-From: krakjoe <joe.watkins@live.co.uk>
-Date: Sun, 8 Jun 2014 17:40:36 +0100
-Subject: [PATCH] fix #73
-
----
- apc_bin.c | 1 -
- apc_cache.c | 6 ++----
- 2 files changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/apc_bin.c b/apc_bin.c
-index 00f7160..a8f705c 100644
---- a/apc_bin.c
-+++ b/apc_bin.c
-@@ -235,7 +235,6 @@ static void apc_swizzle_zval(apc_bd_t *bd, apc_context_t* ctxt, zend_llist *ll,
- apc_swizzle_ptr(bd, ctxt, ll, &zv->value.str.val);
- break;
- case IS_ARRAY:
-- case IS_CONSTANT_ARRAY:
- apc_swizzle_hashtable(bd, ctxt, ll, zv->value.ht, (apc_swizzle_cb_t)apc_swizzle_zval, 1 TSRMLS_CC);
- apc_swizzle_ptr(bd, ctxt, ll, &zv->value.ht);
- break;
-diff --git a/apc_cache.c b/apc_cache.c
-index b82611d..e0e53df 100644
---- a/apc_cache.c
-+++ b/apc_cache.c
-@@ -1001,9 +1001,8 @@ PHP_APCU_API zend_bool apc_cache_update(apc_cache_t* cache, char *strkey, zend_u
- if ((h == (*slot)->key.h) &&
- !memcmp((*slot)->key.str, strkey, keylen)) {
- /* attempt to perform update */
-- switch(Z_TYPE_P((*slot)->value->val) & ~IS_CONSTANT_INDEX) {
-+ switch(Z_TYPE_P((*slot)->value->val) & ~IS_CONSTANT_TYPE_MASK) {
- case IS_ARRAY:
-- case IS_CONSTANT_ARRAY:
- case IS_OBJECT:
- {
- if(cache->serializer) {
-@@ -1124,7 +1123,7 @@ static zval* my_serialize_object(zval* dst, const zval* src, apc_context_t* ctxt
- }
-
- if(serialize((unsigned char**)&buf.c, &buf.len, src, config TSRMLS_CC)) {
-- dst->type = src->type & ~IS_CONSTANT_INDEX;
-+ dst->type = src->type & ~IS_CONSTANT;
- dst->value.str.len = buf.len;
- CHECK(dst->value.str.val = apc_pmemcpy(buf.c, (buf.len + 1), pool TSRMLS_CC));
- }
-@@ -1357,7 +1356,6 @@ static APC_HOTSPOT zval* my_copy_zval(zval* dst, const zval* src, apc_context_t*
- break;
-
- case IS_ARRAY:
-- case IS_CONSTANT_ARRAY:
- if(ctxt->serializer == NULL) {
-
- CHECK(dst->value.ht =
---
-1.9.3
-
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index e44c55f..898c9b8 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -22,15 +22,13 @@
Name: %{?scl_prefix}php-pecl-apcu
Summary: APC User Cache
-Version: 4.0.4
+Version: 4.0.5
Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{pecl_name}.ini
Source2: %{pecl_name}-panel.conf
Source3: %{pecl_name}.conf.php
-Patch0: %{pecl_name}-php56.patch
-
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/APCu
@@ -153,8 +151,6 @@ mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p1 -b .php56
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_APCU_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
if test "x${extver}" != "x%{version}"; then
@@ -163,14 +159,6 @@ if test "x${extver}" != "x%{version}"; then
fi
cd ..
-# Fix file roles https://github.com/krakjoe/apcu/pull/69
-sed -e '/LICENSE/s/role="src"/role="doc"/' \
- -e '/NOTICE/s/role="src"/role="doc"/' \
- -e '/README.md/s/role="src"/role="doc"/' \
- -e '/TECHNOTES.txt/s/role="src"/role="doc"/' \
- -e '/TODO/s/role="src"/role="doc"/' \
- -i package.xml
-
%if %{with_zts}
# duplicate for ZTS build
cp -pr NTS ZTS
@@ -311,6 +299,9 @@ fi
%changelog
+* Wed Jun 11 2014 Remi Collet <remi@fedoraproject.org> - 4.0.5-1
+- Update to 4.0.5 (beta)
+
* Sun Jun 8 2014 Remi Collet <remi@fedoraproject.org> - 4.0.4-3
- add build patch for php 5.6.0beta4