summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-07 18:33:25 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-07 18:33:25 +0100
commitcd539dfb862d922071c65c0fa5edc569304b2739 (patch)
tree4cbe3d9fb886f54ae2a0cff25eb715ae6c9036e1
parentee0d5c42437379c249f5e8687de82a4a6067f3d8 (diff)
php-pecl-apcu: F24
-rw-r--r--php-pecl-apcu.spec19
1 files changed, 13 insertions, 6 deletions
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index af4cabb..fc0532a 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -19,10 +19,6 @@
%{?scl: %scl_package php-pecl-apcu}
%{!?scl: %global pkg_name %{name}}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?php_incldir: %global php_incldir %{_includedir}/php}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global gh_commit d7b65bf289e7dd3cd22350554b5eb99fc3bb2a9c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner krakjoe
@@ -43,7 +39,7 @@ Version: 4.0.10
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
Source1: %{pecl_name}.ini
@@ -68,11 +64,15 @@ Provides: %{?scl_prefix}php-apcu = %{version}
Provides: %{?scl_prefix}php-apcu%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(apcu) = %{version}
Provides: %{?scl_prefix}php-pecl(apcu)%{?_isa} = %{version}
+# For "more" SCL
+Provides: %{?scl_prefix}php-pecl-apcu = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-apcu%{?_isa} = %{version}-%{release}
%if "%{php_version}" < "5.5"
Conflicts: %{?scl_prefix}php-pecl-apc < 4
%else
Obsoletes: %{?scl_prefix}php-pecl-apc < 4
%endif
+
# Same provides than APC, this is a drop in replacement
Provides: %{?scl_prefix}php-apc = %{version}
Provides: %{?scl_prefix}php-apc%{?_isa} = %{version}
@@ -177,6 +177,8 @@ mv NTS/package.xml .
mv %{pecl_name}-%{version} NTS
%endif
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
cd NTS
# Sanity check, really often broken
@@ -284,6 +286,7 @@ REPORT_EXIT_STATUS=1 \
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -300,6 +303,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%files
@@ -339,6 +343,9 @@ fi
%changelog
+* Mon Mar 7 2016 Remi Collet <remi@fedoraproject.org> - 4.0.10-2
+- adapt for F24
+
* Mon Dec 7 2015 Remi Collet <remi@fedoraproject.org> - 4.0.10-1
- Update to 4.0.10 (stable)
@@ -426,4 +433,4 @@ fi
- new snapshot with full APC compatibility
* Sat Mar 23 2013 Remi Collet <remi@fedoraproject.org> - 4.0.0-0.1.git44e8dd4
-- initial package, version 4.0.0 \ No newline at end of file
+- initial package, version 4.0.0