summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-02 12:10:32 +0200
committerRemi Collet <remi@remirepo.net>2020-09-02 12:10:32 +0200
commit243ea6894a4dd4ae685e4691ab547afb2bd0a62c (patch)
tree8560d09d19867dd8915d2efb3c09972c3884a21c
parent776c128b1397dad5aeecf8cb8d06549024d8c4a4 (diff)
more upstream patches
-rw-r--r--apcu-upstream.patch20
-rw-r--r--php-pecl-apcu.spec9
2 files changed, 24 insertions, 5 deletions
diff --git a/apcu-upstream.patch b/apcu-upstream.patch
index 9170b6a..78c4c65 100644
--- a/apcu-upstream.patch
+++ b/apcu-upstream.patch
@@ -251,3 +251,23 @@ index 2aede0c..75035a3 100644
$handle = proc_open(addslashes($cmd), $descriptorspec, $pipes, $doc_root, NULL, array("bypass_shell" => true, "suppress_errors" => true));
} else {
$cmd = "exec {$php_executable} -n $php_args -t {$doc_root} -S $host:$port";
+From 7a1989e306d78f4bb9276abbad9cf0db35c9d06e Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 2 Sep 2020 12:07:57 +0200
+Subject: [PATCH] fix #399 relax test for PHP 8
+
+---
+ tests/not_enough_shm.phpt | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/tests/not_enough_shm.phpt b/tests/not_enough_shm.phpt
+index 0b5ea1b..acb3c31 100644
+--- a/tests/not_enough_shm.phpt
++++ b/tests/not_enough_shm.phpt
+@@ -8,5 +8,4 @@ apc.entries_hint=1000000
+ --FILE--
+ Irrelevant
+ --EXPECTF--
+-%A
+-Fatal error: Unable to allocate %d bytes of shared memory for cache structures. Either apc.shm_size is too small or apc.entries_hint too large in Unknown on line 0
++%A: Unable to allocate %d bytes of shared memory for cache structures. Either apc.shm_size is too small or apc.entries_hint too large in Unknown on line 0
diff --git a/php-pecl-apcu.spec b/php-pecl-apcu.spec
index a17ff5e..84d251c 100644
--- a/php-pecl-apcu.spec
+++ b/php-pecl-apcu.spec
@@ -36,7 +36,7 @@ URL: https://pecl.php.net/package/APCu
Release: 0.7.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
Source1: %{pecl_name}-5.1.2.ini
@@ -247,10 +247,6 @@ done
%check
-%if "%{php_version}" > "8.0"
-rm ?TS/tests/not_enough_shm.phpt
-%endif
-
cd NTS
%{_bindir}/php -n \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
@@ -332,6 +328,9 @@ fi
%changelog
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 5.1.18-5
+- more upstream patches
+
* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 5.1.18-4
- rebuild for PHP 8.0.0beta3