summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-apcu-bc.spec13
1 files changed, 12 insertions, 1 deletions
diff --git a/php-pecl-apcu-bc.spec b/php-pecl-apcu-bc.spec
index fd1b2f1..cecd964 100644
--- a/php-pecl-apcu-bc.spec
+++ b/php-pecl-apcu-bc.spec
@@ -22,7 +22,11 @@
%global pecl_name apcu-bc
%global ext_name apc
%global apcver %(%{_bindir}/php -r 'echo (phpversion("apcu")?:0);' 2>/dev/null || echo 65536)
+%if "%{php_version}" > "7.1"
+%global with_zts 0
+%else
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%endif
# After 40-apcu.ini
%global ini_name 50-%{ext_name}.ini
@@ -33,7 +37,7 @@ Version: 1.0.3
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{proj_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
%endif
@@ -75,6 +79,10 @@ Obsoletes: php56u-pecl-%{ext_name} <= %{version}
Obsoletes: php56w-pecl-%{ext_name} <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -230,6 +238,9 @@ fi
%changelog
+* Sat Jul 23 2016 Remi Collet <remi@fedoraproject.org> - 1.0.3-3
+- disable ZTS build with PHP 7.1
+
* Mon Mar 7 2016 Remi Collet <remi@fedoraproject.org> - 1.0.3-2
- fix apcver macro definition