summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-apcu-bc.spec31
2 files changed, 24 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 58583a1..264be2d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 apc version 5.1.3 ] {
+Extension [ <persistent> extension #178 apc version 5.1.10 ] {
- Dependencies {
Dependency [ apcu (Required) ]
diff --git a/php-pecl-apcu-bc.spec b/php-pecl-apcu-bc.spec
index 8a50745..22cf48a 100644
--- a/php-pecl-apcu-bc.spec
+++ b/php-pecl-apcu-bc.spec
@@ -1,18 +1,22 @@
# remirepo spec file for php-pecl-apcu-bc
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-apcu-bc
+%else
+%global pkg_name %{name}
%endif
-%{?scl: %scl_package php-pecl-apcu-bc}
-%{!?scl: %global pkg_name %{name}}
-
%global gh_commit 52b97a7ef7565509ff1db58ad95fb13c87ab2544
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner krakjoe
@@ -28,19 +32,19 @@
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Summary: APCu Backwards Compatibility Module
-Version: 1.0.3
+Version: 1.0.4
%if 0%{?gh_date:1}
Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{proj_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
%endif
License: PHP
-Group: Development/Languages
URL: https://pecl.php.net/package/apcu_bc
+BuildRequires: gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-apcu-devel >= 5.1.2
@@ -79,6 +83,10 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -131,6 +139,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -149,6 +159,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -199,7 +211,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -234,6 +246,9 @@ fi
%changelog
+* Fri Feb 16 2018 Remi Collet <remi@remirepo.net> - 1.0.4-1
+- update to 1.0.4 (stable, no change)
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.0.3-7
- rebuild for PHP 7.2.0beta1 new API