summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-04 09:27:37 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-04 09:27:37 +0100
commite81bcefbb3833396018edc3c4d064971db0a7821 (patch)
tree39294190d7520ecd4c366a1d838e40d0d9ceda4a
parent833782181a49790c1ffea9692c38e74eba7ad276 (diff)
php-pecl-apcu-bc: test build (upcoming 1.0.1)
-rw-r--r--REFLECTION171
-rw-r--r--php-pecl-apcu-bc.spec11
2 files changed, 178 insertions, 4 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..3e95e60
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,171 @@
+Extension [ <persistent> extension #70 apc version 5.1.2 ] {
+
+ - Dependencies {
+ Dependency [ apcu (Required) ]
+ }
+
+ - Functions {
+ Function [ <internal:apc> function apc_cache_info ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $type ]
+ Parameter #1 [ <optional> $limited ]
+ }
+ }
+ Function [ <internal:apc> function apc_clear_cache ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $type ]
+ }
+ }
+ Function [ <internal:apc> function apc_store ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $var ]
+ Parameter #2 [ <optional> $ttl ]
+ }
+ }
+ Function [ <internal:apc> function apc_fetch ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> &$success ]
+ }
+ }
+ Function [ <internal:apc> function apc_enabled ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:apc> function apc_delete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keys ]
+ }
+ }
+ Function [ <internal:apc> function apc_add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $var ]
+ Parameter #2 [ <optional> $ttl ]
+ }
+ }
+ Function [ <internal:apc> function apc_sma_info ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $limited ]
+ }
+ }
+ Function [ <internal:apc> function apc_inc ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $step ]
+ Parameter #2 [ <optional> &$success ]
+ }
+ }
+ Function [ <internal:apc> function apc_dec ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $step ]
+ Parameter #2 [ <optional> &$success ]
+ }
+ }
+ Function [ <internal:apc> function apc_cas ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $old ]
+ Parameter #2 [ <required> $new ]
+ }
+ }
+ Function [ <internal:apc> function apc_exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keys ]
+ }
+ }
+ }
+
+ - Classes [1] {
+ Class [ <internal:apc> <iterateable> class APCIterator extends APCuIterator implements Traversable, Iterator ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [9] {
+ Method [ <internal:apc, overwrites APCuIterator, ctor> public method __construct ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $ignored ]
+ Parameter #1 [ <optional> $search ]
+ Parameter #2 [ <optional> $format ]
+ Parameter #3 [ <optional> $chunk_size ]
+ Parameter #4 [ <optional> $list ]
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator> public method getTotalHits ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator> public method getTotalSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:apcu, inherits APCuIterator> public method getTotalCount ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-apcu-bc.spec b/php-pecl-apcu-bc.spec
index e40707e..55ca117 100644
--- a/php-pecl-apcu-bc.spec
+++ b/php-pecl-apcu-bc.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-apcu-bc
#
-# Copyright (c) 2015 Remi Collet
+# Copyright (c) 2015-2016 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -35,12 +35,12 @@
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Summary: APCu Backwards Compatibility Module
-Version: 1.0.0
+Version: 1.0.1
%if 0%{?gh_date:1}
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{proj_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
%endif
@@ -111,7 +111,7 @@ mv %{proj_name}-%{version} NTS
cd NTS
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_APC_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
+extver=$(sed -n '/#define PHP_APCU_BC_VERSION/{s/.* "//;s/".*$//;p}' php_apc.h)
if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:dev}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}%{?gh_date:dev}.
exit 1
@@ -238,6 +238,9 @@ fi
%changelog
+* Mon Jan 4 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-0
+- test build for upcoming 1.0.1
+
* Sat Dec 26 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
- missing dependency on APCu