summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-06 14:22:28 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-06 14:22:28 +0100
commit370d02140caf5a74dfe8ba869f563cb3da8714e0 (patch)
tree0d964ba8c1bf686a236b3c0923efd6b36e1fed6f
parent960e8f5e8b998b779dd5d62440ea426f3979bc1b (diff)
php-pecl-apcu-bc: use apcu version from installed version
-rw-r--r--php-pecl-apcu-bc.spec4
1 files changed, 3 insertions, 1 deletions
diff --git a/php-pecl-apcu-bc.spec b/php-pecl-apcu-bc.spec
index b8e9f0e..7164426 100644
--- a/php-pecl-apcu-bc.spec
+++ b/php-pecl-apcu-bc.spec
@@ -29,6 +29,7 @@
%global proj_name apcu_bc
%global pecl_name apcu-bc
%global ext_name apc
+%global apcver %(php -r 'echo phpversion("apcu");' 2>/dev/null || echo 65536)
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 40-apcu.ini
%global ini_name 50-%{ext_name}.ini
@@ -36,7 +37,6 @@
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Summary: APCu Backwards Compatibility Module
# From APCU, to be greater that last APC version
-%global apcver 5.1.2
Version: 1.0.1
%if 0%{?gh_date:1}
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -130,6 +130,8 @@ cat << 'EOF' | tee %{ini_name}
extension=%{ext_name}.so
EOF
+: Build apcu_bc %{version} with apcu %{apcver}
+
%build
cd NTS