summaryrefslogtreecommitdiffstats
path: root/php-pecl-amqp.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-09 16:45:57 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-09 16:45:57 +0200
commitefc7265b3f3883d3a826d7f792a8a1d8c5d1351a (patch)
tree86bd43ee8b8abd1e77de9bd09dcd23a6dc8fa039 /php-pecl-amqp.spec
parentf86527db3966491ba0a875f8229b2dcab49c7d50 (diff)
php-pecl: add numerical prefix to extension configuration file (2)
Diffstat (limited to 'php-pecl-amqp.spec')
-rw-r--r--php-pecl-amqp.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 71fc3c7..2f010a3 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -17,10 +17,16 @@
%global pecl_name amqp
%global prever beta2
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
Summary: Communicate with any AMQP compliant server
Name: %{?scl_prefix}php-pecl-amqp
Version: 1.4.0
-Release: 0.2.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.3.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
@@ -86,7 +92,7 @@ if test "x${extver}" != "x%{version}%{?prever}"; then
fi
cd ..
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension = %{pecl_name}.so
@@ -143,14 +149,14 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
-install -Dpm 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -Dpm 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -Dpm 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -Dpm 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -234,17 +240,20 @@ fi
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 1.4.0-0.3.beta2
+- add numerical prefix to extension configuration file
+
* Sun Mar 9 2014 Remi Collet <remi@fedoraproject.org> - 1.4.0-0.2.beta2
- update to 1.4.0beta2