summaryrefslogtreecommitdiffstats
path: root/php-pecl-amqp.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-02 13:30:45 +0100
committerRemi Collet <remi@php.net>2021-11-02 13:30:45 +0100
commita337bce8382d154f5a1f0530fb98affb24ca229e (patch)
treea43d553f1ff6e955fd8ec719c2184d96536e3a61 /php-pecl-amqp.spec
parentf5bc0213742d9e19ae01c6f335015d22eb05a9ab (diff)
update to 1.11.0RC1
Diffstat (limited to 'php-pecl-amqp.spec')
-rw-r--r--php-pecl-amqp.spec23
1 files changed, 13 insertions, 10 deletions
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index c6753d0..8279fba 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -24,21 +24,22 @@
%global pecl_name amqp
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 1.11.0
-%global upstream_prever beta
+%global upstream_prever RC1
+%global upstream_lower rc1
%global buildver %(pkg-config --silence-errors --modversion librabbitmq 2>/dev/null || echo 65536)
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
-Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/amqp
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 5.6
+BuildRequires: %{?scl_prefix}php-devel >= 5.6
BuildRequires: %{?scl_prefix}php-pear
# Upstream requires 0.7.1, set 0.8.0 to ensure "last" is used.
BuildRequires: librabbitmq-devel >= 0.8.0
@@ -84,6 +85,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -237,21 +241,17 @@ export RABBITMQ_MNESIA_BASE=$PWD/base
ret=0
pushd NTS
: Run the upstream test Suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || ret=1
+%{__php} -n run-tests.php -q -P --show-diff || ret=1
popd
%if %{with_zts}
pushd ZTS
: Run the upstream test Suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff || ret=1
+%{__ztsphp} -n run-tests.php -q -P--show-diff || ret=1
popd
%endif
@@ -300,6 +300,9 @@ fi
%changelog
+* Tue Nov 2 2021 Remi Collet <remi@remirepo.net> - 1.11.0~rc1-1
+- update to 1.11.0RC1
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.11.0~beta-2
- rebuild for 8.1.0RC1