summaryrefslogtreecommitdiffstats
path: root/php-pecl-amqp.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-31 09:16:18 +0200
committerRemi Collet <remi@php.net>2023-07-31 09:16:18 +0200
commit02b63ef16d57ed753e491af50032420e85329b21 (patch)
treed2401f6c27c98115f800d7c0aee2eee6c6e480f7 /php-pecl-amqp.spec
parent0f2680e571c52ee7fa64dd46c4647af68a714eee (diff)
update to 2.0.0alpha2
open https://github.com/php-amqp/php-amqp/issues/448 missing file
Diffstat (limited to 'php-pecl-amqp.spec')
-rw-r--r--php-pecl-amqp.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 4572f4a..0994658 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -18,7 +18,7 @@
%global pecl_name amqp
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 2.0.0
-%global upstream_prever alpha1
+%global upstream_prever alpha2
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -37,7 +37,7 @@ BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: librabbitmq-devel
+BuildRequires: librabbitmq-devel >= 0.8.0
Requires: librabbitmq%{?_isa} >= %{buildver}
%if %{with tests}
BuildRequires: rabbitmq-server
@@ -94,10 +94,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-# lower minimal version
-# https://github.com/php-amqp/php-amqp/issues/439
-sed -e '/librabbitmq/s/0.10.0/0.8.0/' -i config.m4
-
# Upstream often forget to change this
extver=$(sed -n '/#define PHP_AMQP_VERSION /{s/.* "//;s/".*$//;p}' php_amqp_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -228,6 +224,10 @@ export RABBITMQ_MNESIA_BASE=$PWD/base
ret=0
pushd %{sources}
+
+# https://github.com/php-amqp/php-amqp/issues/448
+rm tests/amqpconnection_tls*.phpt
+
: Run the upstream test Suite for NTS extension
TEST_PHP_ARGS="-n -d extension=$PWD/../NTS/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
@@ -279,6 +279,10 @@ fi
%changelog
+* Mon Jul 31 2023 Remi Collet <remi@remirepo.net> - 2.0.0~alpha2-1
+- update to 2.0.0alpha2
+- open https://github.com/php-amqp/php-amqp/issues/448 missing file
+
* Sun Jul 30 2023 Remi Collet <remi@remirepo.net> - 2.0.0~alpha1-1
- update to 2.0.0alpha1
- drop patch merged upstream