summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-01 12:29:06 +0100
committerRemi Collet <remi@php.net>2021-12-01 12:29:06 +0100
commitfca04d4770c806710bdc90d3458c89c86211d410 (patch)
tree5615ebd938241eed35194794f56830add6bd5082
parenta337bce8382d154f5a1f0530fb98affb24ca229e (diff)
refresh reflection with 8.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION551
-rw-r--r--php-pecl-amqp.spec11
3 files changed, 401 insertions, 163 deletions
diff --git a/PHPINFO b/PHPINFO
index 87c8c96..7329f81 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ amqp
Version => 1.11.0RC1
Revision => release
-Compiled => Sep 1 2021 @ 00:00:00
+Compiled => Nov 2 2021 @ 00:00:00
AMQP protocol version => 0-9-1
librabbitmq version => 0.11.0
Default max channels per connection => 256
diff --git a/REFLECTION b/REFLECTION
index 59bc46a..3abea2b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
+Extension [ <persistent> extension #119 amqp version 1.11.0RC1 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -112,31 +112,31 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [18] {
- Property [ <default> private $login ]
- Property [ <default> private $password ]
- Property [ <default> private $host ]
- Property [ <default> private $vhost ]
- Property [ <default> private $port ]
- Property [ <default> private $read_timeout ]
- Property [ <default> private $write_timeout ]
- Property [ <default> private $connect_timeout ]
- Property [ <default> private $rpc_timeout ]
- Property [ <default> private $channel_max ]
- Property [ <default> private $frame_max ]
- Property [ <default> private $heartbeat ]
- Property [ <default> private $cacert ]
- Property [ <default> private $key ]
- Property [ <default> private $cert ]
- Property [ <default> private $verify ]
- Property [ <default> private $sasl_method ]
- Property [ <default> private $connection_name ]
+ Property [ private $login = NULL ]
+ Property [ private $password = NULL ]
+ Property [ private $host = NULL ]
+ Property [ private $vhost = NULL ]
+ Property [ private $port = NULL ]
+ Property [ private $read_timeout = NULL ]
+ Property [ private $write_timeout = NULL ]
+ Property [ private $connect_timeout = NULL ]
+ Property [ private $rpc_timeout = NULL ]
+ Property [ private $channel_max = NULL ]
+ Property [ private $frame_max = NULL ]
+ Property [ private $heartbeat = NULL ]
+ Property [ private $cacert = NULL ]
+ Property [ private $key = NULL ]
+ Property [ private $cert = NULL ]
+ Property [ private $verify = NULL ]
+ Property [ private $sasl_method = NULL ]
+ Property [ private $connection_name = NULL ]
}
- Methods [43] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> array $credentials ]
+ Parameter #0 [ <optional> array $credentials = <default> ]
}
}
@@ -421,12 +421,12 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [6] {
- Property [ <default> private $connection ]
- Property [ <default> private $prefetch_count ]
- Property [ <default> private $prefetch_size ]
- Property [ <default> private $global_prefetch_count ]
- Property [ <default> private $global_prefetch_size ]
- Property [ <default> private $consumers ]
+ Property [ private $connection = NULL ]
+ Property [ private $prefetch_count = NULL ]
+ Property [ private $prefetch_size = 0 ]
+ Property [ private $global_prefetch_count = NULL ]
+ Property [ private $global_prefetch_size = NULL ]
+ Property [ private $consumers = NULL ]
}
- Methods [24] {
@@ -512,7 +512,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [3] {
Parameter #0 [ <required> $size ]
Parameter #1 [ <required> $count ]
- Parameter #2 [ <optional> $global ]
+ Parameter #2 [ <optional> $global = <default> ]
}
}
@@ -543,7 +543,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
Method [ <internal:amqp> public method basicRecover ] {
- Parameters [1] {
- Parameter #0 [ <optional> $requeue ]
+ Parameter #0 [ <optional> $requeue = <default> ]
}
}
@@ -556,7 +556,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
Method [ <internal:amqp> public method waitForConfirm ] {
- Parameters [1] {
- Parameter #0 [ <optional> $timeout ]
+ Parameter #0 [ <optional> $timeout = <default> ]
}
}
@@ -564,7 +564,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> $ack_callback ]
- Parameter #1 [ <optional> $nack_callback ]
+ Parameter #1 [ <optional> $nack_callback = <default> ]
}
}
@@ -578,7 +578,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
Method [ <internal:amqp> public method waitForBasicReturn ] {
- Parameters [1] {
- Parameter #0 [ <optional> $timeout ]
+ Parameter #0 [ <optional> $timeout = <default> ]
}
}
@@ -602,15 +602,15 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [9] {
- Property [ <default> private $connection ]
- Property [ <default> private $channel ]
- Property [ <default> private $name ]
- Property [ <default> private $consumer_tag ]
- Property [ <default> private $passive ]
- Property [ <default> private $durable ]
- Property [ <default> private $exclusive ]
- Property [ <default> private $auto_delete ]
- Property [ <default> private $arguments ]
+ Property [ private $connection = NULL ]
+ Property [ private $channel = NULL ]
+ Property [ private $name = '' ]
+ Property [ private $consumer_tag = NULL ]
+ Property [ private $passive = false ]
+ Property [ private $durable = false ]
+ Property [ private $exclusive = false ]
+ Property [ private $auto_delete = true ]
+ Property [ private $arguments = NULL ]
}
- Methods [25] {
@@ -692,15 +692,15 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [3] {
Parameter #0 [ <required> $exchange_name ]
- Parameter #1 [ <optional> $routing_key ]
- Parameter #2 [ <optional> $arguments ]
+ Parameter #1 [ <optional> $routing_key = <default> ]
+ Parameter #2 [ <optional> $arguments = <default> ]
}
}
Method [ <internal:amqp> public method get ] {
- Parameters [1] {
- Parameter #0 [ <optional> $flags ]
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -708,8 +708,8 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [3] {
Parameter #0 [ <required> $callback ]
- Parameter #1 [ <optional> $flags ]
- Parameter #2 [ <optional> $consumer_tag ]
+ Parameter #1 [ <optional> $flags = <default> ]
+ Parameter #2 [ <optional> $consumer_tag = <default> ]
}
}
@@ -717,7 +717,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> $delivery_tag ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #1 [ <optional> $flags = <default> ]
}
}
@@ -725,7 +725,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> $delivery_tag ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #1 [ <optional> $flags = <default> ]
}
}
@@ -733,7 +733,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> $delivery_tag ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #1 [ <optional> $flags = <default> ]
}
}
@@ -746,14 +746,14 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
Method [ <internal:amqp> public method cancel ] {
- Parameters [1] {
- Parameter #0 [ <optional> $consumer_tag ]
+ Parameter #0 [ <optional> $consumer_tag = <default> ]
}
}
Method [ <internal:amqp> public method delete ] {
- Parameters [1] {
- Parameter #0 [ <optional> $flags ]
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -761,8 +761,8 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [3] {
Parameter #0 [ <required> $exchange_name ]
- Parameter #1 [ <optional> $routing_key ]
- Parameter #2 [ <optional> $arguments ]
+ Parameter #1 [ <optional> $routing_key = <default> ]
+ Parameter #2 [ <optional> $arguments = <default> ]
}
}
@@ -804,15 +804,15 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [9] {
- Property [ <default> private $connection ]
- Property [ <default> private $channel ]
- Property [ <default> private $name ]
- Property [ <default> private $type ]
- Property [ <default> private $passive ]
- Property [ <default> private $durable ]
- Property [ <default> private $auto_delete ]
- Property [ <default> private $internal ]
- Property [ <default> private $arguments ]
+ Property [ private $connection = NULL ]
+ Property [ private $channel = NULL ]
+ Property [ private $name = '' ]
+ Property [ private $type = NULL ]
+ Property [ private $passive = false ]
+ Property [ private $durable = false ]
+ Property [ private $auto_delete = false ]
+ Property [ private $internal = false ]
+ Property [ private $arguments = NULL ]
}
- Methods [20] {
@@ -908,7 +908,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [3] {
Parameter #0 [ <required> $exchange_name ]
Parameter #1 [ <required> $routing_key ]
- Parameter #2 [ <optional> $flags ]
+ Parameter #2 [ <optional> $flags = <default> ]
}
}
@@ -917,15 +917,15 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [3] {
Parameter #0 [ <required> $exchange_name ]
Parameter #1 [ <required> $routing_key ]
- Parameter #2 [ <optional> $flags ]
+ Parameter #2 [ <optional> $flags = <default> ]
}
}
Method [ <internal:amqp> public method delete ] {
- Parameters [2] {
- Parameter #0 [ <optional> $exchange_name ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #0 [ <optional> $exchange_name = <default> ]
+ Parameter #1 [ <optional> $flags = <default> ]
}
}
@@ -933,9 +933,9 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [4] {
Parameter #0 [ <required> $message ]
- Parameter #1 [ <optional> $routing_key ]
- Parameter #2 [ <optional> $flags ]
- Parameter #3 [ <optional> array $headers ]
+ Parameter #1 [ <optional> $routing_key = <default> ]
+ Parameter #2 [ <optional> $flags = <default> ]
+ Parameter #3 [ <optional> array $headers = <default> ]
}
}
@@ -971,20 +971,20 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [14] {
- Property [ <default> private $content_type ]
- Property [ <default> private $content_encoding ]
- Property [ <default> private $headers ]
- Property [ <default> private $delivery_mode ]
- Property [ <default> private $priority ]
- Property [ <default> private $correlation_id ]
- Property [ <default> private $reply_to ]
- Property [ <default> private $expiration ]
- Property [ <default> private $message_id ]
- Property [ <default> private $timestamp ]
- Property [ <default> private $type ]
- Property [ <default> private $user_id ]
- Property [ <default> private $app_id ]
- Property [ <default> private $cluster_id ]
+ Property [ private $content_type = '' ]
+ Property [ private $content_encoding = '' ]
+ Property [ private $headers = NULL ]
+ Property [ private $delivery_mode = 1 ]
+ Property [ private $priority = 0 ]
+ Property [ private $correlation_id = '' ]
+ Property [ private $reply_to = '' ]
+ Property [ private $expiration = '' ]
+ Property [ private $message_id = '' ]
+ Property [ private $timestamp = 0 ]
+ Property [ private $type = '' ]
+ Property [ private $user_id = '' ]
+ Property [ private $app_id = '' ]
+ Property [ private $cluster_id = '' ]
}
- Methods [15] {
@@ -1092,12 +1092,12 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [6] {
- Property [ <default> private $body ]
- Property [ <default> private $consumer_tag ]
- Property [ <default> private $delivery_tag ]
- Property [ <default> private $is_redelivery ]
- Property [ <default> private $exchange_name ]
- Property [ <default> private $routing_key ]
+ Property [ private $body = NULL ]
+ Property [ private $consumer_tag = NULL ]
+ Property [ private $delivery_tag = NULL ]
+ Property [ private $is_redelivery = NULL ]
+ Property [ private $exchange_name = NULL ]
+ Property [ private $routing_key = NULL ]
}
- Methods [23] {
@@ -1257,14 +1257,14 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [1] {
- Property [ <default> private $timestamp ]
+ Property [ private $timestamp = NULL ]
}
- Methods [3] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $timestamp ]
+ Parameter #0 [ <optional> $timestamp = <default> ]
}
}
@@ -1278,6 +1278,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
- Parameters [0] {
}
+ - Return [ string ]
}
}
}
@@ -1298,8 +1299,8 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [2] {
- Property [ <default> private $exponent ]
- Property [ <default> private $significand ]
+ Property [ private $exponent = 0 ]
+ Property [ private $significand = 0 ]
}
- Methods [3] {
@@ -1325,7 +1326,7 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
}
- Class [ <internal:amqp> class AMQPException extends Exception implements Throwable ] {
+ Class [ <internal:amqp> class AMQPException extends Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1337,52 +1338,86 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:amqp> class AMQPConnectionException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPConnectionException extends AMQPException implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -1394,52 +1429,86 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:amqp> class AMQPChannelException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPChannelException extends AMQPException implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -1451,52 +1520,86 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:amqp> class AMQPQueueException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPQueueException extends AMQPException implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -1508,52 +1611,86 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:amqp> class AMQPEnvelopeException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPEnvelopeException extends AMQPException implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -1565,53 +1702,87 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [5] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- Property [ <default> public $envelope ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
+ Property [ public $envelope = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:amqp> class AMQPExchangeException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPExchangeException extends AMQPException implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -1623,52 +1794,86 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:amqp> class AMQPValueException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPValueException extends AMQPException implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -1680,47 +1885,81 @@ Extension [ <persistent> extension #128 amqp version 1.11.0RC1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 8279fba..cebc784 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -24,8 +24,8 @@
%global pecl_name amqp
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 1.11.0
-%global upstream_prever RC1
-%global upstream_lower rc1
+#global upstream_prever RC1
+#global upstream_lower rc1
%global buildver %(pkg-config --silence-errors --modversion librabbitmq 2>/dev/null || echo 65536)
@@ -56,10 +56,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -300,6 +296,9 @@ fi
%changelog
+* Wed Dec 1 2021 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+
* Tue Nov 2 2021 Remi Collet <remi@remirepo.net> - 1.11.0~rc1-1
- update to 1.11.0RC1