summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-19 17:43:28 +0200
committerRemi Collet <remi@remirepo.net>2017-10-19 17:43:28 +0200
commitd50af640d7373f9f232155bb6f81314892d34494 (patch)
tree0510adf4816554dc71998fab3e739aaccf4b6fa5
parentdd40c3f08053a220292e9ca86c53099d45f72fe3 (diff)
v1.9.3
-rw-r--r--REFLECTION84
-rw-r--r--php-pecl-amqp.spec9
2 files changed, 84 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index a44e296..fcfa799 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #72 amqp version 1.9.1 ] {
+Extension [ <persistent> extension #72 amqp version 1.9.3 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -82,7 +82,7 @@ Extension [ <persistent> extension #72 amqp version 1.9.1 ] {
Constant [ integer PHP_AMQP_MAX_CHANNELS ] { 256 }
}
- - Classes [14] {
+ - Classes [15] {
Class [ <internal:amqp> class AMQPConnection ] {
- Constants [0] {
@@ -361,13 +361,14 @@ Extension [ <persistent> extension #72 amqp version 1.9.1 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [4] {
Property [ <default> private $connection ]
Property [ <default> private $prefetch_count ]
Property [ <default> private $prefetch_size ]
+ Property [ <default> private $consumers ]
}
- - Methods [19] {
+ - Methods [20] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
@@ -492,6 +493,12 @@ Extension [ <persistent> extension #72 amqp version 1.9.1 ] {
Parameter #0 [ <optional> $timeout ]
}
}
+
+ Method [ <internal:amqp> public method getConsumers ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -996,15 +1003,16 @@ Extension [ <persistent> extension #72 amqp version 1.9.1 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [6] {
Property [ <default> private $body ]
+ Property [ <default> private $consumer_tag ]
Property [ <default> private $delivery_tag ]
Property [ <default> private $is_redelivery ]
Property [ <default> private $exchange_name ]
Property [ <default> private $routing_key ]
}
- - Methods [22] {
+ - Methods [23] {
Method [ <internal:amqp, overwrites AMQPBasicProperties, ctor> public method __construct ] {
- Parameters [0] {
@@ -1023,6 +1031,12 @@ Extension [ <persistent> extension #72 amqp version 1.9.1 ] {
}
}
+ Method [ <internal:amqp> public method getConsumerTag ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:amqp> public method getDeliveryTag ] {
- Parameters [0] {
@@ -1451,6 +1465,64 @@ Extension [ <persistent> extension #72 amqp version 1.9.1 ] {
}
}
+ Class [ <internal:amqp> class AMQPEnvelopeException extends AMQPException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> public $envelope ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:amqp> class AMQPExchangeException extends AMQPException implements Throwable ] {
- Constants [0] {
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 90bfdb1..554422f 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -28,14 +28,14 @@
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
-Version: 1.9.1
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.9.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-BuildRequires: %{?scl_prefix}php-devel > 5.3.0
+BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
#BuildRequires: php-debuginfo valgrind gdb
# Upstream requires 0.5.2, set 0.8.0 to ensure "last" is used.
@@ -306,6 +306,9 @@ fi
%changelog
+* Thu Oct 19 2017 Remi Collet <remi@remirepo.net> - 1.9.3-1
+- Update to 1.9.3 (stable)
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.9.1-3
- rebuild for PHP 7.2.0beta1 new API