summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-04 08:29:00 +0200
committerRemi Collet <remi@remirepo.net>2020-04-04 08:29:00 +0200
commit94041889b3988def9ab9b0a8f8ecbc1f2c180d13 (patch)
treedb9707f0f727f2408c6525a9a0017a2df55c58ed
parentd6068b4bbeeecfe5935a7bce51994ae04b200881 (diff)
v1.10.0
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION129
-rw-r--r--php-pecl-amqp.spec19
3 files changed, 118 insertions, 40 deletions
diff --git a/PHPINFO b/PHPINFO
index fcde918..7db9bba 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,11 +1,11 @@
amqp
-Version => 1.9.4
+Version => 1.10.0
Revision => release
-Compiled => Jan 2 2019 @ 15:02:47
+Compiled => Apr 4 2020 @ 00:00:00
AMQP protocol version => 0-9-1
-librabbitmq version => 0.9.0
+librabbitmq version => 0.10.0
Default max channels per connection => 256
Default max frame size => 131072
Default heartbeats interval => 0
@@ -18,10 +18,14 @@ amqp.timeout => no value => no value
amqp.read_timeout => 0 => 0
amqp.write_timeout => 0 => 0
amqp.connect_timeout => 0 => 0
+amqp.rpc_timeout => 0 => 0
amqp.login => guest => guest
amqp.password => guest => guest
amqp.auto_ack => 0 => 0
amqp.prefetch_count => 3 => 3
+amqp.prefetch_size => 0 => 0
+amqp.global_prefetch_count => 0 => 0
+amqp.global_prefetch_size => 0 => 0
amqp.channel_max => 256 => 256
amqp.frame_max => 131072 => 131072
amqp.heartbeat => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index ee989ab..7760bf7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
+Extension [ <persistent> extension #113 amqp version 1.10.0 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -22,6 +22,9 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
Entry [ amqp.connect_timeout <ALL> ]
Current = '0'
}
+ Entry [ amqp.rpc_timeout <ALL> ]
+ Current = '0'
+ }
Entry [ amqp.login <ALL> ]
Current = 'guest'
}
@@ -34,6 +37,15 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
Entry [ amqp.prefetch_count <ALL> ]
Current = '3'
}
+ Entry [ amqp.prefetch_size <ALL> ]
+ Current = '0'
+ }
+ Entry [ amqp.global_prefetch_count <ALL> ]
+ Current = '0'
+ }
+ Entry [ amqp.global_prefetch_size <ALL> ]
+ Current = '0'
+ }
Entry [ amqp.channel_max <ALL> ]
Current = '256'
}
@@ -61,30 +73,30 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
}
- Constants [24] {
- Constant [ integer AMQP_NOPARAM ] { 0 }
- Constant [ integer AMQP_JUST_CONSUME ] { 1 }
- Constant [ integer AMQP_DURABLE ] { 2 }
- Constant [ integer AMQP_PASSIVE ] { 4 }
- Constant [ integer AMQP_EXCLUSIVE ] { 8 }
- Constant [ integer AMQP_AUTODELETE ] { 16 }
- Constant [ integer AMQP_INTERNAL ] { 32 }
- Constant [ integer AMQP_NOLOCAL ] { 64 }
- Constant [ integer AMQP_AUTOACK ] { 128 }
- Constant [ integer AMQP_IFEMPTY ] { 256 }
- Constant [ integer AMQP_IFUNUSED ] { 512 }
- Constant [ integer AMQP_MANDATORY ] { 1024 }
- Constant [ integer AMQP_IMMEDIATE ] { 2048 }
- Constant [ integer AMQP_MULTIPLE ] { 4096 }
- Constant [ integer AMQP_NOWAIT ] { 8192 }
- Constant [ integer AMQP_REQUEUE ] { 16384 }
+ Constant [ int AMQP_NOPARAM ] { 0 }
+ Constant [ int AMQP_JUST_CONSUME ] { 1 }
+ Constant [ int AMQP_DURABLE ] { 2 }
+ Constant [ int AMQP_PASSIVE ] { 4 }
+ Constant [ int AMQP_EXCLUSIVE ] { 8 }
+ Constant [ int AMQP_AUTODELETE ] { 16 }
+ Constant [ int AMQP_INTERNAL ] { 32 }
+ Constant [ int AMQP_NOLOCAL ] { 64 }
+ Constant [ int AMQP_AUTOACK ] { 128 }
+ Constant [ int AMQP_IFEMPTY ] { 256 }
+ Constant [ int AMQP_IFUNUSED ] { 512 }
+ Constant [ int AMQP_MANDATORY ] { 1024 }
+ Constant [ int AMQP_IMMEDIATE ] { 2048 }
+ Constant [ int AMQP_MULTIPLE ] { 4096 }
+ Constant [ int AMQP_NOWAIT ] { 8192 }
+ Constant [ int AMQP_REQUEUE ] { 16384 }
Constant [ string AMQP_EX_TYPE_DIRECT ] { direct }
Constant [ string AMQP_EX_TYPE_FANOUT ] { fanout }
Constant [ string AMQP_EX_TYPE_TOPIC ] { topic }
Constant [ string AMQP_EX_TYPE_HEADERS ] { headers }
- Constant [ integer AMQP_OS_SOCKET_TIMEOUT_ERRNO ] { 536870923 }
- Constant [ integer PHP_AMQP_MAX_CHANNELS ] { 256 }
- Constant [ integer AMQP_SASL_METHOD_PLAIN ] { 0 }
- Constant [ integer AMQP_SASL_METHOD_EXTERNAL ] { 1 }
+ Constant [ int AMQP_OS_SOCKET_TIMEOUT_ERRNO ] { 536870923 }
+ Constant [ int PHP_AMQP_MAX_CHANNELS ] { 256 }
+ Constant [ int AMQP_SASL_METHOD_PLAIN ] { 0 }
+ Constant [ int AMQP_SASL_METHOD_EXTERNAL ] { 1 }
}
- Classes [15] {
@@ -99,7 +111,7 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
- Static methods [0] {
}
- - Properties [16] {
+ - Properties [18] {
Property [ <default> private $login ]
Property [ <default> private $password ]
Property [ <default> private $host ]
@@ -108,6 +120,7 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
Property [ <default> private $read_timeout ]
Property [ <default> private $write_timeout ]
Property [ <default> private $connect_timeout ]
+ Property [ <default> private $rpc_timeout ]
Property [ <default> private $channel_max ]
Property [ <default> private $frame_max ]
Property [ <default> private $heartbeat ]
@@ -116,9 +129,10 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
Property [ <default> private $cert ]
Property [ <default> private $verify ]
Property [ <default> private $sasl_method ]
+ Property [ <default> private $connection_name ]
}
- - Methods [39] {
+ - Methods [43] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
@@ -272,6 +286,19 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
}
}
+ Method [ <internal:amqp> public method getRpcTimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setRpcTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout ]
+ }
+ }
+
Method [ <internal:amqp> public method getUsedChannels ] {
- Parameters [0] {
@@ -366,6 +393,19 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
Parameter #0 [ <required> $sasl_method ]
}
}
+
+ Method [ <internal:amqp> public method getConnectionName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setConnectionName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $connection_name ]
+ }
+ }
}
}
@@ -380,14 +420,16 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [6] {
Property [ <default> private $connection ]
Property [ <default> private $prefetch_count ]
Property [ <default> private $prefetch_size ]
+ Property [ <default> private $global_prefetch_count ]
+ Property [ <default> private $global_prefetch_size ]
Property [ <default> private $consumers ]
}
- - Methods [20] {
+ - Methods [24] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
@@ -439,11 +481,38 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
}
}
+ Method [ <internal:amqp> public method setGlobalPrefetchSize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $size ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getGlobalPrefetchSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setGlobalPrefetchCount ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $count ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getGlobalPrefetchCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:amqp> public method qos ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $size ]
Parameter #1 [ <required> $count ]
+ Parameter #2 [ <optional> $global ]
}
}
@@ -1216,10 +1285,10 @@ Extension [ <persistent> extension #71 amqp version 1.9.4 ] {
Class [ <internal:amqp> final class AMQPDecimal ] {
- Constants [4] {
- Constant [ public integer EXPONENT_MIN ] { 0 }
- Constant [ public integer EXPONENT_MAX ] { 255 }
- Constant [ public integer SIGNIFICAND_MIN ] { 0 }
- Constant [ public integer SIGNIFICAND_MAX ] { 4294967295 }
+ Constant [ public int EXPONENT_MIN ] { 0 }
+ Constant [ public int EXPONENT_MAX ] { 255 }
+ Constant [ public int SIGNIFICAND_MIN ] { 0 }
+ Constant [ public int SIGNIFICAND_MAX ] { 4294967295 }
}
- Static properties [0] {
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index e296c32..c609145 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-amqp
#
-# Copyright (c) 2012-2019 Remi Collet
+# Copyright (c) 2012-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -32,18 +32,16 @@
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
-Version: 1.9.4
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.10.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-URL: http://pecl.php.net/package/amqp
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+URL: https://pecl.php.net/package/amqp
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 5.6
BuildRequires: %{?scl_prefix}php-pear
-#BuildRequires: php-debuginfo valgrind gdb
# Upstream requires 0.7.1, set 0.8.0 to ensure "last" is used.
-# see https://github.com/pdezwart/php-amqp/pull/347
%if 0%{?fedora} >= 23 || 0%{?rhel} >= 7
BuildRequires: librabbitmq-devel >= 0.8.0
Requires: librabbitmq%{?_isa} >= %{buildver}
@@ -161,6 +159,9 @@ extension = %{pecl_name}.so
; call to AMQPQueue::get() or AMQPQueue::consume() during which
; the AMQP_AUTOACK flag is not set.
;amqp.prefetch_count = 3
+;amqp.prefetch_size = 0
+;amqp.global_prefetch_count =0
+;amqp.global_prefetch_size =0
; The virtual host on the broker to which to connect.
;amqp.vhost = /
@@ -170,6 +171,7 @@ extension = %{pecl_name}.so
;amqp.read_timeout = 0
;amqp.write_timeout = 0
;amqp.connect_timeout = 0
+;amqp.rpc_timeout = 0
;amqp.channel_max = 256
;amqp.frame_max = 131072
@@ -314,6 +316,9 @@ fi
%changelog
+* Sat Apr 4 2020 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.9.4-9
- rebuild for 7.4.0RC1