summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-03 15:41:13 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-03 15:41:13 +0100
commit8e8f6b7b353e554dbb8dd1846650a9e063ebc361 (patch)
treefeab7ccb356eb15e5ec724db3c80115d838bd75b
parente98744403cfc0ad05164aae06c49fe402602c398 (diff)
php-pecl-amqp: 1.6.0 (stable)
-rw-r--r--REFLECTION2
-rw-r--r--amqp-178.patch79
-rw-r--r--amqp-179.patch22
-rw-r--r--php-pecl-amqp.spec18
4 files changed, 8 insertions, 113 deletions
diff --git a/REFLECTION b/REFLECTION
index e5cd8e3..daef67d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #74 amqp version 1.6.0beta4 ] {
+Extension [ <persistent> extension #74 amqp version 1.6.0 ] {
- INI {
Entry [ amqp.host <ALL> ]
diff --git a/amqp-178.patch b/amqp-178.patch
deleted file mode 100644
index 493be50..0000000
--- a/amqp-178.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From e7699fb159dca1d68d419255acee4ea9f532bfa2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 18 Sep 2015 11:38:15 +0200
-Subject: [PATCH] fix build with librabbitmq 0.5, fix #177
-
----
- amqp.c | 4 ++++
- amqp_connection.c | 4 ++++
- amqp_connection.h | 4 +++-
- 3 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/amqp.c b/amqp.c
-index 4c8769b..087e5cd 100644
---- a/amqp.c
-+++ b/amqp.c
-@@ -493,6 +493,10 @@ zend_function_entry amqp_connection_class_functions[] = {
- PHP_ME(amqp_connection_class, getUsedChannels, arginfo_amqp_connection_class_getUsedChannels, ZEND_ACC_PUBLIC)
- PHP_ME(amqp_connection_class, getMaxChannels, arginfo_amqp_connection_class_getMaxChannels, ZEND_ACC_PUBLIC)
- PHP_ME(amqp_connection_class, isPersistent, arginfo_amqp_connection_class_isPersistent, ZEND_ACC_PUBLIC)
-+#if AMQP_VERSION_MAJOR * 100 + AMQP_VERSION_MINOR * 10 + AMQP_VERSION_PATCH > 52
-+ PHP_ME(amqp_connection_class, getHeartbeatInterval, arginfo_amqp_connection_class_getHeartbeatInterval, ZEND_ACC_PUBLIC)
-+ PHP_ME(amqp_connection_class, getMaxFrameSize, arginfo_amqp_connection_class_getMaxFrameSize, ZEND_ACC_PUBLIC)
-+#endif
-
- {NULL, NULL, NULL} /* Must be the last line in amqp_functions[] */
- };
-diff --git a/amqp_connection.c b/amqp_connection.c
-index cae9c12..f65fe3b 100644
---- a/amqp_connection.c
-+++ b/amqp_connection.c
-@@ -141,6 +141,7 @@ HashTable *amqp_connection_object_get_debug_info(zval *object, int *is_temp TSRM
- }
- zend_hash_add(debug_info, "max_channel_id", sizeof("max_channel_id"), &value, sizeof(zval *), NULL);
-
-+#if AMQP_VERSION_MAJOR * 100 + AMQP_VERSION_MINOR * 10 + AMQP_VERSION_PATCH > 52
- MAKE_STD_ZVAL(value);
- if (connection->connection_resource) {
- ZVAL_LONG(value, amqp_get_frame_max(connection->connection_resource->connection_state));
-@@ -156,6 +157,7 @@ HashTable *amqp_connection_object_get_debug_info(zval *object, int *is_temp TSRM
- ZVAL_NULL(value);
- }
- zend_hash_add(debug_info, "heartbeat_interval", sizeof("heartbeat_interval"), &value, sizeof(zval *), NULL);
-+#endif
-
- /* Start adding values */
- return debug_info;
-@@ -1361,6 +1363,7 @@ PHP_METHOD(amqp_connection_class, getMaxChannels)
- }
- /* }}} */
-
-+#if AMQP_VERSION_MAJOR * 100 + AMQP_VERSION_MINOR * 10 + AMQP_VERSION_PATCH > 52
- /* {{{ proto amqp::getMaxFrameSize()
- Get max supported frame size per connection in bytes */
- PHP_METHOD(amqp_connection_class, getMaxFrameSize)
-@@ -1408,6 +1411,7 @@ PHP_METHOD(amqp_connection_class, getHeartbeatInterval)
- RETURN_LONG(amqp_get_heartbeat(connection->connection_resource->connection_state));
- }
- /* }}} */
-+#endif
-
- /* {{{ proto amqp::isPersistent()
- check whether amqp connection is persistent */
-diff --git a/amqp_connection.h b/amqp_connection.h
-index 277e5ff..2c6ef92 100644
---- a/amqp_connection.h
-+++ b/amqp_connection.h
-@@ -68,9 +68,11 @@ PHP_METHOD(amqp_connection_class, getWriteTimeout);
- PHP_METHOD(amqp_connection_class, setWriteTimeout);
-
- PHP_METHOD(amqp_connection_class, getUsedChannels);
--PHP_METHOD(amqp_connection_class, getMaxFrameSize);
- PHP_METHOD(amqp_connection_class, getMaxChannels);
-+#if AMQP_VERSION_MAJOR * 100 + AMQP_VERSION_MINOR * 10 + AMQP_VERSION_PATCH > 52
- PHP_METHOD(amqp_connection_class, getHeartbeatInterval);
-+PHP_METHOD(amqp_connection_class, getMaxFrameSize);
-+#endif
- PHP_METHOD(amqp_connection_class, isPersistent);
-
- /*
diff --git a/amqp-179.patch b/amqp-179.patch
deleted file mode 100644
index 58c7678..0000000
--- a/amqp-179.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 0205ec625f6d585848933d710a2ea267c8c72071 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 18 Sep 2015 11:41:58 +0200
-Subject: [PATCH] honour --with-libdir option
-
----
- config.m4 | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/config.m4 b/config.m4
-index d5b5999..c219769 100644
---- a/config.m4
-+++ b/config.m4
-@@ -80,7 +80,7 @@ if test "$PHP_AMQP" != "no"; then
- fi
- fi
-
-- PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $AMQP_DIR/lib, AMQP_SHARED_LIBADD)
-+ PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $AMQP_DIR/$PHP_LIBDIR, AMQP_SHARED_LIBADD)
- PHP_SUBST(AMQP_SHARED_LIBADD)
-
- AMQP_SOURCES="amqp.c amqp_exchange.c amqp_queue.c amqp_connection.c amqp_connection_resource.c amqp_channel.c amqp_envelope.c amqp_object_store.c"
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 3ab18de..b567985 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -30,28 +30,23 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever beta4
+#global prever beta4
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
Version: 1.6.0
-Release: 0.4.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# https://github.com/pdezwart/php-amqp/pull/178
-Patch0: %{pecl_name}-178.patch
-# https://github.com/pdezwart/php-amqp/pull/179
-Patch1: %{pecl_name}-179.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel > 5.2.0
BuildRequires: %{?scl_prefix}php-pear
%if "%{?vendor}" == "Remi Collet"
-# Upstream requires 0.5.2, set 0.6.0 to ensure "last" is used.
-BuildRequires: librabbitmq-devel >= 0.6.0
+# Upstream requires 0.5.2, set 0.7.0 to ensure "last" is used.
+BuildRequires: librabbitmq-devel >= 0.7.0
%else
BuildRequires: librabbitmq-devel >= 0.5.2
%endif
@@ -112,8 +107,6 @@ sed -e 's/role="test"/role="src"/' -i package.xml
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
-%patch0 -p1 -b .pr178
-%patch1 -p1 -b .pr179
# Upstream often forget to change this
extver=$(sed -n '/#define PHP_AMQP_VERSION/{s/.* "//;s/".*$//;p}' php_amqp.h)
@@ -295,6 +288,9 @@ fi
%changelog
+* Tue Nov 3 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-1
+- update to 1.6.0 (stable)
+
* Fri Sep 18 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-0.4.beta4
- open https://github.com/pdezwart/php-amqp/pull/178 - librabbitmq 0.5
- open https://github.com/pdezwart/php-amqp/pull/179 --with-libdir