summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-03 09:14:30 +0200
committerRemi Collet <remi@php.net>2023-08-03 09:14:30 +0200
commit7b1c8cfecd4ffffa9c2c4e2d0dd9c3b38e88c76b (patch)
tree9c57fc42f43ac35d2036b44d900bfbbde0966493
parentfd227d7195365a73be994c359ddae2702ecd9ddf (diff)
update to 2.0.0beta2
drop patch merged upstream
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION6
-rw-r--r--amqp-pr455.patch22
-rw-r--r--php-pecl-amqp.spec10
4 files changed, 9 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index 00486a9..c08cedd 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,7 +1,7 @@
amqp
-Version => 2.0.0beta1
+Version => 2.0.0beta2
Compiled => Aug 3 2023 @ 00:00:00
AMQP protocol version => 0-9-1
librabbitmq version => 0.13.0
diff --git a/REFLECTION b/REFLECTION
index b951aa0..9ffd23b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #124 amqp version 2.0.0beta1 ] {
+Extension [ <persistent> extension #124 amqp version 2.0.0beta2 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -73,11 +73,11 @@ Extension [ <persistent> extension #124 amqp version 2.0.0beta1 ] {
}
- Constants [32] {
- Constant [ string AMQP_EXTENSION_VERSION ] { 2.0.0beta1 }
+ Constant [ string AMQP_EXTENSION_VERSION ] { 2.0.0beta2 }
Constant [ int AMQP_EXTENSION_VERSION_MAJOR ] { 2 }
Constant [ int AMQP_EXTENSION_VERSION_MINOR ] { 0 }
Constant [ int AMQP_EXTENSION_VERSION_PATCH ] { 0 }
- Constant [ string AMQP_EXTENSION_VERSION_EXTRA ] { beta1 }
+ Constant [ string AMQP_EXTENSION_VERSION_EXTRA ] { beta2 }
Constant [ int AMQP_EXTENSION_VERSION_ID ] { 20000 }
Constant [ int AMQP_NOPARAM ] { 0 }
Constant [ int AMQP_JUST_CONSUME ] { 1 }
diff --git a/amqp-pr455.patch b/amqp-pr455.patch
deleted file mode 100644
index 0d705e3..0000000
--- a/amqp-pr455.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 60ffb76b339dc92f5adcbe44c8852c27769b2250 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 3 Aug 2023 07:41:46 +0200
-Subject: [PATCH] Fix #454 segfault in setPort
-
----
- amqp_connection.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/amqp_connection.c b/amqp_connection.c
-index 40c2859d..d8f71b12 100644
---- a/amqp_connection.c
-+++ b/amqp_connection.c
-@@ -1165,7 +1165,7 @@ static PHP_METHOD(amqp_connection_class, getPort)
- set the port */
- static PHP_METHOD(amqp_connection_class, setPort)
- {
-- int port;
-+ zend_long port;
-
- /* Get the port from the method params */
- if (zend_parse_parameters(ZEND_NUM_ARGS(), "l", &port) == FAILURE) {
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index da57f28..c803fff 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -18,7 +18,7 @@
%global pecl_name amqp
%global ini_name 40-%{pecl_name}.ini
%global upstream_version 2.0.0
-%global upstream_prever beta1
+%global upstream_prever beta2
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -33,8 +33,6 @@ License: PHP-3.01
URL: https://pecl.php.net/package/amqp
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: %{pecl_name}-pr455.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.4
@@ -96,8 +94,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
-
# Upstream often forget to change this
extver=$(sed -n '/#define PHP_AMQP_VERSION /{s/.* "//;s/".*$//;p}' php_amqp_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -280,6 +276,10 @@ fi
%changelog
+* Thu Aug 3 2023 Remi Collet <remi@remirepo.net> - 2.0.0~beta2-1
+- update to 2.0.0beta2
+- drop patch merged upstream
+
* Thu Aug 3 2023 Remi Collet <remi@remirepo.net> - 2.0.0~beta1-1
- update to 2.0.0beta1
- fix segfault in test suite using patch from