summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-12 16:52:08 +0200
committerRemi Collet <remi@php.net>2023-10-12 16:52:08 +0200
commit477b0b60926ff60d921e00247b87de42bca3f4eb (patch)
tree555e540abf92c0897a3a30d94954740467fcc71e
parent0972f1442e3e75e8ecdb33b9b9cb76c81b50cd4c (diff)
update to 2.1.1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION10
-rw-r--r--php-pecl-amqp.spec5
3 files changed, 11 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index 37c8854..2f09d94 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,8 +1,8 @@
amqp
-Version => 2.1.0
-Compiled => Sep 7 2023 @ 00:00:00
+Version => 2.1.1
+Compiled => Oct 12 2023 @ 00:00:00
AMQP protocol version => 0-9-1
librabbitmq version => 0.13.0
Default max channels per connection => 256
diff --git a/REFLECTION b/REFLECTION
index 58d5df0..29b8706 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 amqp version 2.1.0 ] {
+Extension [ <persistent> extension #126 amqp version 2.1.1 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -79,12 +79,12 @@ Extension [ <persistent> extension #125 amqp version 2.1.0 ] {
}
- Constants [32] {
- Constant [ string AMQP_EXTENSION_VERSION ] { 2.1.0 }
+ Constant [ string AMQP_EXTENSION_VERSION ] { 2.1.1 }
Constant [ int AMQP_EXTENSION_VERSION_MAJOR ] { 2 }
Constant [ int AMQP_EXTENSION_VERSION_MINOR ] { 1 }
- Constant [ int AMQP_EXTENSION_VERSION_PATCH ] { 0 }
+ Constant [ int AMQP_EXTENSION_VERSION_PATCH ] { 1 }
Constant [ string AMQP_EXTENSION_VERSION_EXTRA ] { }
- Constant [ int AMQP_EXTENSION_VERSION_ID ] { 20100 }
+ Constant [ int AMQP_EXTENSION_VERSION_ID ] { 20101 }
Constant [ int AMQP_NOPARAM ] { 0 }
Constant [ int AMQP_JUST_CONSUME ] { 1 }
Constant [ int AMQP_DURABLE ] { 2 }
@@ -1885,7 +1885,7 @@ Extension [ <persistent> extension #125 amqp version 2.1.0 ] {
- Parameters [1] {
Parameter #0 [ <required> string $headerName ]
}
- - Return [ ?string ]
+ - Return [ mixed ]
}
Method [ <internal:amqp> public method hasHeader ] {
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 63fad4b..43cd57c 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -18,7 +18,7 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name amqp
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 2.1.0
+%global upstream_version 2.1.1
#global upstream_prever RC1
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -288,6 +288,9 @@ fi
%changelog
+* Thu Oct 12 2023 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+
* Thu Sep 7 2023 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0
- enable test suite