summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-18 10:17:34 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-18 10:17:34 +0200
commit37cc772393863eebf7e87a5331c1cbacaf49ad16 (patch)
tree974af6b4515f97993a5a7ac98e16c0b7f4193899
parente4d04098836583e103fa535a6144d20823515888 (diff)
php-pecl-amqp: 1.6.0beta4 (remi-test)
-rw-r--r--REFLECTION47
-rw-r--r--php-pecl-amqp.spec25
2 files changed, 54 insertions, 18 deletions
diff --git a/REFLECTION b/REFLECTION
index 82ebbc7..8266e78 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
+Extension [ <persistent> extension #74 amqp version 1.6.0beta4 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -34,10 +34,20 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
Entry [ amqp.prefetch_count <ALL> ]
Current = '3'
}
+ Entry [ amqp.channel_max <ALL> ]
+ Current = '256'
+ }
+ Entry [ amqp.frame_max <ALL> ]
+ Current = '131072'
+ }
+ Entry [ amqp.heartbeat <ALL> ]
+ Current = '0'
+ }
}
- - Constants [21] {
+ - Constants [22] {
Constant [ integer AMQP_NOPARAM ] { 0 }
+ Constant [ integer AMQP_JUST_CONSUME ] { 1 }
Constant [ integer AMQP_DURABLE ] { 2 }
Constant [ integer AMQP_PASSIVE ] { 4 }
Constant [ integer AMQP_EXCLUSIVE ] { 8 }
@@ -364,7 +374,7 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
- Properties [0] {
}
- - Methods [23] {
+ - Methods [24] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
@@ -522,6 +532,12 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
}
}
+ Method [ <internal:amqp> public method getConsumerTag ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal, deprecated:amqp> public method declare ] {
- Parameters [0] {
@@ -836,7 +852,7 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -846,6 +862,9 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -890,7 +909,7 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -900,6 +919,9 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -944,7 +966,7 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -954,6 +976,9 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -998,7 +1023,7 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1008,6 +1033,9 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -1052,7 +1080,7 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
Property [ <default> protected $line ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
@@ -1062,6 +1090,9 @@ Extension [ <persistent> extension #74 amqp version 1.6.0beta3 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 6ca6a14..c7cbcc0 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -23,19 +23,19 @@
%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%global with_tests 0%{?_with_tests:1}
%global pecl_name amqp
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever beta3
+%global prever beta4
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
Version: 1.6.0
-Release: 0.2.%{prever}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
@@ -96,7 +96,7 @@ such as RabbitMQ, OpenAMQP and Qpid, giving you the ability to create and
delete exchanges and queues, as well as publish to any exchange and consume
from any queue.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
@@ -119,8 +119,6 @@ cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension = %{pecl_name}.so
-; http://www.php.net/manual/en/amqp.configuration.php
-
; Whether calls to AMQPQueue::get() and AMQPQueue::consume()
; should require that the client explicitly acknowledge messages.
; Setting this value to 1 will pass in the AMQP_AUTOACK flag to
@@ -148,10 +146,14 @@ extension = %{pecl_name}.so
;amqp.vhost = /
; Timeout
-;amqp.timeout=
-;amqp.read_timeout=0
-;amqp.write_timeout=0
-;amqp.connect_timeout=0
+;amqp.timeout =
+;amqp.read_timeout = 0
+;amqp.write_timeout = 0
+;amqp.connect_timeout = 0
+
+;amqp.channel_max = 256
+;amqp.frame_max = 131072
+;amqp.heartbeat = 0
EOF
%if %{with_zts}
@@ -285,6 +287,9 @@ fi
%changelog
+* Fri Sep 18 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-0.3.beta4
+- update to 1.6.0beta4
+
* Fri Jun 19 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-0.2.beta3
- allow build against rh-php56 (as more-php56)