summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-21 08:07:33 +0200
committerRemi Collet <remi@php.net>2023-08-21 08:07:33 +0200
commit3279d076b4e3e571c9ad4db2a9fa9939b584e8aa (patch)
treedf7cef00387d3794b5e1ce046ca807e8e84e88a5
parent6133bd992f2399d3835930a667cef6fb8a1d4656 (diff)
update to 2.0.0
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION30
-rw-r--r--php-pecl-amqp.spec23
3 files changed, 37 insertions, 24 deletions
diff --git a/PHPINFO b/PHPINFO
index 4fd2fed..c4dcb7c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,8 +1,8 @@
amqp
-Version => 2.0.0RC1
-Compiled => Aug 17 2023 @ 00:00:00
+Version => 2.0.0
+Compiled => Aug 21 2023 @ 00:00:00
AMQP protocol version => 0-9-1
librabbitmq version => 0.13.0
Default max channels per connection => 256
@@ -32,4 +32,6 @@ amqp.cacert => no value => no value
amqp.cert => no value => no value
amqp.key => no value => no value
amqp.verify => 1 => 1
-amqp.sasl_method => no value => no value
+amqp.sasl_method => AMQP_SASL_METHOD_PLAIN => AMQP_SASL_METHOD_PLAIN
+amqp.serialization_depth => 128 => 128
+amqp.deserialization_depth => 128 => 128
diff --git a/REFLECTION b/REFLECTION
index 36a555c..5504ed9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
+Extension [ <persistent> extension #125 amqp version 2.0.0 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -68,16 +68,22 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
Current = '1'
}
Entry [ amqp.sasl_method <ALL> ]
- Current = ''
+ Current = 'AMQP_SASL_METHOD_PLAIN'
+ }
+ Entry [ amqp.serialization_depth <ALL> ]
+ Current = '128'
+ }
+ Entry [ amqp.deserialization_depth <ALL> ]
+ Current = '128'
}
}
- Constants [32] {
- Constant [ string AMQP_EXTENSION_VERSION ] { 2.0.0RC1 }
+ Constant [ string AMQP_EXTENSION_VERSION ] { 2.0.0 }
Constant [ int AMQP_EXTENSION_VERSION_MAJOR ] { 2 }
Constant [ int AMQP_EXTENSION_VERSION_MINOR ] { 0 }
Constant [ int AMQP_EXTENSION_VERSION_PATCH ] { 0 }
- Constant [ string AMQP_EXTENSION_VERSION_EXTRA ] { RC1 }
+ Constant [ string AMQP_EXTENSION_VERSION_EXTRA ] { }
Constant [ int AMQP_EXTENSION_VERSION_ID ] { 20000 }
Constant [ int AMQP_NOPARAM ] { 0 }
Constant [ int AMQP_JUST_CONSUME ] { 1 }
@@ -1357,7 +1363,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
Method [ <internal:amqp> public method get ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #0 [ <optional> ?int $flags = null ]
}
- Return [ ?AMQPEnvelope ]
}
@@ -1366,7 +1372,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
- Parameters [3] {
Parameter #0 [ <optional> ?callable $callback = null ]
- Parameter #1 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #1 [ <optional> ?int $flags = null ]
Parameter #2 [ <optional> ?string $consumerTag = null ]
}
- Return [ void ]
@@ -1376,7 +1382,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> int $deliveryTag ]
- Parameter #1 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #1 [ <optional> ?int $flags = null ]
}
- Return [ void ]
}
@@ -1385,7 +1391,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> int $deliveryTag ]
- Parameter #1 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #1 [ <optional> ?int $flags = null ]
}
- Return [ void ]
}
@@ -1394,7 +1400,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <required> int $deliveryTag ]
- Parameter #1 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #1 [ <optional> ?int $flags = null ]
}
- Return [ void ]
}
@@ -1417,7 +1423,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
Method [ <internal:amqp> public method delete ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #0 [ <optional> ?int $flags = null ]
}
- Return [ int ]
}
@@ -1616,7 +1622,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
- Parameters [2] {
Parameter #0 [ <optional> ?string $exchangeName = null ]
- Parameter #1 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #1 [ <optional> ?int $flags = null ]
}
- Return [ void ]
}
@@ -1626,7 +1632,7 @@ Extension [ <persistent> extension #125 amqp version 2.0.0RC1 ] {
- Parameters [4] {
Parameter #0 [ <required> string $message ]
Parameter #1 [ <optional> ?string $routingKey = null ]
- Parameter #2 [ <optional> int $flags = AMQP_NOPARAM ]
+ Parameter #2 [ <optional> ?int $flags = null ]
Parameter #3 [ <optional> array $headers = [] ]
}
- Return [ void ]
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index f7b2034..df2b1db 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -10,18 +10,18 @@
# Please, preserve the changelog entries
#
-%{?scl:%scl_package php-pecl-amqp}
+%{?scl:%scl_package php-pecl-amqp}
-%bcond_with tests
+%bcond_with tests
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name amqp
-%global ini_name 40-%{pecl_name}.ini
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name amqp
+%global ini_name 40-%{pecl_name}.ini
%global upstream_version 2.0.0
-%global upstream_prever RC1
+#global upstream_prever RC1
%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
-%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
-%global _configure ../%{sources}/configure
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
%global buildver %(pkg-config --silence-errors --modversion librabbitmq 2>/dev/null || echo 65536)
@@ -150,7 +150,9 @@ extension = %{pecl_name}.so
;amqp.cert = ''
;amqp.key = ''
;amqp.verify = 1
-;amqp.sasl_method = ''
+;amqp.sasl_method = 'AMQP_SASL_METHOD_PLAIN'
+;amqp.serialization_depth = 128
+;amqp.deserialization_depth = 128
EOF
mkdir NTS
@@ -276,6 +278,9 @@ fi
%changelog
+* Mon Aug 21 2023 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+
* Thu Aug 17 2023 Remi Collet <remi@remirepo.net> - 2.0.0~rc1-1
- update to 2.0.0rc1