summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-12 11:02:41 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-12 11:02:41 +0100
commit1f30180f4a500d34dc4f2570dbba6af1290dc7e6 (patch)
tree00feae9db8a1764f550892f0a9c69fed18ba8191
parentb86f6cadd1f1a5da94c6cf5303196186bb00a932 (diff)
php-pecl-amqp: 1.7.0alpha1
-rw-r--r--REFLECTION-DEV1207
-rw-r--r--amqp-pr182.patch43
-rw-r--r--php-pecl-amqp-dev.spec15
3 files changed, 1261 insertions, 4 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
new file mode 100644
index 0000000..de8b6e9
--- /dev/null
+++ b/REFLECTION-DEV
@@ -0,0 +1,1207 @@
+Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
+
+ - INI {
+ Entry [ amqp.host <ALL> ]
+ Current = 'localhost'
+ }
+ Entry [ amqp.vhost <ALL> ]
+ Current = '/'
+ }
+ Entry [ amqp.port <ALL> ]
+ Current = '5672'
+ }
+ Entry [ amqp.timeout <ALL> ]
+ Current = ''
+ }
+ Entry [ amqp.read_timeout <ALL> ]
+ Current = '0'
+ }
+ Entry [ amqp.write_timeout <ALL> ]
+ Current = '0'
+ }
+ Entry [ amqp.connect_timeout <ALL> ]
+ Current = '0'
+ }
+ Entry [ amqp.login <ALL> ]
+ Current = 'guest'
+ }
+ Entry [ amqp.password <ALL> ]
+ Current = 'guest'
+ }
+ Entry [ amqp.auto_ack <ALL> ]
+ Current = '0'
+ }
+ Entry [ amqp.prefetch_count <ALL> ]
+ Current = '3'
+ }
+ Entry [ amqp.channel_max <ALL> ]
+ Current = '256'
+ }
+ Entry [ amqp.frame_max <ALL> ]
+ Current = '131072'
+ }
+ Entry [ amqp.heartbeat <ALL> ]
+ Current = '0'
+ }
+ }
+
+ - Constants [22] {
+ Constant [ integer AMQP_NOPARAM ] { 0 }
+ Constant [ integer AMQP_JUST_CONSUME ] { 1 }
+ Constant [ integer AMQP_DURABLE ] { 2 }
+ Constant [ integer AMQP_PASSIVE ] { 4 }
+ Constant [ integer AMQP_EXCLUSIVE ] { 8 }
+ Constant [ integer AMQP_AUTODELETE ] { 16 }
+ Constant [ integer AMQP_INTERNAL ] { 32 }
+ Constant [ integer AMQP_NOLOCAL ] { 64 }
+ Constant [ integer AMQP_AUTOACK ] { 128 }
+ Constant [ integer AMQP_IFEMPTY ] { 256 }
+ Constant [ integer AMQP_IFUNUSED ] { 512 }
+ Constant [ integer AMQP_MANDATORY ] { 1024 }
+ Constant [ integer AMQP_IMMEDIATE ] { 2048 }
+ Constant [ integer AMQP_MULTIPLE ] { 4096 }
+ Constant [ integer AMQP_NOWAIT ] { 8192 }
+ Constant [ integer AMQP_REQUEUE ] { 16384 }
+ Constant [ string AMQP_EX_TYPE_DIRECT ] { direct }
+ Constant [ string AMQP_EX_TYPE_FANOUT ] { fanout }
+ Constant [ string AMQP_EX_TYPE_TOPIC ] { topic }
+ Constant [ string AMQP_EX_TYPE_HEADERS ] { headers }
+ Constant [ integer AMQP_OS_SOCKET_TIMEOUT_ERRNO ] { 536870923 }
+ Constant [ integer PHP_AMQP_MAX_CHANNELS ] { 256 }
+ }
+
+ - Classes [10] {
+ Class [ <internal:amqp> class AMQPConnection ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [11] {
+ Property [ <default> private $login ]
+ Property [ <default> private $password ]
+ Property [ <default> private $host ]
+ Property [ <default> private $vhost ]
+ Property [ <default> private $port ]
+ Property [ <default> private $read_timeout ]
+ Property [ <default> private $write_timeout ]
+ Property [ <default> private $connect_timeout ]
+ Property [ <default> private $channel_max ]
+ Property [ <default> private $frame_max ]
+ Property [ <default> private $heartbeat ]
+ }
+
+ - Methods [29] {
+ Method [ <internal:amqp, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array $credentials ]
+ }
+ }
+
+ Method [ <internal:amqp> public method isConnected ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method connect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method pconnect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method pdisconnect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method disconnect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method reconnect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method preconnect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getLogin ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setLogin ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $login ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getPassword ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setPassword ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $password ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getHost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setHost ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $host ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getPort ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setPort ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $port ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getVhost ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setVhost ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $vhost ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getTimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getReadTimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setReadTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getWriteTimeout ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setWriteTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getUsedChannels ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getMaxChannels ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method isPersistent ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getHeartbeatInterval ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getMaxFrameSize ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPChannel ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> private $connection ]
+ Property [ <default> private $prefetch_count ]
+ Property [ <default> private $prefetch_size ]
+ }
+
+ - Methods [13] {
+ Method [ <internal:amqp, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> AMQPConnection $amqp_connection ]
+ }
+ }
+
+ Method [ <internal:amqp> public method isConnected ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getChannelId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setPrefetchSize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $size ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getPrefetchSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setPrefetchCount ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $count ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getPrefetchCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method qos ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $size ]
+ Parameter #1 [ <required> $count ]
+ }
+ }
+
+ Method [ <internal:amqp> public method startTransaction ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method commitTransaction ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method rollbackTransaction ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getConnection ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method basicRecover ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $requeue ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPQueue ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [9] {
+ Property [ <default> private $connection ]
+ Property [ <default> private $channel ]
+ Property [ <default> private $name ]
+ Property [ <default> private $consumer_tag ]
+ Property [ <default> private $passive ]
+ Property [ <default> private $durable ]
+ Property [ <default> private $exclusive ]
+ Property [ <default> private $auto_delete ]
+ Property [ <default> private $arguments ]
+ }
+
+ - Methods [25] {
+ Method [ <internal:amqp, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> AMQPChannel $amqp_channel ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $queue_name ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getFlags ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setFlags ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getArgument ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $argument ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getArguments ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setArgument ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:amqp> public method setArguments ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $arguments ]
+ }
+ }
+
+ Method [ <internal:amqp> public method hasArgument ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:amqp> public method declareQueue ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method bind ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $exchange_name ]
+ Parameter #1 [ <optional> $routing_key ]
+ Parameter #2 [ <optional> $arguments ]
+ }
+ }
+
+ Method [ <internal:amqp> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method consume ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $callback ]
+ Parameter #1 [ <optional> $flags ]
+ Parameter #2 [ <optional> $consumer_tag ]
+ }
+ }
+
+ Method [ <internal:amqp> public method ack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $delivery_tag ]
+ Parameter #1 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method nack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $delivery_tag ]
+ Parameter #1 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method reject ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $delivery_tag ]
+ Parameter #1 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method purge ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method cancel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $consumer_tag ]
+ }
+ }
+
+ Method [ <internal:amqp> public method delete ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method unbind ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $exchange_name ]
+ Parameter #1 [ <optional> $routing_key ]
+ Parameter #2 [ <optional> $arguments ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getChannel ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getConnection ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getConsumerTag ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal, deprecated:amqp> public method declare ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPExchange ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [9] {
+ Property [ <default> private $connection ]
+ Property [ <default> private $channel ]
+ Property [ <default> private $name ]
+ Property [ <default> private $type ]
+ Property [ <default> private $passive ]
+ Property [ <default> private $durable ]
+ Property [ <default> private $auto_delete ]
+ Property [ <default> private $internal ]
+ Property [ <default> private $arguments ]
+ }
+
+ - Methods [20] {
+ Method [ <internal:amqp, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> AMQPChannel $amqp_channel ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setName ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $exchange_name ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getFlags ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setFlags ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $exchange_type ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getArgument ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $argument ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getArguments ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setArgument ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:amqp> public method setArguments ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $arguments ]
+ }
+ }
+
+ Method [ <internal:amqp> public method hasArgument ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $argument ]
+ }
+ }
+
+ Method [ <internal:amqp> public method declareExchange ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method bind ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $exchange_name ]
+ Parameter #1 [ <required> $routing_key ]
+ Parameter #2 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method unbind ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $exchange_name ]
+ Parameter #1 [ <required> $routing_key ]
+ Parameter #2 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method delete ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $exchange_name ]
+ Parameter #1 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:amqp> public method publish ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $routing_key ]
+ Parameter #2 [ <optional> $flags ]
+ Parameter #3 [ <optional> array $headers ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getChannel ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getConnection ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal, deprecated:amqp> public method declare ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPEnvelope ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [18] {
+ Property [ <default> private $body ]
+ Property [ <default> private $delivery_tag ]
+ Property [ <default> private $is_redelivery ]
+ Property [ <default> private $exchange_name ]
+ Property [ <default> private $routing_key ]
+ Property [ <default> private $content_type ]
+ Property [ <default> private $content_encoding ]
+ Property [ <default> private $headers ]
+ Property [ <default> private $delivery_mode ]
+ Property [ <default> private $priority ]
+ Property [ <default> private $correlation_id ]
+ Property [ <default> private $reply_to ]
+ Property [ <default> private $expiration ]
+ Property [ <default> private $message_id ]
+ Property [ <default> private $timestamp ]
+ Property [ <default> private $type ]
+ Property [ <default> private $user_id ]
+ Property [ <default> private $app_id ]
+ }
+
+ - Methods [21] {
+ Method [ <internal:amqp, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getBody ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getRoutingKey ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getDeliveryTag ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getDeliveryMode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getExchangeName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method isRedelivery ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getContentType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getContentEncoding ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getPriority ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getExpiration ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getUserId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getAppId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getMessageId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getReplyTo ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getCorrelationId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getHeaders ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method getHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:amqp> public method hasHeader ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPConnectionException extends AMQPException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPChannelException extends AMQPException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPQueueException extends AMQPException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPExchangeException extends AMQPException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/amqp-pr182.patch b/amqp-pr182.patch
new file mode 100644
index 0000000..ed2905e
--- /dev/null
+++ b/amqp-pr182.patch
@@ -0,0 +1,43 @@
+From b5f8ad6da275665dfb871e478a676969bda02d3c Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 12 Nov 2015 10:41:54 +0100
+Subject: [PATCH] fix build with old gcc
+
+---
+ php_amqp.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/php_amqp.h b/php_amqp.h
+index 49afd55..ef13d44 100644
+--- a/php_amqp.h
++++ b/php_amqp.h
+@@ -118,7 +118,7 @@ typedef struct _amqp_channel_object {
+ #endif
+ } amqp_channel_object;
+
+-typedef struct _amqp_connection_resource {
++struct _amqp_connection_resource {
+ zend_bool is_connected;
+ zend_bool is_persistent;
+ zend_bool is_dirty;
+@@ -131,9 +131,9 @@ typedef struct _amqp_connection_resource {
+ PHP5to7_param_str_len_type_t resource_key_len;
+ amqp_connection_state_t connection_state;
+ amqp_socket_t *socket;
+-} amqp_connection_resource;
++};
+
+-typedef struct _amqp_connection_object {
++struct _amqp_connection_object {
+ #if PHP_MAJOR_VERSION >= 7
+ amqp_connection_resource *connection_resource;
+ zend_object zo;
+@@ -141,7 +141,7 @@ typedef struct _amqp_connection_object {
+ zend_object zo;
+ amqp_connection_resource *connection_resource;
+ #endif
+-} amqp_connection_object;
++};
+
+ #define DEFAULT_PORT "5672" /* default AMQP port */
+ #define DEFAULT_HOST "localhost"
diff --git a/php-pecl-amqp-dev.spec b/php-pecl-amqp-dev.spec
index 44f5370..bdace1f 100644
--- a/php-pecl-amqp-dev.spec
+++ b/php-pecl-amqp-dev.spec
@@ -22,7 +22,7 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global pecl_name amqp
%if "%{php_version}" < "5.6"
@@ -30,17 +30,20 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-#global prever beta4
+%global prever alpha1
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
-Version: 1.6.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.7.0
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+# https://github.com/pdezwart/php-amqp/pull/182
+Patch0: %{pecl_name}-pr182.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel > 5.2.0
BuildRequires: %{?scl_prefix}php-pear
@@ -107,6 +110,7 @@ sed -e 's/role="test"/role="src"/' -i package.xml
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
+%patch0 -p1 -b .pr182
# Upstream often forget to change this
extver=$(sed -n '/#define PHP_AMQP_VERSION/{s/.* "//;s/".*$//;p}' php_amqp.h)
@@ -288,6 +292,9 @@ fi
%changelog
+* Thu Nov 12 2015 Remi Collet <remi@fedoraproject.org> - 1.7.0-0.1.alpha1
+- update to 1.7.0alpha1
+
* Tue Nov 3 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-2
- update to 1.6.0 (stable)
- fix typo in config file