summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-26 11:02:31 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-26 11:02:31 +0100
commit03c5fed6154a6375690e96c5f839d5fd22713f8e (patch)
tree1d9a085a5eb3ea4fe70d5e85b3fd254b5d6c1c30
parent566b27182e4aa7c37e90317d3c9332f01959e0b5 (diff)
php-pecl-amqp: 1.7.0alpha2
-rw-r--r--REFLECTION-DEV92
-rw-r--r--amqp-pr182.patch43
-rw-r--r--php-pecl-amqp-dev.spec11
3 files changed, 51 insertions, 95 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index de8b6e9..fb6ae1b 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
+Extension [ <persistent> extension #74 amqp version 1.7.0alpha2 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -918,7 +918,7 @@ Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
}
}
- Class [ <internal:amqp> class AMQPException extends Exception implements Throwable ] {
+ Class [ <internal:amqp> class AMQPException extends Exception ] {
- Constants [0] {
}
@@ -949,33 +949,33 @@ Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:amqp> class AMQPConnectionException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPConnectionException extends AMQPException ] {
- Constants [0] {
}
@@ -1006,33 +1006,33 @@ Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:amqp> class AMQPChannelException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPChannelException extends AMQPException ] {
- Constants [0] {
}
@@ -1063,33 +1063,33 @@ Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:amqp> class AMQPQueueException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPQueueException extends AMQPException ] {
- Constants [0] {
}
@@ -1120,33 +1120,33 @@ Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
- Class [ <internal:amqp> class AMQPExchangeException extends AMQPException implements Throwable ] {
+ Class [ <internal:amqp> class AMQPExchangeException extends AMQPException ] {
- Constants [0] {
}
@@ -1177,28 +1177,28 @@ Extension [ <persistent> extension #71 amqp version 1.7.0alpha1 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
}
}
}
diff --git a/amqp-pr182.patch b/amqp-pr182.patch
deleted file mode 100644
index ed2905e..0000000
--- a/amqp-pr182.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From b5f8ad6da275665dfb871e478a676969bda02d3c Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 12 Nov 2015 10:41:54 +0100
-Subject: [PATCH] fix build with old gcc
-
----
- php_amqp.h | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/php_amqp.h b/php_amqp.h
-index 49afd55..ef13d44 100644
---- a/php_amqp.h
-+++ b/php_amqp.h
-@@ -118,7 +118,7 @@ typedef struct _amqp_channel_object {
- #endif
- } amqp_channel_object;
-
--typedef struct _amqp_connection_resource {
-+struct _amqp_connection_resource {
- zend_bool is_connected;
- zend_bool is_persistent;
- zend_bool is_dirty;
-@@ -131,9 +131,9 @@ typedef struct _amqp_connection_resource {
- PHP5to7_param_str_len_type_t resource_key_len;
- amqp_connection_state_t connection_state;
- amqp_socket_t *socket;
--} amqp_connection_resource;
-+};
-
--typedef struct _amqp_connection_object {
-+struct _amqp_connection_object {
- #if PHP_MAJOR_VERSION >= 7
- amqp_connection_resource *connection_resource;
- zend_object zo;
-@@ -141,7 +141,7 @@ typedef struct _amqp_connection_object {
- zend_object zo;
- amqp_connection_resource *connection_resource;
- #endif
--} amqp_connection_object;
-+};
-
- #define DEFAULT_PORT "5672" /* default AMQP port */
- #define DEFAULT_HOST "localhost"
diff --git a/php-pecl-amqp-dev.spec b/php-pecl-amqp-dev.spec
index bdace1f..3ecb7be 100644
--- a/php-pecl-amqp-dev.spec
+++ b/php-pecl-amqp-dev.spec
@@ -30,20 +30,17 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever alpha1
+%global prever alpha2
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
Version: 1.7.0
-Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# https://github.com/pdezwart/php-amqp/pull/182
-Patch0: %{pecl_name}-pr182.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel > 5.2.0
BuildRequires: %{?scl_prefix}php-pear
@@ -110,7 +107,6 @@ sed -e 's/role="test"/role="src"/' -i package.xml
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
-%patch0 -p1 -b .pr182
# Upstream often forget to change this
extver=$(sed -n '/#define PHP_AMQP_VERSION/{s/.* "//;s/".*$//;p}' php_amqp.h)
@@ -292,6 +288,9 @@ fi
%changelog
+* Sat Dec 26 2015 Remi Collet <remi@fedoraproject.org> - 1.7.0-0.2.alpha2
+- update to 1.7.0alpha2
+
* Thu Nov 12 2015 Remi Collet <remi@fedoraproject.org> - 1.7.0-0.1.alpha1
- update to 1.7.0alpha1