summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION59
-rw-r--r--php-pecl-ahocorasick.spec11
2 files changed, 69 insertions, 1 deletions
diff --git a/REFLECTION b/REFLECTION
index 96af1b7..862c7ed 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -14,5 +14,64 @@ Extension [ <persistent> extension #73 ahocorasick version 2.0 ] {
Function [ <internal:ahocorasick> function ahocorasick_add_patterns ] {
}
}
+
+ - Classes [1] {
+ Class [ <internal:ahocorasick> class AhoException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+ }
}
diff --git a/php-pecl-ahocorasick.spec b/php-pecl-ahocorasick.spec
index 304ee92..035aab8 100644
--- a/php-pecl-ahocorasick.spec
+++ b/php-pecl-ahocorasick.spec
@@ -23,12 +23,14 @@
Summary: Effective Aho-Corasick string pattern matching algorithm
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.0.2
+Version: 0.0.3
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP and LGPLv3
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://github.com/ph4r05/php_aho_corasick/pull/11.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -94,6 +96,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .pr11
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_AHOCORASICK_VERSION/{s/.* "//;s/".*$//;p}' src/php_ahocorasick.h)
if test "x${extver}" != "x%{version}"; then
@@ -227,6 +231,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Mar 14 2019 Remi Collet <remi@remirepo.net> - 0.0.3-1
+- update to 0.0.3
+- open https://github.com/ph4r05/php_aho_corasick/pull/11
+ fix error: format not a string literal and no format arguments
+
* Thu Feb 14 2019 Remi Collet <remi@remirepo.net> - 0.0.2-1
- update to 0.0.2