summaryrefslogtreecommitdiffstats
path: root/php-pear.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pear.spec')
-rw-r--r--php-pear.spec92
1 files changed, 6 insertions, 86 deletions
diff --git a/php-pear.spec b/php-pear.spec
index 4e624f0..5fa5448 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -39,8 +39,8 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
-Version: 1.10.15
-Release: 3%{?dist}
+Version: 1.10.16
+Release: 1%{?dist}
Epoch: 1
# BSD-2-Clause: PEAR, PEAR_Manpages, Archive_Tar, Console_Getopt
# BSD-3-Clause: XML_Util
@@ -99,26 +99,6 @@ Provides: %{?scl_prefix}php-autoloader(pear/structures_graph) = %{structver}
Provides: %{?scl_prefix}php-autoloader(pear/xml_util) = %{xmlutil}
%endif
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# From other third party
-Obsoletes: php53-pear <= %{epoch}:%{version}
-Obsoletes: php53u-pear <= %{epoch}:%{version}
-Obsoletes: php54-pear <= %{epoch}:%{version}
-Obsoletes: php54w-pear <= %{epoch}:%{version}
-Obsoletes: php55u-pear <= %{epoch}:%{version}
-Obsoletes: php55w-pear <= %{epoch}:%{version}
-Obsoletes: php56u-pear <= %{epoch}:%{version}
-Obsoletes: php56w-pear <= %{epoch}:%{version}
-Obsoletes: php70u-pear <= %{epoch}:%{version}
-Obsoletes: php70w-pear <= %{epoch}:%{version}
-Obsoletes: php71u-pear <= %{epoch}:%{version}
-Obsoletes: pear1u <= %{epoch}:%{version}
-Obsoletes: pear1 <= %{epoch}:%{version}
-Obsoletes: php71w-pear <= %{epoch}:%{version}
-Obsoletes: php72w-pear <= %{epoch}:%{version}
-%endif
-
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}}
# Archive_Tar requires 5.2
# XML_Util, Structures_Graph require 5.3
# Console_Getopt requires 5.4
@@ -139,7 +119,7 @@ Requires: %{?scl_prefix}php-bz2
# Structures_Graph: none
# XML_Util: pcre
# optional: overload and xdebug
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8 && 0%{!?scl:1}
+%if 0%{!?scl:1}
%global with_html_dir 0
# for /var/www/html ownership
Requires: httpd-filesystem
@@ -147,10 +127,8 @@ Requires: httpd-filesystem
%global with_html_dir 1
%endif
%if 0%{?!scl:1}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Recommends: php-composer(fedora/autoloader)
%endif
-%endif
%description
@@ -233,10 +211,6 @@ install -d %{buildroot}%{peardir} \
%{buildroot}%{_localstatedir}/cache/php-pear \
%{buildroot}%{_localstatedir}/www/html \
%{buildroot}%{_localstatedir}/lib/pear/pkgxml \
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
- %{buildroot}%{_docdir}/pecl \
- %{buildroot}%{_datadir}/tests/pecl \
-%endif
%{buildroot}%{_sysconfdir}/pear
export INSTALL_ROOT=%{buildroot}
@@ -344,7 +318,6 @@ echo 'Test suite disabled (missing "--with tests" option)'
%endif
-%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
# Register newly installed PECL packages
%transfiletriggerin -- %{pecl_xmldir}
while read file; do
@@ -366,57 +339,6 @@ while ($file=fgets(STDIN)) {
}' | while read name; do
%{_bindir}/pecl uninstall --nodeps --ignore-errors --register-only "$name" >/dev/null || :
done
-%endif
-
-
-%if 0%{?fedora} < 25 && 0%{?rhel} < 8
-%pre
-# Manage relocation of metadata, before update to pear
-if [ -d %{peardir}/.registry -a ! -d %{metadir}/.registry ]; then
- mkdir -p %{metadir}
- mv -f %{peardir}/.??* %{metadir}
-fi
-
-
-%post
-# force new value as pear.conf is (noreplace)
-current=$(%{_bindir}/pear config-get test_dir system)
-if [ "$current" != "%{_datadir}/tests/pear" ]; then
-%{_bindir}/pear config-set \
- test_dir %{_datadir}/tests/pear \
- system >/dev/null || :
-fi
-
-current=$(%{_bindir}/pear config-get data_dir system)
-if [ "$current" != "%{_datadir}/pear-data" ]; then
-%{_bindir}/pear config-set \
- data_dir %{_datadir}/pear-data \
- system >/dev/null || :
-fi
-
-current=$(%{_bindir}/pear config-get metadata_dir system)
-if [ "$current" != "%{metadir}" ]; then
-%{_bindir}/pear config-set \
- metadata_dir %{metadir} \
- system >/dev/null || :
-fi
-
-current=$(%{_bindir}/pear config-get -c pecl doc_dir system)
-if [ "$current" != "%{_docdir}/pecl" ]; then
-%{_bindir}/pear config-set \
- -c pecl \
- doc_dir %{_docdir}/pecl \
- system >/dev/null || :
-fi
-
-current=$(%{_bindir}/pear config-get -c pecl test_dir system)
-if [ "$current" != "%{_datadir}/tests/pecl" ]; then
-%{_bindir}/pear config-set \
- -c pecl \
- test_dir %{_datadir}/tests/pecl \
- system >/dev/null || :
-fi
-%endif
%postun
@@ -448,11 +370,6 @@ fi
%doc README*
%dir %{_docdir}/pear
%doc %{_docdir}/pear/*
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-%dir %{_docdir}/pecl
-%dir %{_datadir}/tests
-%dir %{_datadir}/tests/pecl
-%endif
%{_datadir}/tests/pear
%{_datadir}/pear-data
%if 0%{?scl:1}
@@ -466,6 +383,9 @@ fi
%changelog
+* Mon Nov 25 2024 Remi Collet <remi@remirepo.net> - 1.10.16-1
+- update to 1.10.16
+
* Tue Mar 19 2024 Remi Collet <remi@remirepo.net> - 1.10.15-3
- update Structures_Graph to 1.2.0 (no change)