summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--macros.pear22
-rw-r--r--php-pear.spec7
2 files changed, 17 insertions, 12 deletions
diff --git a/macros.pear b/macros.pear
index 71aacc6..1b6ac7b 100644
--- a/macros.pear
+++ b/macros.pear
@@ -7,21 +7,21 @@
#
# Define PEAR directories used in php-pear-* spec files
#
-%pear_phpdir %(%{__pear} config-get php_dir 2> /dev/null || echo undefined)
-%pear_docdir %(%{__pear} config-get doc_dir 2> /dev/null || echo undefined)
-%pear_testdir %(%{__pear} config-get test_dir 2> /dev/null || echo undefined)
-%pear_datadir %(%{__pear} config-get data_dir 2> /dev/null || echo undefined)
-%pear_cfgdir %(%{__pear} config-get cfg_dir 2> /dev/null || echo undefined)
-%pear_wwwdir %(%{__pear} config-get www_dir 2> /dev/null || echo undefined)
-%@SCL@pear_metadir %(%{__pear} config-get metadata_dir 2> /dev/null || echo undefined)
+%pear_phpdir %(%{__pear} config-get php_dir 2> /dev/null || echo @PREFIX@/share/pear)
+%pear_docdir %(%{__pear} config-get doc_dir 2> /dev/null || echo @PREFIX@/share/doc/pear)
+%pear_testdir %(%{__pear} config-get test_dir 2> /dev/null || echo @PREFIX@/share/tests/pear)
+%pear_datadir %(%{__pear} config-get data_dir 2> /dev/null || echo @PREFIX@/share/pear-data)
+%pear_cfgdir %(%{__pear} config-get cfg_dir 2> /dev/null || echo @ETCDIR@/pear)
+%pear_wwwdir %(%{__pear} config-get www_dir 2> /dev/null || echo @VARDIR@/www/html)
+%@SCL@pear_metadir %(%{__pear} config-get metadata_dir 2> /dev/null || echo @VARDIR@/lib/pear)
#
# Define PECL directories used in php-pecl-* spec files:
#
-%pecl_phpdir %(%{__pecl} config-get php_dir 2> /dev/null || echo undefined)
-%pecl_docdir %(%{__pecl} config-get doc_dir 2> /dev/null || echo undefined)
-%pecl_testdir %(%{__pecl} config-get test_dir 2> /dev/null || echo undefined)
-%pecl_datadir %(%{__pecl} config-get data_dir 2> /dev/null || echo undefined)
+%pecl_phpdir %(%{__pecl} config-get php_dir 2> /dev/null || echo @PREFIX@/share/pear)
+%pecl_docdir %(%{__pecl} config-get doc_dir 2> /dev/null || echo @PREFIX@/share/doc/pecl)
+%pecl_testdir %(%{__pecl} config-get test_dir 2> /dev/null || echo @PREFIX@/share/tests/pecl)
+%pecl_datadir %(%{__pecl} config-get data_dir 2> /dev/null || echo @PREFIX@/share/pear-data)
#
# Define XML directories to store package registration information:
diff --git a/php-pear.spec b/php-pear.spec
index d979967..b509f0f 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -33,7 +33,7 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
Version: 1.9.5
-Release: 12%{?dist}
+Release: 13%{?dist}
Epoch: 1
# PEAR, Archive_Tar, XML_Util, Console_Getopt are BSD
# Structures_Graph is LGPLv3+
@@ -165,6 +165,8 @@ cp %{SOURCE1} %{SOURCE30} %{SOURCE31} %{SOURCE32} %{SOURCE33} .
sed -e 's/@SCL@/%{?scl:%{scl}_}/' \
-e 's:@VARDIR@:%{_localstatedir}:' \
-e 's:@BINDIR@:%{_bindir}:' \
+ -e 's:@ETCDIR@:%{_sysconfdir}:' \
+ -e 's:@PREFIX@:%{_prefix}:' \
%{SOURCE13} | tee macros.pear
@@ -398,6 +400,9 @@ fi
%changelog
+* Thu Jul 23 2015 Remi Collet <remi@fedoraproject.org> 1:1.9.5-13
+- fix default values in rpm macro file (instead of undefined)
+
* Tue Jul 21 2015 Remi Collet <remi@fedoraproject.org> 1:1.9.5-12
- update Console_Getopt to 1.4.1
- update Structures_Graph to 1.1.1