summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--install-pear.php18
-rw-r--r--php-pear-1.10-metadata.patch357
-rw-r--r--php-pear-1.10-restcache.patch27
-rw-r--r--php-pear-dev.spec53
4 files changed, 34 insertions, 421 deletions
diff --git a/install-pear.php b/install-pear.php
index 4ed36d6..3d2bb37 100644
--- a/install-pear.php
+++ b/install-pear.php
@@ -1,10 +1,8 @@
<?php
-while (@ob_end_flush());
-/* $Id$ */
error_reporting(1803);
-if (ini_get('date.timezone') === '' && function_exists('date_default_timezone_set')) {
+if (ini_get('date.timezone') === '') {
date_default_timezone_set('UTC');
}
@@ -91,6 +89,9 @@ for ($i = 0; $i < sizeof($argv); $i++) {
$debug = 1;
} elseif ($arg == '--extremedebug') {
$debug = 2;
+ } elseif ($arg == '-M' || $arg == '--man') {
+ $man_dir = $argv[$i+1];
+ $i++;
}
}
@@ -133,6 +134,11 @@ if (!empty($www_dir)) {
$config->set('www_dir', $www_dir, 'default');
}
+// Manual pages
+if (!empty($man_dir)) {
+ $config->set('man_dir', $man_dir, 'default');
+}
+
// Downloaded files
if (!empty($download_dir)) {
$config->set('download_dir', $download_dir, 'default');
@@ -162,6 +168,7 @@ if (!empty($test_dir)) {
if (!empty($with_dir)) {
$ds = DIRECTORY_SEPARATOR;
$config->set('php_dir', $with_dir, 'default');
+
// Metadata
if (!empty($metadata_dir)) {
$config->set('metadata_dir', $metadata_dir, 'default');
@@ -181,6 +188,9 @@ if (!empty($with_dir)) {
if (empty($cfg_dir)) {
$config->set('cfg_dir', $with_dir . $ds . 'cfg', 'default');
}
+ if (empty($man_dir)) {
+ $config->set('man_dir', $with_dir . $ds . 'local' . $ds . 'man', 'default');
+ }
if (!is_writable($config->get('cache_dir'))) {
include_once 'System.php';
$cdir = System::mktemp(array('-d', 'pear'));
@@ -218,7 +228,7 @@ if (isset($suffix)) {
}
}
-/* Print PEAR Conf (useful for debuging do NOT REMOVE) */
+/* Print PEAR Conf (useful for debugging do NOT REMOVE) */
if ($debug) {
sort($keys);
foreach ($keys as $key) {
diff --git a/php-pear-1.10-metadata.patch b/php-pear-1.10-metadata.patch
deleted file mode 100644
index 00b53e0..0000000
--- a/php-pear-1.10-metadata.patch
+++ /dev/null
@@ -1,357 +0,0 @@
-From e523edb6f2be7c5e672b3537e295d5007d107af8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 26 Jul 2015 08:22:52 +0200
-Subject: [PATCH 1/5] add "metadata_dir" configuration option
-
----
- PEAR/Command/Install.php | 8 +++++++-
- PEAR/Config.php | 34 +++++++++++++++++++++++++++++-----
- PEAR/DependencyDB.php | 9 ++++++---
- PEAR/Installer.php | 25 +++++++++++++++----------
- PEAR/Registry.php | 23 +++++++++++++----------
- 5 files changed, 70 insertions(+), 29 deletions(-)
-
-diff --git a/PEAR/Command/Install.php b/PEAR/Command/Install.php
-index 88c5284..87f8f17 100644
---- a/PEAR/Command/Install.php
-+++ b/PEAR/Command/Install.php
-@@ -555,7 +555,13 @@ function doInstall($command, $options, $params)
- $packrootphp_dir = $this->installer->_prependPath(
- $this->config->get('php_dir', null, 'pear.php.net'),
- $options['packagingroot']);
-- $instreg = new PEAR_Registry($packrootphp_dir); // other instreg!
-+ $metadata_dir = $this->config->get('metadata_dir', null, 'pear.php.net');
-+ if ($metadata_dir) {
-+ $metadata_dir = $this->installer->_prependPath(
-+ $metadata_dir,
-+ $options['packagingroot']);
-+ }
-+ $instreg = new PEAR_Registry($packrootphp_dir, false, false, $metadata_dir); // other instreg!
-
- if ($this->config->get('verbose') > 2) {
- $this->ui->outputData('using package root: ' . $options['packagingroot']);
-diff --git a/PEAR/Config.php b/PEAR/Config.php
-index cd2bb91..36ad988 100644
---- a/PEAR/Config.php
-+++ b/PEAR/Config.php
-@@ -86,6 +86,13 @@
- }
- }
-
-+// Default for metadata_dir
-+if (getenv('PHP_PEAR_METADATA_DIR')) {
-+ define('PEAR_CONFIG_DEFAULT_METADATA_DIR', getenv('PHP_PEAR_METADATA_DIR'));
-+} else {
-+ define('PEAR_CONFIG_DEFAULT_METADATA_DIR', '');
-+}
-+
- // Default for ext_dir
- if (getenv('PHP_PEAR_EXTENSION_DIR')) {
- define('PEAR_CONFIG_DEFAULT_EXT_DIR', getenv('PHP_PEAR_EXTENSION_DIR'));
-@@ -397,6 +404,13 @@ class PEAR_Config extends PEAR
- 'prompt' => 'PEAR directory',
- 'group' => 'File Locations',
- ),
-+ 'metadata_dir' => array(
-+ 'type' => 'directory',
-+ 'default' => PEAR_CONFIG_DEFAULT_METADATA_DIR,
-+ 'doc' => 'directory where metadata files are installed (registry, filemap, channels, ...)',
-+ 'prompt' => 'PEAR metadata directory',
-+ 'group' => 'File Locations',
-+ ),
- 'ext_dir' => array(
- 'type' => 'directory',
- 'default' => PEAR_CONFIG_DEFAULT_EXT_DIR,
-@@ -646,7 +660,9 @@ function __construct($user_file = '', $system_file = '', $ftp_file = false,
- $this->configuration['default'][$key] = $info['default'];
- }
-
-- $this->_registry['default'] = new PEAR_Registry($this->configuration['default']['php_dir']);
-+ $this->_registry['default'] = new PEAR_Registry(
-+ $this->configuration['default']['php_dir'], false, false,
-+ $this->configuration['default']['metadata_dir']);
- $this->_registry['default']->setConfig($this, false);
- $this->_regInitialized['default'] = false;
- //$GLOBALS['_PEAR_Config_instance'] = &$this;
-@@ -750,7 +766,9 @@ function readConfigFile($file = null, $layer = 'user', $strict = true)
- $this->configuration[$layer] = $data;
- $this->_setupChannels();
- if (!$this->_noRegistry && ($phpdir = $this->get('php_dir', $layer, 'pear.php.net'))) {
-- $this->_registry[$layer] = new PEAR_Registry($phpdir);
-+ $this->_registry[$layer] = new PEAR_Registry(
-+ $phpdir, false, false,
-+ $this->get('metadata_dir', $layer, 'pear.php.net'));
- $this->_registry[$layer]->setConfig($this, false);
- $this->_regInitialized[$layer] = false;
- } else {
-@@ -907,7 +925,9 @@ function mergeConfigFile($file, $override = true, $layer = 'user', $strict = tru
-
- $this->_setupChannels();
- if (!$this->_noRegistry && ($phpdir = $this->get('php_dir', $layer, 'pear.php.net'))) {
-- $this->_registry[$layer] = new PEAR_Registry($phpdir);
-+ $this->_registry[$layer] = new PEAR_Registry(
-+ $phpdir, false, false,
-+ $this->get('metadata_dir', $layer, 'pear.php.net'));
- $this->_registry[$layer]->setConfig($this, false);
- $this->_regInitialized[$layer] = false;
- } else {
-@@ -1595,7 +1615,9 @@ function _lazyChannelSetup($uselayer = false)
-
- if (!is_object($this->_registry[$layer])) {
- if ($phpdir = $this->get('php_dir', $layer, 'pear.php.net')) {
-- $this->_registry[$layer] = new PEAR_Registry($phpdir);
-+ $this->_registry[$layer] = new PEAR_Registry(
-+ $phpdir, false, false,
-+ $this->get('metadata_dir', $layer, 'pear.php.net'));
- $this->_registry[$layer]->setConfig($this, false);
- $this->_regInitialized[$layer] = false;
- } else {
-@@ -2079,7 +2101,9 @@ function setInstallRoot($root)
- continue;
- }
- $this->_registry[$layer] =
-- new PEAR_Registry($this->get('php_dir', $layer, 'pear.php.net'));
-+ new PEAR_Registry(
-+ $this->get('php_dir', $layer, 'pear.php.net'), false, false,
-+ $this->get('metadata_dir', $layer, 'pear.php.net'));
- $this->_registry[$layer]->setConfig($this, false);
- $this->_regInitialized[$layer] = false;
- }
-diff --git a/PEAR/DependencyDB.php b/PEAR/DependencyDB.php
-index 90731e3..4f633ff 100644
---- a/PEAR/DependencyDB.php
-+++ b/PEAR/DependencyDB.php
-@@ -120,8 +120,11 @@ function setConfig(&$config, $depdb = false)
-
- $this->_registry = &$this->_config->getRegistry();
- if (!$depdb) {
-- $this->_depdb = $this->_config->get('php_dir', null, 'pear.php.net') .
-- DIRECTORY_SEPARATOR . '.depdb';
-+ $dir = $this->_config->get('metadata_dir', null, 'pear.php.net');
-+ if (!$dir) {
-+ $dir = $this->_config->get('php_dir', null, 'pear.php.net');
-+ }
-+ $this->_depdb = $dir . DIRECTORY_SEPARATOR . '.depdb';
- } else {
- $this->_depdb = $depdb;
- }
-@@ -758,4 +761,4 @@ function _registerDep(&$data, &$pkg, $dep, $type, $group = false)
- );
- }
- }
--}
-\ No newline at end of file
-+}
-diff --git a/PEAR/Installer.php b/PEAR/Installer.php
-index 5bd7b58..c28167b 100644
---- a/PEAR/Installer.php
-+++ b/PEAR/Installer.php
-@@ -1128,15 +1128,6 @@ function install($pkgfile, $options = array())
-
- $pkgname = $pkg->getName();
- $channel = $pkg->getChannel();
-- if (isset($this->_options['packagingroot'])) {
-- $regdir = $this->_prependPath(
-- $this->config->get('php_dir', null, 'pear.php.net'),
-- $this->_options['packagingroot']);
--
-- $packrootphp_dir = $this->_prependPath(
-- $this->config->get('php_dir', null, $channel),
-- $this->_options['packagingroot']);
-- }
-
- if (isset($options['installroot'])) {
- $this->config->setInstallRoot($options['installroot']);
-@@ -1148,7 +1139,21 @@ function install($pkgfile, $options = array())
- $this->config->setInstallRoot(false);
- $this->_registry = &$this->config->getRegistry();
- if (isset($this->_options['packagingroot'])) {
-- $installregistry = new PEAR_Registry($regdir);
-+ $regdir = $this->_prependPath(
-+ $this->config->get('php_dir', null, 'pear.php.net'),
-+ $this->_options['packagingroot']);
-+
-+ $metadata_dir = $this->config->get('metadata_dir', null, 'pear.php.net');
-+ if ($metadata_dir) {
-+ $metadata_dir = $this->_prependPath(
-+ $metadata_dir,
-+ $this->_options['packagingroot']);
-+ }
-+ $packrootphp_dir = $this->_prependPath(
-+ $this->config->get('php_dir', null, $channel),
-+ $this->_options['packagingroot']);
-+
-+ $installregistry = new PEAR_Registry($regdir, false, false, $metadata_dir);
- if (!$installregistry->channelExists($channel, true)) {
- // we need to fake a channel-discover of this channel
- $chanobj = $this->_registry->getChannel($channel, true);
-diff --git a/PEAR/Registry.php b/PEAR/Registry.php
-index 8bad666..6103907 100644
---- a/PEAR/Registry.php
-+++ b/PEAR/Registry.php
-@@ -131,23 +131,26 @@ class PEAR_Registry extends PEAR
- * @access public
- */
- function __construct($pear_install_dir = PEAR_INSTALL_DIR, $pear_channel = false,
-- $pecl_channel = false)
-+ $pecl_channel = false, $pear_metadata_dir = '')
- {
- parent::__construct();
-- $this->setInstallDir($pear_install_dir);
-+ $this->setInstallDir($pear_install_dir, $pear_metadata_dir);
- $this->_pearChannel = $pear_channel;
- $this->_peclChannel = $pecl_channel;
- $this->_config = false;
- }
-
-- function setInstallDir($pear_install_dir = PEAR_INSTALL_DIR)
-+ function setInstallDir($pear_install_dir = PEAR_INSTALL_DIR, $pear_metadata_dir = '')
- {
- $ds = DIRECTORY_SEPARATOR;
- $this->install_dir = $pear_install_dir;
-- $this->channelsdir = $pear_install_dir.$ds.'.channels';
-- $this->statedir = $pear_install_dir.$ds.'.registry';
-- $this->filemap = $pear_install_dir.$ds.'.filemap';
-- $this->lockfile = $pear_install_dir.$ds.'.lock';
-+ if (!$pear_metadata_dir) {
-+ $pear_metadata_dir = $pear_install_dir;
-+ }
-+ $this->channelsdir = $pear_metadata_dir.$ds.'.channels';
-+ $this->statedir = $pear_metadata_dir.$ds.'.registry';
-+ $this->filemap = $pear_metadata_dir.$ds.'.filemap';
-+ $this->lockfile = $pear_metadata_dir.$ds.'.lock';
- }
-
- function hasWriteAccess()
-@@ -180,7 +183,7 @@ function setConfig(&$config, $resetInstallDir = true)
- {
- $this->_config = &$config;
- if ($resetInstallDir) {
-- $this->setInstallDir($config->get('php_dir'));
-+ $this->setInstallDir($config->get('php_dir'), $config->get('metadata_dir'));
- }
- }
-
-@@ -327,9 +330,9 @@ function _initializeDepDB()
- $this->_dependencyDB = &PEAR_DependencyDB::singleton($this->_config);
- if (PEAR::isError($this->_dependencyDB)) {
- // attempt to recover by removing the dep db
-- if (file_exists($this->_config->get('php_dir', null, 'pear.php.net') .
-+ if (file_exists($this->_config->get('metadata_dir', null, 'pear.php.net') .
- DIRECTORY_SEPARATOR . '.depdb')) {
-- @unlink($this->_config->get('php_dir', null, 'pear.php.net') .
-+ @unlink($this->_config->get('metadata_dir', null, 'pear.php.net') .
- DIRECTORY_SEPARATOR . '.depdb');
- }
-
-
-From 75856858b1a66f4e1c3c3f6cff9c6698d2967601 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 26 Jul 2015 09:04:20 +0200
-Subject: [PATCH 3/5] move metadata_dir to "File Locations (Advanced)"
-
----
- PEAR/Config.php | 15 ++++++++-------
- 1 file changed, 8 insertions(+), 7 deletions(-)
-
-diff --git a/PEAR/Config.php b/PEAR/Config.php
-index 36ad988..edb594f 100644
---- a/PEAR/Config.php
-+++ b/PEAR/Config.php
-@@ -404,13 +404,6 @@ class PEAR_Config extends PEAR
- 'prompt' => 'PEAR directory',
- 'group' => 'File Locations',
- ),
-- 'metadata_dir' => array(
-- 'type' => 'directory',
-- 'default' => PEAR_CONFIG_DEFAULT_METADATA_DIR,
-- 'doc' => 'directory where metadata files are installed (registry, filemap, channels, ...)',
-- 'prompt' => 'PEAR metadata directory',
-- 'group' => 'File Locations',
-- ),
- 'ext_dir' => array(
- 'type' => 'directory',
- 'default' => PEAR_CONFIG_DEFAULT_EXT_DIR,
-@@ -509,6 +502,14 @@ class PEAR_Config extends PEAR
- 'prompt' => 'php.ini location',
- 'group' => 'File Locations (Advanced)',
- ),
-+ 'metadata_dir' => array(
-+ 'type' => 'directory',
-+ 'default' => PEAR_CONFIG_DEFAULT_METADATA_DIR,
-+ 'doc' => 'directory where metadata files are installed (registry, filemap, channels, ...)',
-+ 'prompt' => 'PEAR metadata directory',
-+ 'group' => 'File Locations',
-+ 'group' => 'File Locations (Advanced)',
-+ ),
- // Maintainers
- 'username' => array(
- 'type' => 'string',
-
-From b81ca684ac60f62173a2958e7db06f26002fff2d Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 26 Jul 2015 09:05:04 +0200
-Subject: [PATCH 4/5] cleanup
-
----
- PEAR/Config.php | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/PEAR/Config.php b/PEAR/Config.php
-index edb594f..0c4c8e4 100644
---- a/PEAR/Config.php
-+++ b/PEAR/Config.php
-@@ -507,7 +507,6 @@ class PEAR_Config extends PEAR
- 'default' => PEAR_CONFIG_DEFAULT_METADATA_DIR,
- 'doc' => 'directory where metadata files are installed (registry, filemap, channels, ...)',
- 'prompt' => 'PEAR metadata directory',
-- 'group' => 'File Locations',
- 'group' => 'File Locations (Advanced)',
- ),
- // Maintainers
-
-From d862eea2fd1f8895f51e00b4eaea0bace0899fc5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 26 Jul 2015 10:20:00 +0200
-Subject: [PATCH 5/5] ignore already installed (in base system) when packaging
- root
-
----
- PEAR/Downloader/Package.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/PEAR/Downloader/Package.php b/PEAR/Downloader/Package.php
-index 5b2ce14..29592dc 100644
---- a/PEAR/Downloader/Package.php
-+++ b/PEAR/Downloader/Package.php
-@@ -413,7 +413,7 @@ public static function removeInstalled(&$params)
- if ($param->_installRegistry->packageExists($package, $channel)) {
- $packageVersion = $param->_installRegistry->packageInfo($package, 'version', $channel);
- if (version_compare($packageVersion, $param->getVersion(), '==')) {
-- if (!isset($options['force'])) {
-+ if (!isset($options['force']) && !isset($options['packagingroot'])) {
- $info = $param->getParsedPackage();
- unset($info['version']);
- unset($info['state']);
-From e484e87b800183d680b6830f23c8bef48d1b6ede Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 30 Jul 2015 13:37:55 +0200
-Subject: [PATCH] skip check (in base) when packagingroot used (different tree)
-
----
- PEAR/Downloader/Package.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/PEAR/Downloader/Package.php b/PEAR/Downloader/Package.php
-index 29592dc..70ea8c3 100644
---- a/PEAR/Downloader/Package.php
-+++ b/PEAR/Downloader/Package.php
-@@ -425,7 +425,7 @@ public static function removeInstalled(&$params)
- $params[$i] = false;
- }
- } elseif (!isset($options['force']) && !isset($options['upgrade']) &&
-- !isset($options['soft'])) {
-+ !isset($options['soft']) && !isset($options['packagingroot'])) {
- $info = $param->getParsedPackage();
- $param->_downloader->log(1, 'Skipping package "' .
- $param->getShortName() .
diff --git a/php-pear-1.10-restcache.patch b/php-pear-1.10-restcache.patch
deleted file mode 100644
index 40d129f..0000000
--- a/php-pear-1.10-restcache.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From fccb285ce442c710d9795d2a102b229799de4922 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sun, 26 Jul 2015 08:08:23 +0200
-Subject: [PATCH] allow pear to work when cache_dir is not writable
-
----
- PEAR/REST.php | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/PEAR/REST.php b/PEAR/REST.php
-index c5ed192..1e472b7 100644
---- a/PEAR/REST.php
-+++ b/PEAR/REST.php
-@@ -235,6 +235,13 @@ function saveCache($url, $contents, $lastmodified, $nochange = false, $cacheid =
- }
- }
-
-+ if (!is_writeable($cache_dir)) {
-+ // If writing to the cache dir is not going to work, silently do nothing.
-+ // An ugly hack, but retains compat with PEAR 1.9.1 where many commands
-+ // work fine as non-root user (w/out write access to default cache dir).
-+ return true;
-+ }
-+
- if ($cacheid === null && $nochange) {
- $cacheid = unserialize(implode('', file($cacheidfile)));
- }
diff --git a/php-pear-dev.spec b/php-pear-dev.spec
index d29e41d..e3e37a4 100644
--- a/php-pear-dev.spec
+++ b/php-pear-dev.spec
@@ -15,12 +15,14 @@
%global peardir %{_datadir}/pear
%global metadir %{_localstatedir}/lib/pear
+
%global getoptver 1.4.1
%global arctarver 1.4.0
# https://pear.php.net/bugs/bug.php?id=19367
# Structures_Graph 1.0.4 - incorrect FSF address
%global structver 1.1.1
%global xmlutil 1.3.0
+%global manpages 1.10.0dev2
# Tests are only run with rpmbuild --with tests
# Can't be run in mock / koji because PEAR is the first package
@@ -28,14 +30,14 @@
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_root_sysconfdir}/rpm; echo $d)
-%global pearprever dev1
+%global pearprever dev2
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
Version: 1.10.0
-Release: 0.4.%{pearprever}%{?dist}
+Release: 0.5.%{pearprever}%{?dist}
Epoch: 1
-# PEAR, Archive_Tar, XML_Util, Console_Getopt are BSD
+# PEAR, PEAR_Manpages, Archive_Tar, XML_Util, Console_Getopt are BSD
# Structures_Graph is LGPLv3+
License: BSD and LGPLv3+
Group: Development/Languages
@@ -52,22 +54,7 @@ Source21: http://pear.php.net/get/Archive_Tar-%{arctarver}.tgz
Source22: http://pear.php.net/get/Console_Getopt-%{getoptver}.tgz
Source23: http://pear.php.net/get/Structures_Graph-%{structver}.tgz
Source24: http://pear.php.net/get/XML_Util-%{xmlutil}.tgz
-# Man pages
-# https://github.com/pear/pear-core/pull/14
-Source30: pear.1
-Source31: pecl.1
-Source32: peardev.1
-# https://github.com/pear/pear-core/pull/16
-Source33: pear.conf.5
-
-# From RHEL: ignore REST cache creation failures as non-root user (#747361)
-# TODO See https://github.com/pear/pear-core/commit/dfef86e05211d2abc7870209d69064d448ef53b3#PEAR/REST.php
-# https://github.com/pear/pear-core/pull/42
-Patch0: php-pear-1.10-restcache.patch
-# Relocate Metadata
-# https://github.com/pear/pear-core/pull/44
-# https://github.com/pear/pear-core/pull/45
-Patch1: php-pear-1.10-metadata.patch
+Source25: http://pear.php.net/get/PEAR_Manpages-%{manpages}.tgz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -87,6 +74,7 @@ Provides: %{?scl_prefix}php-pear(Archive_Tar) = %{arctarver}
Provides: %{?scl_prefix}php-pear(PEAR) = %{version}
Provides: %{?scl_prefix}php-pear(Structures_Graph) = %{structver}
Provides: %{?scl_prefix}php-pear(XML_Util) = %{xmlutil}
+Provides: %{?scl_prefix}php-pear(PEAR_Manpages) = %{manpages}
Provides: %{?scl_prefix}php-composer(pear/console_getopt) = %{getoptver}
Provides: %{?scl_prefix}php-composer(pear/archive_tar) = %{arctarver}
@@ -152,7 +140,7 @@ components. This package contains the basic PEAR components.
%setup -cT
# Create a usable PEAR directory (used by install-pear.php)
-for archive in %{SOURCE0} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24}
+for archive in %{SOURCE0} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} %{SOURCE25}
do
tar xzf $archive --strip-components 1 || tar xzf $archive --strip-path 1
file=${archive##*/}
@@ -163,11 +151,10 @@ do
[ -f package2.xml ] && mv package2.xml ${file%%-*}.xml \
|| mv package.xml ${file%%-*}.xml
done
-cp %{SOURCE1} %{SOURCE30} %{SOURCE31} %{SOURCE32} %{SOURCE33} .
+cp %{SOURCE1} .
# apply patches on used PEAR during install
-%patch0 -p1 -b .rest
-%patch1 -p1 -b .metadata
+# None \o/
sed -e 's/@SCL@/%{?scl:%{scl}_}/' \
-e 's:@VARDIR@:%{_localstatedir}:' \
@@ -219,7 +206,8 @@ export INSTALL_ROOT=$RPM_BUILD_ROOT
--test %{_datadir}/tests/pear \
--data %{_datadir}/pear-data \
--metadata %{metadir} \
- %{SOURCE0} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24}
+ --man %{_mandir} \
+ %{SOURCE0} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} %{SOURCE25}
# Replace /usr/bin/* with simple scripts:
install -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pear
@@ -243,8 +231,7 @@ install -m 644 -D macros.pear \
# apply patches on installed PEAR tree
pushd $RPM_BUILD_ROOT%{peardir}
- %__patch --no-backup --fuzz 0 -p1 < %{PATCH0}
- %__patch --no-backup --fuzz 0 -p1 < %{PATCH1}
+# none
popd
# Why this file here ?
@@ -253,12 +240,6 @@ rm -rf $RPM_BUILD_ROOT/.depdb* $RPM_BUILD_ROOT/.lock $RPM_BUILD_ROOT/.channels $
# Need for re-registrying XML_Util
install -pm 644 *.xml $RPM_BUILD_ROOT%{_localstatedir}/lib/pear/pkgxml
-# The man pages
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-install -p -m 644 pear.1 pecl.1 peardev.1 $RPM_BUILD_ROOT%{_mandir}/man1/
-install -d $RPM_BUILD_ROOT%{_mandir}/man5
-install -p -m 644 pear.conf.5 $RPM_BUILD_ROOT%{_mandir}/man5/
-
# make the cli commands available in standard root for SCL build
%if 0%{?scl:1}
install -m 755 -d $RPM_BUILD_ROOT%{_root_bindir}
@@ -405,6 +386,12 @@ fi
%changelog
+* Fri Jul 31 2015 Remi Collet <remi@fedoraproject.org> 1:1.10.0-0.5.dev2
+- update PEAR to 1.10.0dev2
+- drop all patches, merged upstream
+- drop man pages from sources
+- add PEAR_Manpages upstream package
+
* Thu Jul 30 2015 Remi Collet <remi@fedoraproject.org> 1:1.10.0-0.4.dev1
- add patch to skip version check with --packagingroot
- open https://github.com/pear/pear-core/pull/45
@@ -418,7 +405,7 @@ fi
- open https://github.com/pear/pear-core/pull/44
* Sat Jul 25 2015 Remi Collet <remi@fedoraproject.org> 1:1.10.0-0.1.dev1
-- update PEAR 1.10.0dev1 (for PHP7)
+- update PEAR to 1.10.0dev1 (for PHP7)
* Thu Jul 23 2015 Remi Collet <remi@fedoraproject.org> 1:1.9.5-13
- fix default values in rpm macro file (instead of undefined)