diff options
-rw-r--r-- | pear.sh | 2 | ||||
-rw-r--r-- | pecl.sh | 2 | ||||
-rw-r--r-- | php-pear.spec | 5 |
3 files changed, 6 insertions, 3 deletions
@@ -1,6 +1,6 @@ #!/bin/sh EXT="-d extension=posix.so" -DIR=$(/usr/bin/php -r 'echo ini_get("extension_dir");') +DIR=$(/usr/bin/php -n -r 'echo ini_get("extension_dir");') if [ -f $DIR/xml.so ] ; then EXT="$EXT -d extension=xml.so" fi @@ -1,6 +1,6 @@ #!/bin/sh EXT="-d extension=posix.so" -DIR=$(/usr/bin/php -r 'echo ini_get("extension_dir");') +DIR=$(/usr/bin/php -n -r 'echo ini_get("extension_dir");') if [ -f $DIR/xml.so ] ; then EXT="$EXT -d extension=xml.so" fi diff --git a/php-pear.spec b/php-pear.spec index 0ececc9..3524c50 100644 --- a/php-pear.spec +++ b/php-pear.spec @@ -17,7 +17,7 @@ Summary: PHP Extension and Application Repository framework Name: php-pear Version: 1.9.4 -Release: 26%{?dist} +Release: 26%{?dist}.1 Epoch: 1 # PEAR, Archive_Tar, XML_Util are BSD # Console_Getopt is PHP @@ -322,6 +322,9 @@ fi %changelog +* Thu Apr 10 2014 Remi Collet <rcollet@redhat.com> 1:1.9.4-26.1 +- better fix to detect xml.so + * Thu Apr 10 2014 Remi Collet <rcollet@redhat.com> 1:1.9.4-26 - fix xml.so is shared only with php 5.5+ |