summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-10 19:12:35 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-10 19:12:35 +0200
commit1af327c9e25653904943a318747dcfc24ec6531c (patch)
tree832605b1e2cbb79d9b9518cf18b4d13a5119986d
parent1d23576a710a154a650068969d285256bb45482e (diff)
php-pear: better fix to detect xml.so
-rw-r--r--pear.sh2
-rw-r--r--pecl.sh2
-rw-r--r--php-pear.spec5
3 files changed, 6 insertions, 3 deletions
diff --git a/pear.sh b/pear.sh
index 1847471..d0f10ed 100644
--- a/pear.sh
+++ b/pear.sh
@@ -1,6 +1,6 @@
#!/bin/sh
EXT="-d extension=posix.so"
-DIR=$(/usr/bin/php -r 'echo ini_get("extension_dir");')
+DIR=$(/usr/bin/php -n -r 'echo ini_get("extension_dir");')
if [ -f $DIR/xml.so ] ; then
EXT="$EXT -d extension=xml.so"
fi
diff --git a/pecl.sh b/pecl.sh
index cb55ef9..fbb999a 100644
--- a/pecl.sh
+++ b/pecl.sh
@@ -1,6 +1,6 @@
#!/bin/sh
EXT="-d extension=posix.so"
-DIR=$(/usr/bin/php -r 'echo ini_get("extension_dir");')
+DIR=$(/usr/bin/php -n -r 'echo ini_get("extension_dir");')
if [ -f $DIR/xml.so ] ; then
EXT="$EXT -d extension=xml.so"
fi
diff --git a/php-pear.spec b/php-pear.spec
index 0ececc9..3524c50 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -17,7 +17,7 @@
Summary: PHP Extension and Application Repository framework
Name: php-pear
Version: 1.9.4
-Release: 26%{?dist}
+Release: 26%{?dist}.1
Epoch: 1
# PEAR, Archive_Tar, XML_Util are BSD
# Console_Getopt is PHP
@@ -322,6 +322,9 @@ fi
%changelog
+* Thu Apr 10 2014 Remi Collet <rcollet@redhat.com> 1:1.9.4-26.1
+- better fix to detect xml.so
+
* Thu Apr 10 2014 Remi Collet <rcollet@redhat.com> 1:1.9.4-26
- fix xml.so is shared only with php 5.5+