summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--php-pear.spec73
2 files changed, 60 insertions, 15 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/php-pear.spec b/php-pear.spec
index e8488be..96304e6 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -20,7 +20,7 @@
%global metadir %{_localstatedir}/lib/pear
%global getoptver 1.4.3
-%global arctarver 1.4.9
+%global arctarver 1.5.0
# https://pear.php.net/bugs/bug.php?id=19367
# Structures_Graph 1.0.4 - incorrect FSF address
%global structver 1.1.1
@@ -29,7 +29,7 @@
# Tests are only run with rpmbuild --with tests
# Can't be run in mock / koji because PEAR is the first package
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_root_sysconfdir}/rpm; echo $d)
@@ -39,12 +39,13 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
-Version: 1.10.12
-Release: 1%{?dist}
+Version: 1.10.15
+Release: 2%{?dist}
Epoch: 1
-# PEAR, PEAR_Manpages, Archive_Tar, XML_Util, Console_Getopt are BSD
-# Structures_Graph is LGPLv3+
-License: BSD and LGPLv3+
+# BSD-2-Clause: PEAR, PEAR_Manpages, Archive_Tar, Console_Getopt
+# BSD-3-Clause: XML_Util
+# LGPL-3.0-or-later: Structures_Graph
+License: BSD-2-Clause AND BSD-3-Clause AND LGPL-3.0-or-later
URL: http://pear.php.net/package/PEAR
Source0: http://download.pear.php.net/package/PEAR-%{version}%{?pearprever}.tgz
# wget https://raw.githubusercontent.com/pear/pear-core/stable/install-pear.php
@@ -68,7 +69,7 @@ BuildRequires: %{?scl_prefix}php-xml
BuildRequires: %{_root_bindir}/gpg
# For pecl_xmldir macro
BuildRequires: %{?scl_prefix}php-devel
-%if %{with_tests}
+%if %{with tests}
BuildRequires: %{_bindir}/phpunit
%endif
%if 0%{?!scl:1}
@@ -98,7 +99,7 @@ Provides: %{?scl_prefix}php-autoloader(pear/structures_graph) = %{structver}
Provides: %{?scl_prefix}php-autoloader(pear/xml_util) = %{xmlutil}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# From other third party
Obsoletes: php53-pear <= %{epoch}:%{version}
Obsoletes: php53u-pear <= %{epoch}:%{version}
@@ -146,7 +147,9 @@ Requires: httpd-filesystem
%global with_html_dir 1
%endif
%if 0%{?!scl:1}
-Requires: php-composer(fedora/autoloader)
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Recommends: php-composer(fedora/autoloader)
+%endif
%endif
@@ -277,11 +280,11 @@ install -m 644 -D macros.pear \
# apply patches on installed PEAR tree
pushd %{buildroot}%{peardir}
-: no patch
+ : none
popd
# Why this file here ?
-rm -rf %{buildroot}/.depdb* %{buildroot}/.lock %{buildroot}/.channels $RPM_BUILD_ROOT/.filemap
+rm -rf %{buildroot}/.depdb* %{buildroot}/.lock %{buildroot}/.channels %{buildroot}/.filemap
# Need for re-registrying XML_Util
install -pm 644 *.xml %{buildroot}%{_localstatedir}/lib/pear/pkgxml
@@ -310,7 +313,7 @@ grep /usr/local %{buildroot}%{_sysconfdir}/pear.conf && exit 1
grep -rl %{buildroot} %{buildroot} && exit 1
-%if %{with_tests}
+%if %{with tests}
cp /etc/php.ini .
echo "include_path=.:%{buildroot}%{peardir}:/usr/share/php" >>php.ini
export PHPRC=$PWD/php.ini
@@ -462,12 +465,52 @@ fi
%changelog
-* Mon Apr 20 2020 Remi Collet <remi@remirepo.net> - 1.10.12-1
+* Tue Mar 19 2024 Remi Collet <remi@remirepo.net> - 1.10.15-2
+- update Archive_Tar to 1.5.0
+
+* Mon Mar 11 2024 Remi Collet <remi@remirepo.net> - 1.10.15-1
+- update to 1.10.15
+
+* Mon Nov 27 2023 Remi Collet <remi@remirepo.net> - 1.10.14-1
+- update to 1.10.14
+- drop patches merged upstream
+
+* Thu Nov 23 2023 Remi Collet <remi@remirepo.net> - 1.10.13-7
+- fix more deprecations from
+ https://github.com/pear/pear-core/pull/127
+
+* Mon Feb 20 2023 Remi Collet <remi@remirepo.net> - 1.10.13-5
+- fix PHP 8.2 deprecations using patch from
+ https://github.com/pear/pear-core/pull/124
+- use SPDX license IDs
+
+* Wed Aug 11 2021 Remi Collet <remi@remirepo.net> - 1.10.13-1
+- update to 1.10.13
+
+* Wed Jul 21 2021 Remi Collet <remi@remirepo.net> - 1:1.10.12-9
+- update Archive_Tar to 1.4.14
+
+* Fri Jun 18 2021 Remi Collet <remi@remirepo.net> - 1:1.10.12-8
+- fedora/autoloader is optional
+
+* Mon May 10 2021 Remi Collet <remi@remirepo.net> - 1:1.10.12-7
+- update Archive_Tar to 1.4.13
+
+* Tue Jan 19 2021 Remi Collet <remi@remirepo.net> - 1:1.10.12-5
+- update Archive_Tar to 1.4.12
+
+* Mon Nov 23 2020 Remi Collet <remi@remirepo.net> - 1:1.10.12-4
+- update Archive_Tar to 1.4.11
+
+* Wed Sep 16 2020 Remi Collet <remi@remirepo.net> - 1:1.10.12-2
+- update Archive_Tar to 1.4.10
+
+* Mon Apr 20 2020 Remi Collet <remi@remirepo.net> - 1:1.10.12-1
- update PEAR to 1.10.12
- update XML_Util to 1.4.5
- drop patch merged upstream
-* Sat Apr 11 2020 Remi Collet <remi@remirepo.net> - 1.10.11-1
+* Sat Apr 11 2020 Remi Collet <remi@remirepo.net> - 1:1.10.11-1
- update to 1.10.11
- drop patch merged upstream